summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/python-distutils-extra/python-distutils-extra.SlackBuild12
-rw-r--r--python/python-distutils-extra/python-distutils-extra.info6
2 files changed, 9 insertions, 9 deletions
diff --git a/python/python-distutils-extra/python-distutils-extra.SlackBuild b/python/python-distutils-extra/python-distutils-extra.SlackBuild
index 22d487c34a..1109d09f63 100644
--- a/python/python-distutils-extra/python-distutils-extra.SlackBuild
+++ b/python/python-distutils-extra/python-distutils-extra.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-distutils-extra
-VERSION=${VERSION:-2.38}
+VERSION=${VERSION:-2.39}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,14 +50,14 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/python-distutils-extra/python-distutils-extra.info b/python/python-distutils-extra/python-distutils-extra.info
index 60217d0cea..925246eebf 100644
--- a/python/python-distutils-extra/python-distutils-extra.info
+++ b/python/python-distutils-extra/python-distutils-extra.info
@@ -1,8 +1,8 @@
PRGNAM="python-distutils-extra"
-VERSION="2.38"
+VERSION="2.39"
HOMEPAGE="https://launchpad.net/python-distutils-extra"
-DOWNLOAD="https://launchpad.net/python-distutils-extra/trunk/2.38/+download/python-distutils-extra-2.38.tar.gz"
-MD5SUM="4e4c9bee92a3ca8bfd915f3adcf14648"
+DOWNLOAD="https://launchpad.net/python-distutils-extra/trunk/2.39/+download/python-distutils-extra-2.39.tar.gz"
+MD5SUM="16e06db0ef73a35b4bff4b9eed5699b5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""