summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/python-scandir/README13
-rw-r--r--python/python-scandir/python-scandir.SlackBuild86
-rw-r--r--python/python-scandir/python-scandir.info10
-rw-r--r--python/python-scandir/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/python/python-scandir/README b/python/python-scandir/README
new file mode 100644
index 0000000000..7fcbf2782f
--- /dev/null
+++ b/python/python-scandir/README
@@ -0,0 +1,13 @@
+scandir, a better directory iterator and faster os.walk()
+
+scandir() is a generator version of os.listdir() that returns
+an iterator over files in a directory, and also exposes the
+extra information most OSes provide while iterating files in a
+directory (such as type and stat information).
+
+This module also includes a version of os.walk() that uses
+scandir() to speed it up significantly.
+
+NOTE: If you’re using Python version 3.5+, os.scandir() and the
+speed improvements to os.walk() are already available in the
+standard library.
diff --git a/python/python-scandir/python-scandir.SlackBuild b/python/python-scandir/python-scandir.SlackBuild
new file mode 100644
index 0000000000..1eae126459
--- /dev/null
+++ b/python/python-scandir/python-scandir.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for python-scandir
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-scandir
+SRCNAM=$(echo $PRGNAM | cut -c8-15)
+VERSION=${VERSION:-1.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-scandir/python-scandir.info b/python/python-scandir/python-scandir.info
new file mode 100644
index 0000000000..027dfdd551
--- /dev/null
+++ b/python/python-scandir/python-scandir.info
@@ -0,0 +1,10 @@
+PRGNAM="python-scandir"
+VERSION="1.2"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+DOWNLOAD="https://pypi.python.org/packages/source/s/scandir/scandir-1.2.tar.gz"
+MD5SUM="3a317b482128e072f6cfb3bb2ce52e06"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-scandir/slack-desc b/python/python-scandir/slack-desc
new file mode 100644
index 0000000000..74c9308f89
--- /dev/null
+++ b/python/python-scandir/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-scandir: python-scandir (directory iterator)
+python-scandir:
+python-scandir: scandir, a better directory iterator and faster os.walk().
+python-scandir: scandir() is a generator version of os.listdir() that returns an
+python-scandir: iterator over files in a directory, and also exposes the extra
+python-scandir: information most OSes provide while iterating files in a directory
+python-scandir: (such as type and stat information).
+python-scandir:
+python-scandir: Homepage: https://github.com/benhoyt/scandir
+python-scandir:
+python-scandir: