summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/easygui/README15
-rw-r--r--python/easygui/easygui.SlackBuild88
-rw-r--r--python/easygui/easygui.info10
-rw-r--r--python/easygui/slack-desc19
4 files changed, 132 insertions, 0 deletions
diff --git a/python/easygui/README b/python/easygui/README
new file mode 100644
index 0000000000..b3192eb373
--- /dev/null
+++ b/python/easygui/README
@@ -0,0 +1,15 @@
+easygui is a module for very simple, very easy GUI programming in Python.
+Experienced Pythonistas need support for quick and dirty GUI features.
+New Python programmers need GUI capabilities that don't require any
+knowledge of Tkinter, frames, widgets, callbacks or lambda. This is
+what easygui provides. Using it, all GUI interactions are invoked
+by simple function calls.
+
+easygui is different from other GUIs in that it is NOT event-driven.
+It allows you to program in a traditional linear fashion, and to put up
+dialogs for simple input and output when you need to do so. If you have
+not yet learned the event-driven paradigm for GUI programming, easygui will
+allow you to be productive with very basic tasks immediately. If you later
+wish to make the transition to an event-driven GUI paradigm, you can move
+to an event-driven style with a more powerful GUI package such as anygui,
+PythonCard, Tkinter, wxPython, etcetera.
diff --git a/python/easygui/easygui.SlackBuild b/python/easygui/easygui.SlackBuild
new file mode 100644
index 0000000000..25dfad377a
--- /dev/null
+++ b/python/easygui/easygui.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for easygui
+
+# Copyright 2007-2011 LukenShiro, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=easygui
+VERSION=${VERSION:-0.96}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+SRC_VERSION=version_${VERSION}_docs
+
+if [ "$ARCH" = "i486" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# directory for python packages
+PYTHONDIR=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
+DOCFILES="cookbook faq epydoc pydoc tutorial"
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir -p $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${SRC_VERSION}.tar.gz
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# install .py source file and sample file
+python ./setup.py build install --root=$PKG
+
+# Copy documentation files
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+for docdir in $DOCFILES ; do mv $docdir $PKG/usr/doc/$PRGNAM-$VERSION/ ; done
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/easygui/easygui.info b/python/easygui/easygui.info
new file mode 100644
index 0000000000..9b5c5fd618
--- /dev/null
+++ b/python/easygui/easygui.info
@@ -0,0 +1,10 @@
+PRGNAM="easygui"
+VERSION="0.96"
+HOMEPAGE="http://easygui.sourceforge.net/"
+DOWNLOAD="http://easygui.sourceforge.net/download/version_0.96/easygui_version_0.96_docs.tar.gz"
+MD5SUM="2b97ebdee114e8723e84ef542506ddf2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
diff --git a/python/easygui/slack-desc b/python/easygui/slack-desc
new file mode 100644
index 0000000000..7296a7dbf9
--- /dev/null
+++ b/python/easygui/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+easygui: easygui (very easy GUI programming in python on top of Tkinter)
+easygui:
+easygui: It provides an easy-to-use interface for simple GUI interaction with
+easygui: a user. It does not require the programmer to know anything about
+easygui: tkinter, frames, widgets, callbacks or lambda.
+easygui: All GUI interactions are invoked by simple function calls that return
+easygui: results. It is written by Stephen Ferg.
+easygui:
+easygui: Homepage: http://easygui.sourceforge.net
+easygui:
+easygui: