summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/snuggs/snuggs.SlackBuild8
-rw-r--r--python/snuggs/snuggs.info8
2 files changed, 7 insertions, 9 deletions
diff --git a/python/snuggs/snuggs.SlackBuild b/python/snuggs/snuggs.SlackBuild
index 37e474ef39..0e72249f11 100644
--- a/python/snuggs/snuggs.SlackBuild
+++ b/python/snuggs/snuggs.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=snuggs
-VERSION=${VERSION:-1.4.3}
+VERSION=${VERSION:-1.4.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,10 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/snuggs/snuggs.info b/python/snuggs/snuggs.info
index a2660e1848..e42cfc4551 100644
--- a/python/snuggs/snuggs.info
+++ b/python/snuggs/snuggs.info
@@ -1,10 +1,10 @@
PRGNAM="snuggs"
-VERSION="1.4.3"
+VERSION="1.4.7"
HOMEPAGE="https://github.com/mapbox/snuggs"
-DOWNLOAD="https://github.com/mapbox/snuggs/archive/1.4.3/snuggs-1.4.3.tar.gz"
-MD5SUM="e76ccbd05e486d12ac8610de5ed88f47"
+DOWNLOAD="https://github.com/mapbox/snuggs/archive/1.4.7/snuggs-1.4.7.tar.gz"
+MD5SUM="28633274352aa2149b4d490c1e883a2a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="click numpy pyparsing"
+REQUIRES="click numpy numpy3 pyparsing python3-pyparsing"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"