summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/backlash/README8
-rw-r--r--python/backlash/backlash.SlackBuild69
-rw-r--r--python/backlash/backlash.info10
-rw-r--r--python/backlash/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/python/backlash/README b/python/backlash/README
new file mode 100644
index 0000000000..731ed822c1
--- /dev/null
+++ b/python/backlash/README
@@ -0,0 +1,8 @@
+Backlash supports both debugging applications on crash and realtime console, both are based on the Werkzeug Debugger and adapted to work with WebOb.
+
+backlash is a swiss army knife for web applications debugging, which provides:
+ An Interactive In Browser Debugger based on a Werkzeug Debugger fork ported to WebOb
+ Crash reporting by email and on Sentry
+ Slow requests reporting by email and on Sentry.
+
+Backlash was born as a replacement for WebError in TurboGears2.3 versions.
diff --git a/python/backlash/backlash.SlackBuild b/python/backlash/backlash.SlackBuild
new file mode 100644
index 0000000000..4f62b1c1c8
--- /dev/null
+++ b/python/backlash/backlash.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# SlackBuild script for backlash.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=backlash
+VERSION=${VERSION:-0.1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/backlash/backlash.info b/python/backlash/backlash.info
new file mode 100644
index 0000000000..002c78a87c
--- /dev/null
+++ b/python/backlash/backlash.info
@@ -0,0 +1,10 @@
+PRGNAM="backlash"
+VERSION="0.1.4"
+HOMEPAGE="https://github.com/TurboGears/backlash"
+DOWNLOAD="https://pypi.python.org/packages/source/b/backlash/backlash-0.1.4.tar.gz"
+MD5SUM="13799d406a98bfdcf1937df7f846590a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="WebOb"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/backlash/slack-desc b/python/backlash/slack-desc
new file mode 100644
index 0000000000..e894d36372
--- /dev/null
+++ b/python/backlash/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+backlash: backlash (Python Module)
+backlash:
+backlash: Standalone WebOb port of the Werkzeug Debugger with Python3 support
+backlash: born as a WebError replacement for TurboGears2.
+backlash:
+backlash: backlash is a swiss army knife for web applications debugging,
+backlash: which provides:
+backlash: * An Interactive In Browser Debugger based on a Werkzeug Debugger
+backlash: fork ported to WebOb
+backlash: * Crash reporting by email and on Sentry
+backlash: * Slow requests reporting by email and on Sentry.