summaryrefslogtreecommitdiffstats
path: root/system/ds4drv
diff options
context:
space:
mode:
Diffstat (limited to 'system/ds4drv')
-rw-r--r--system/ds4drv/ds4drv.SlackBuild9
-rw-r--r--system/ds4drv/ds4drv.info8
2 files changed, 7 insertions, 10 deletions
diff --git a/system/ds4drv/ds4drv.SlackBuild b/system/ds4drv/ds4drv.SlackBuild
index f3a1f1bafd..1f52788d85 100644
--- a/system/ds4drv/ds4drv.SlackBuild
+++ b/system/ds4drv/ds4drv.SlackBuild
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ds4drv
-VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-0.5.1}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +76,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/system/ds4drv/ds4drv.info b/system/ds4drv/ds4drv.info
index e55f01ed87..be7856c083 100644
--- a/system/ds4drv/ds4drv.info
+++ b/system/ds4drv/ds4drv.info
@@ -1,10 +1,10 @@
PRGNAM="ds4drv"
-VERSION="0.5.0"
+VERSION="0.5.1"
HOMEPAGE="https://github.com/chrippa/ds4drv"
-DOWNLOAD="https://pypi.python.org/packages/source/d/ds4drv/ds4drv-0.5.0.tar.gz"
-MD5SUM="705d48f45634f9dbd3f40c8876fb2c96"
+DOWNLOAD="https://github.com/chrippa/ds4drv/archive/v0.5.1/ds4drv-0.5.1.tar.gz"
+MD5SUM="5a116106debdaaaed138d337282e1985"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pyudev python-evdev"
+REQUIRES="python3-pyudev python3-evdev"
MAINTAINER="Dugan Chen"
EMAIL="thedoogster [at] gmail [dot] com"