summaryrefslogtreecommitdiffstats
path: root/system/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2.SlackBuild')
-rw-r--r--system/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2.SlackBuild45
1 files changed, 24 insertions, 21 deletions
diff --git a/system/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2.SlackBuild b/system/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2.SlackBuild
index c36ea40bb9..dd98940f61 100644
--- a/system/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2.SlackBuild
+++ b/system/epson-inkjet-printer-escpr2/epson-inkjet-printer-escpr2.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for escpr2
-# Copyright 2018-2022 Tim Dickson
+# Copyright 2018-2023 Tim Dickson
# All rights reserved.
#
# thanks to Ruben Schuller for escpr slack build, which this is
@@ -27,15 +27,16 @@
#note to self. paste list of supported models into first line of empty README.models
#file. run sh ./fixrm to spread the model list evenly over as many lines as needed
-#also request upload of source to slackbuildsdirectlinks.
+#also upload source to slackbuildsdirectlinks, as epson keeps changing the url
+#of their own download link.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=epson-inkjet-printer-escpr2
-VERSION=${VERSION:-1.1.48}
-EXTRABIT=1lsb3.2
+VERSION=${VERSION:-1.2.9}
+EXTRABIT=1
TARNAM=$PRGNAM-$VERSION-$EXTRABIT.tar.gz
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -47,23 +48,13 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-#lets get the source tarball from the rpm and clean up the bits we don't need
-rpm2tgz $PRGNAM-$VERSION-$EXTRABIT.src.rpm
-tar -xzf $PRGNAM-$VERSION-$EXTRABIT.src.tgz
-cp $PRGNAM-$VERSION-$EXTRABIT/$PRGNAM-$VERSION-$EXTRABIT.tar.gz ./
-rm $PRGNAM-$VERSION-$EXTRABIT.src.tgz
-rm -r $PRGNAM-$VERSION-$EXTRABIT
-rm -f lsb-rpm.spec
-
TMP=${TMP:-/tmp/SBo}
+EXTRACTTMP=${TMP}/epson-inkjet-printer-escpr2-src
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -84,13 +75,23 @@ fi
set -e
rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
+mkdir -p $TMP $PKG $OUTPUT $EXTRACTTMP
+#lets get the source tarball from the rpm and clean up the bits we don't need
+cd $EXTRACTTMP
+rpm2tgz $CWD/$PRGNAM-$VERSION-$EXTRABIT.src.rpm
+tar -xzf $PRGNAM-$VERSION-$EXTRABIT.src.tgz
+#fix for dave and others whose rpm2tgz behaves differently. :-)
+if [ -e $PRGNAM-$VERSION-$EXTRABIT/$PRGNAM-$VERSION-$EXTRABIT.tar.gz ]; then
+ cp $PRGNAM-$VERSION-$EXTRABIT/$PRGNAM-$VERSION-$EXTRABIT.tar.gz ./
+fi
+rm -f $PRGNAM-$VERSION-$EXTRABIT.src.tgz
+rm -rf $PRGNAM-$VERSION-$EXTRABIT
+rm -f lsb-rpm.spec
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$TARNAM
-#we remove the tarnam as the original is an rpm
-#this keeps things tidy.
-rm $CWD/$TARNAM
+tar xvf $EXTRACTTMP/$TARNAM
+#lets remove our temp extraction directory
+rm -rf $EXTRACTTMP
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -118,7 +119,9 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+#fix ownership of licence file.
cp -a $CWD/LICENCE.html COPYING COPYING.EPSON COPYING.LIB README AUTHORS ChangeLog NEWS $PKG/usr/doc/$PRGNAM-$VERSION
+chown root:root $PKG/usr/doc/$PRGNAM-$VERSION/LICENCE.html
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
rm -f $PKG/usr/lib*/*.la