summaryrefslogtreecommitdiffstats
path: root/system/localepurge/localepurge.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/localepurge/localepurge.SlackBuild')
-rw-r--r--system/localepurge/localepurge.SlackBuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/system/localepurge/localepurge.SlackBuild b/system/localepurge/localepurge.SlackBuild
index 4afa7e26f5..a2619e8c5f 100644
--- a/system/localepurge/localepurge.SlackBuild
+++ b/system/localepurge/localepurge.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for localepurge.
#
-# Copyright 2016-2018 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2016-2021 Edinaldo P. Silva, Rio de Janeiro, Brazil.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=localepurge
-VERSION=${VERSION:-0.7.3.5}
+VERSION=${VERSION:-0.7.3.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,10 +72,6 @@ find -L . \
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-patch -uN usr/sbin/localepurge < $CWD/localepurge.diff
-patch -uN debian/localepurge.8 < $CWD/localepurge.8.diff
-patch -uN debian/localepurge.config < $CWD/localepurge.config.diff
-
install -D -m755 usr/sbin/localepurge $PKG/usr/bin/localepurge
install -D -m644 debian/localepurge.8 $PKG/usr/man/man8/localepurge.8
install -D -m755 debian/localepurge.config $PKG/usr/bin/localepurge-config
@@ -92,10 +88,10 @@ install -D -m644 $CWD/localelist $PKG/var/cache/localepurge/localelist
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-DOCS="debian/NEWS.Debian debian/README.Debian debian/changelog debian/copyright"
+DOCS="debian/README.Debian debian/changelog debian/copyright"
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install