summaryrefslogtreecommitdiffstats
path: root/system/lv
diff options
context:
space:
mode:
Diffstat (limited to 'system/lv')
-rw-r--r--system/lv/lv.SlackBuild26
-rw-r--r--system/lv/lv.info10
-rw-r--r--system/lv/patches/change-maximum-height-to-144.patch17
-rw-r--r--system/lv/patches/fix_implicit_decls.diff41
-rw-r--r--system/lv/patches/makefile.diff53
-rw-r--r--system/lv/patches/man_typos.diff65
-rw-r--r--system/lv/patches/no_inline.diff19
-rw-r--r--system/lv/patches/series6
-rw-r--r--system/lv/patches/shows-the-filename-only.diff25
9 files changed, 15 insertions, 247 deletions
diff --git a/system/lv/lv.SlackBuild b/system/lv/lv.SlackBuild
index 4961bb29aa..3689d297a6 100644
--- a/system/lv/lv.SlackBuild
+++ b/system/lv/lv.SlackBuild
@@ -2,22 +2,25 @@
# Slackware build script for lv
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20210824 bkw: update for v4.51_8, which includes all the patches
+# that used to be in patches/ here.
+
+# 20201115 bkw: add 2 new patches from Debian git, BUILD=2.
+
# 20201111 bkw: added at v4.51_7. The original upstream for this is
# long gone (dead website), but the maintainer of the Debian package
# continues to develop this. So I'm treating Debian as upstream, and
# the _7 in VERSION is the Debian patchlevel.
-# 20201115 bkw: add 2 new patches from Debian git, BUILD=2.
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=lv
-VERSION=${VERSION:-4.51_7}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-4.51_8}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -29,9 +32,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -68,18 +68,12 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# Apply all of debian's patches.
+# Apply all of debian's patches, some of which used to be part of
+# this SlackBuild (upstream likes them, yay!)
for i in $( cat debian/patches/series ); do
patch -p1 < "debian/patches/$i"
done
-# Local patches. 4 of these were written by the SlackBuild author, sent
-# upstream (to the Debian maintainer). The height and filename patches
-# are from Debian's git.
-for i in $( cat $CWD/patches/series ); do
- patch -p1 < "$CWD/patches/$i"
-done
-
# I wish there were --disable-termcap and/or --enable-ncurses options.
# The configure script is hardcoded: if termcap is found, it uses that
# and never looks for ncurses. Since termcap is pretty well deprecated
diff --git a/system/lv/lv.info b/system/lv/lv.info
index 3d29aca4a8..7d0d69ee7c 100644
--- a/system/lv/lv.info
+++ b/system/lv/lv.info
@@ -1,12 +1,12 @@
PRGNAM="lv"
-VERSION="4.51_7"
+VERSION="4.51_8"
HOMEPAGE="https://packages.debian.org/sid/lv"
-DOWNLOAD="http://deb.debian.org/debian/pool/main/l/lv/lv_4.51.orig.tar.gz \
- http://deb.debian.org/debian/pool/main/l/lv/lv_4.51-7.debian.tar.xz"
+DOWNLOAD="https://deb.debian.org/debian/pool/main/l/lv/lv_4.51.orig.tar.gz \
+ https://deb.debian.org/debian/pool/main/l/lv/lv_4.51-8.debian.tar.xz"
MD5SUM="893084b35a11eaaee4f71827d0092fa5 \
- d6d2d0e27a43480b794615a02235b953"
+ ab750b6850f58922122903412c676af1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"
diff --git a/system/lv/patches/change-maximum-height-to-144.patch b/system/lv/patches/change-maximum-height-to-144.patch
deleted file mode 100644
index 84b4afe0c2..0000000000
--- a/system/lv/patches/change-maximum-height-to-144.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Author: TOMITA Masahiro <tommy@tmtm.org>
-Description: Change maximum height to 144.
-Last-Update: 2020-10-10
-
-Index: lv/src/file.h
-===================================================================
---- lv.orig/src/file.h
-+++ lv/src/file.h
-@@ -16,7 +16,7 @@
- #include <str.h>
- #include <stream.h>
-
--#define LV_PAGE_SIZE 32U /* lines per page */
-+#define LV_PAGE_SIZE 48U /* lines per page */
-
- #ifdef MSDOS
- #define BLOCK_SIZE 2 /* segments on memory */
diff --git a/system/lv/patches/fix_implicit_decls.diff b/system/lv/patches/fix_implicit_decls.diff
deleted file mode 100644
index 1f9de61b91..0000000000
--- a/system/lv/patches/fix_implicit_decls.diff
+++ /dev/null
@@ -1,41 +0,0 @@
-Description: Remove implicit declaration warnings by adding
-appropriate #includes, and fix a typo in a prototype.
-Author: B. Watson <yahlcru@gmail.com>
-
---
-
-diff -Naur lv-4.51.orig/src/file.h lv-4.51.orig.patched/src/file.h
---- lv-4.51.orig/src/file.h 2020-11-12 02:03:33.560002050 -0500
-+++ lv-4.51.orig.patched/src/file.h 2020-11-12 02:04:06.555999050 -0500
-@@ -172,7 +172,7 @@
- public inline int IobufGetc( iobuf_t *iobuf );
- public inline int IobufUngetc( int ch, iobuf_t *iobuf );
- public offset_t IobufFtell( iobuf_t *iobuf );
--public int IobufFseeko( iobuf_t *iobuf, offset_t off, int mode );
-+public int IobufFseek( iobuf_t *iobuf, offset_t off, int mode );
- public int IobufFeof( iobuf_t *iobuf );
- #endif
- #define IobufPutc( a, b ) putc( a, (b)->iop )
-diff -Naur lv-4.51.orig/src/guess.c lv-4.51.orig.patched/src/guess.c
---- lv-4.51.orig/src/guess.c 2003-11-12 22:08:19.000000000 -0500
-+++ lv-4.51.orig.patched/src/guess.c 2020-11-12 02:04:22.621997590 -0500
-@@ -21,6 +21,7 @@
- */
-
- #include <stdio.h>
-+#include <string.h>
-
- #include <import.h>
- #include <decode.h>
-diff -Naur lv-4.51.orig/src/guesslocale.c lv-4.51.orig.patched/src/guesslocale.c
---- lv-4.51.orig/src/guesslocale.c 2004-01-05 03:41:22.000000000 -0500
-+++ lv-4.51.orig.patched/src/guesslocale.c 2020-11-12 02:04:49.294995165 -0500
-@@ -20,6 +20,8 @@
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- */
-
-+#include <ctype.h>
-+
- #ifdef HAVE_SETLOCALE
-
- #include <stdlib.h>
diff --git a/system/lv/patches/makefile.diff b/system/lv/patches/makefile.diff
deleted file mode 100644
index 4c55d7c5d2..0000000000
--- a/system/lv/patches/makefile.diff
+++ /dev/null
@@ -1,53 +0,0 @@
-Description: "make install": Support DESTDIR, use symlink for
-lgrep, use more standard default permissions (and make them
-variables). Create bin/man/lib dirs if they don't already exist.
-Author: B. Watson <yahlcru@gmail.com>
-
---
-
-diff -Naur lv-4.51.orig/src/Makefile.in lv-4.51.orig.patched/src/Makefile.in
---- lv-4.51.orig/src/Makefile.in 2004-01-06 02:22:17.000000000 -0500
-+++ lv-4.51.orig.patched/src/Makefile.in 2020-11-12 01:59:50.646022314 -0500
-@@ -18,6 +18,10 @@
- lvlibdir= $(libdir)/lv
- distdir = lv$(VERSION)
-
-+DESTDIR=
-+BINPERMS= 0755
-+DOCPERMS= 0644
-+
- PURIFY= @PURIFY@
- CC= @CC@
- CFLAGS= @CFLAGS@ -DLV_HELP_PATH=\"$(lvlibdir)\" -I$(srcdir) @DEFS@
-@@ -64,18 +68,22 @@
- #
-
- install::
-- $(INSTALL) -s -m 555 lv $(bindir)
-- if test -f $(bindir)/lgrep; then \
-- /bin/rm -f $(bindir)/lgrep; \
-+ if test ! -d $(DESTDIR)$(bindir); then \
-+ mkdir -p $(DESTDIR)$(bindir); \
-+ fi
-+ $(INSTALL) -s -m $(BINPERMS) lv $(DESTDIR)$(bindir)
-+ if test -f $(DESTDIR)$(bindir)/lgrep; then \
-+ /bin/rm -f $(DESTDIR)$(bindir)/lgrep; \
- fi
-- (cd $(bindir); ln lv lgrep)
-- if test ! -d $(lvlibdir); then \
-- mkdir -p $(lvlibdir); \
-+ (cd $(DESTDIR)$(bindir); ln -s lv lgrep)
-+ if test ! -d $(DESTDIR)$(lvlibdir); then \
-+ mkdir -p $(DESTDIR)$(lvlibdir); \
- fi
-- $(INSTALL) -m 444 $(srcdir)/../lv.hlp $(lvlibdir)
-- if test -d $(mandir) -a -d $(mandir)/man1; then \
-- $(INSTALL) -m 444 $(srcdir)/../lv.1 $(mandir)/man1; \
-+ $(INSTALL) -m $(DOCPERMS) $(srcdir)/../lv.hlp $(DESTDIR)$(lvlibdir)
-+ if test ! -d $(DESTDIR)$(mandir)/man1; then \
-+ mkdir -p $(DESTDIR)$(mandir)/man1; \
- fi
-+ $(INSTALL) -m $(DOCPERMS) $(srcdir)/../lv.1 $(DESTDIR)$(mandir)/man1; \
-
- uninstall::
- for i in $(bindir)/lv $(bindir)/lgrep $(lvlibdir)/lv.hlp $(mandir)/man1/lv.1; do \
diff --git a/system/lv/patches/man_typos.diff b/system/lv/patches/man_typos.diff
deleted file mode 100644
index be6e2ad63d..0000000000
--- a/system/lv/patches/man_typos.diff
+++ /dev/null
@@ -1,65 +0,0 @@
-Description: Fix a few typos in the man & help docs.
-Author: B. Watson <yahlcru@gmail.com>
-
---
-
-diff -Naur lv-4.51.orig/lv.1 lv-4.51.orig.patched/lv.1
---- lv-4.51.orig/lv.1 2020-11-12 01:44:33.656105671 -0500
-+++ lv-4.51.orig.patched/lv.1 2020-11-12 01:45:58.092097996 -0500
-@@ -47,7 +47,7 @@
- but also as a coding-system translation filter
- like \fInkf\fP (1) and \fItcs\fP (1).
- .IP "\fIMultilingual regular expressions / Multilingual grep\fP"
--lv can recognize multi-bytes patterns as regular expressions,
-+lv can recognize multi-byte patterns as regular expressions,
- and lv also provides multilingual \fIgrep\fP (1) functionality
- by giving it another name, \fIlgrep\fP.
- Pattern matching is conducted in the charset level,
-@@ -203,7 +203,7 @@
- Allow physical lines of each logical line printed on the screen
- to be concatenated for cut and paste after screen refresh
- .IP "-s"
--Force old pages to be swept out from the screen Smoothly
-+Force old pages to be swept out from the screen smoothly
- .IP "-u"
- Unify several character sets, eg. JIS X0208 and C6226.
- In addition, lv equates ISO 646 variants,
-@@ -237,7 +237,7 @@
- Show this help
- .SH "CONFIGURATION"
- Options can be described in configuration file ``.lv'' (``_lv'' on MSDOS)
--located at you HOME directory. If and only if you use MSDOS, you can locate
-+located in your HOME directory. If and only if you use MSDOS, you can locate
- ``_lv'' at current working directory.
- They can be also described in the environment variable LV.
- Every configuration will be overloaded in this order if there is. Command line
-diff -Naur lv-4.51.orig/lv.hlp lv-4.51.orig.patched/lv.hlp
---- lv-4.51.orig/lv.hlp 2020-11-12 01:44:33.635105673 -0500
-+++ lv-4.51.orig.patched/lv.hlp 2020-11-12 01:45:58.098097995 -0500
-@@ -37,7 +37,7 @@
- _t_c_s (1).
-
- _M_u_l_t_i_l_i_n_g_u_a_l _r_e_g_u_l_a_r _e_x_p_r_e_s_s_i_o_n_s _/ _M_u_l_t_i_l_i_n_g_u_a_l _g_r_e_p
-- lv can recognize multi-bytes patterns as regular expressions,
-+ lv can recognize multi-byte patterns as regular expressions,
- and lv also provides multilingual _g_r_e_p (1) functionality by giv-
- ing it another name, _l_g_r_e_p. Pattern matching is conducted in
- the charset level, so an EUC fragment, for example, can be found
-@@ -183,7 +183,7 @@
- -l Allow physical lines of each logical line printed on the screen
- to be concatenated for cut and paste after screen refresh
-
-- -s Force old pages to be swept out from the screen Smoothly
-+ -s Force old pages to be swept out from the screen smoothly
-
- -u Unify several character sets, eg. JIS X0208 and C6226. In addi-
- tion, lv equates ISO 646 variants, eg. JIS X0201-Roman, and
-@@ -219,7 +219,7 @@
-
- CCOONNFFIIGGUURRAATTIIOONN
- Options can be described in configuration file ``.lv'' (``_lv'' on
-- MSDOS) located at you HOME directory. If and only if you use MSDOS,
-+ MSDOS) located in your HOME directory. If and only if you use MSDOS,
- you can locate ``_lv'' at current working directory. They can be also
- described in the environment variable LV. Every configuration will be
- overloaded in this order if there is. Command line options are always
diff --git a/system/lv/patches/no_inline.diff b/system/lv/patches/no_inline.diff
deleted file mode 100644
index ebc1eb58f6..0000000000
--- a/system/lv/patches/no_inline.diff
+++ /dev/null
@@ -1,19 +0,0 @@
-Description: Remove inline-related compiler warnings (by not using inline)
-Author: B. Watson <yahlcru@gmail.com>
-
---
-
-diff -Naur lv-4.51.orig/src/file.h lv-4.51.orig.patched/src/file.h
---- lv-4.51.orig/src/file.h 2020-11-12 01:41:53.353120244 -0500
-+++ lv-4.51.orig.patched/src/file.h 2020-11-12 01:44:33.701105667 -0500
-@@ -169,8 +169,8 @@
- # endif
- # define IobufFeof( a ) feof( (a)->iop )
- #else
--public inline int IobufGetc( iobuf_t *iobuf );
--public inline int IobufUngetc( int ch, iobuf_t *iobuf );
-+public int IobufGetc( iobuf_t *iobuf );
-+public int IobufUngetc( int ch, iobuf_t *iobuf );
- public offset_t IobufFtell( iobuf_t *iobuf );
- public int IobufFseek( iobuf_t *iobuf, offset_t off, int mode );
- public int IobufFeof( iobuf_t *iobuf );
diff --git a/system/lv/patches/series b/system/lv/patches/series
deleted file mode 100644
index ce324941d9..0000000000
--- a/system/lv/patches/series
+++ /dev/null
@@ -1,6 +0,0 @@
-change-maximum-height-to-144.patch
-fix_implicit_decls.diff
-no_inline.diff
-man_typos.diff
-makefile.diff
-shows-the-filename-only.diff
diff --git a/system/lv/patches/shows-the-filename-only.diff b/system/lv/patches/shows-the-filename-only.diff
deleted file mode 100644
index 32912b4209..0000000000
--- a/system/lv/patches/shows-the-filename-only.diff
+++ /dev/null
@@ -1,25 +0,0 @@
-Description: shows the file name only if it is shorter than the width of the screen.
-Author: Oohara Yuuma <oohara@libra.interq.or.jp>
-Last-Update: 2008-01-27
-
-Index: lv/src/command.c
-===================================================================
---- lv.orig/src/command.c
-+++ lv/src/command.c
-@@ -1173,8 +1173,15 @@ public void Command( file_t *file, byte
- else
- label = "(END)";
- }
-- if( TRUE == f->top )
-+ if( TRUE == f->top ){
- label = FileName( f );
-+ /* if the file name is not shorter than the width of the screen,
-+ * it causes scrolling and moves the first line of the file
-+ * out of the screen
-+ */
-+ if ( strlen(label) >= f->width )
-+ label = NULL;
-+ }
- }
-
- if( NULL != label ){