summaryrefslogtreecommitdiffstats
path: root/system/munin-node
diff options
context:
space:
mode:
Diffstat (limited to 'system/munin-node')
-rw-r--r--system/munin-node/README17
-rw-r--r--system/munin-node/munin-node.SlackBuild51
-rw-r--r--system/munin-node/munin-node.info4
3 files changed, 51 insertions, 21 deletions
diff --git a/system/munin-node/README b/system/munin-node/README
index 99542d1fbf..06d7aeb4d0 100644
--- a/system/munin-node/README
+++ b/system/munin-node/README
@@ -1,9 +1,9 @@
-munin-node is the client portion of the Munin Monitoring system. It allows the
-Munin master to collect statistics for presentation in RRDTool time-series
-graphs.
+munin-node is the client portion of the Munin Monitoring system. It
+allows the Munin master to collect statistics for presentation in
+RRDTool time-series graphs.
-munin-node is a Perl application and requires several Perl modules as external
-dependencies:
+munin-node is a Perl application and requires several Perl modules as
+external dependencies:
Net::Server
@@ -13,10 +13,11 @@ Additionally, the following modules are required for some plugins:
Net::SNMP
Net::CIDR
-Munin requires that user munin exists and belongs to group munin. Create these
-before running the SlackBuild script:
+Munin requires that user munin exists and belongs to group
+munin. Create these before running the SlackBuild script:
groupadd -g 308 munin
useradd -u 308 -g 308 -s /sbin/nologin munin
-Once munin-node is installed, configure plugins per the Munin documentation.
+Once munin-node is installed, configure plugins per the Munin
+documentation.
diff --git a/system/munin-node/munin-node.SlackBuild b/system/munin-node/munin-node.SlackBuild
index 044af0068c..e22ed5cd90 100644
--- a/system/munin-node/munin-node.SlackBuild
+++ b/system/munin-node/munin-node.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware Package Build Script for munin-node (http://munin-monitoring.org)
# SlackBuild source at https://github.com/chapmajs/munin-node-slackbuild
@@ -9,13 +9,31 @@
# glitch@glitchwrks.com
# All rights reserved.
+# 20220212 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - add a documentation directory (/usr/doc/$PRGNAM-$VERSION).
+# - add the SlackBuild to the doc dir.
+
+# 20220212 bkw: Modified by SlackBuilds.org:
+# - fix download URL.
+# - add missing dependencies to REQUIRES.
+# - fix build (PERL5LIB).
+# - add -j1 to make commands, since parallel builds don't work.
+# - install plugins to $PKG, not the real root fs!
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=munin-node
VERSION=${VERSION:-2.0.25}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
ARCH="noarch"
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -28,15 +46,15 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar zxvf $CWD/$ARCHIVE_NAME-$VERSION.tar.gz
+rm -rf $ARCHIVE_NAME-$VERSION
+tar zxvf $CWD/"$ARCHIVE_NAME"_"$VERSION".orig.tar.gz
cd $ARCHIVE_NAME-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Fix a bug in Perldoc extension detection
patch Makefile < $CWD/patches/Makefile.patch
@@ -44,9 +62,12 @@ patch Makefile < $CWD/patches/Makefile.patch
# Patch Makefile.config for Slackware-esque install locations
patch Makefile.config < $CWD/patches/Makefile.config.patch
-make LIBDIR=/usr/lib${LIBDIRSUFFIX}
-make install-common-prime install-node-prime \
- install-plugins-prime LIBDIR=/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
+# 20220212 bkw: Note: plugins are in /usr/lib/plugins, regardless of
+# build architecture, because this is noarch.
+export PERL5LIB=.
+make -j1 LIBDIR=/usr/lib
+make -j1 install-common-prime install-node-prime \
+ install-plugins-prime LIBDIR=$PKG/usr/lib DESTDIR=$PKG
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
@@ -54,6 +75,14 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mv $PKG/usr/local/share/ $PKG/usr/
rm -rf $PKG/usr/local
+# 20220426 bkw: docs, please.
+# TODO: maintainer, you should figure out to build the HTML docs using
+# the RST source in the doc/ dir, and include those in the package.
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a COPYING ChangeLog HACKING.pod README UPGRADING* authors $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
# move config files to .new
cd $PKG/etc/munin
for file in $(find . -type f); do
@@ -69,4 +98,4 @@ cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/munin-node/munin-node.info b/system/munin-node/munin-node.info
index dea380e116..63c7a68e0e 100644
--- a/system/munin-node/munin-node.info
+++ b/system/munin-node/munin-node.info
@@ -1,10 +1,10 @@
PRGNAM="munin-node"
VERSION="2.0.25"
HOMEPAGE="http://munin-monitoring.org"
-DOWNLOAD="http://downloads.munin-monitoring.org/munin/stable/2.0.25/munin-2.0.25.tar.gz"
+DOWNLOAD="https://slackware.uk/~urchlay/src/munin_2.0.25.orig.tar.gz"
MD5SUM="b418a667ce42665557329a7ac3bd1b93"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="perl-Net-Server Net-SSLeay perl-Module-Build"
+REQUIRES="perl-Net-Server perl-Module-Build perl-HTML-Template perl-Log-Log4perl zulu-openjdk8"
MAINTAINER="Jonathan Chapman"
EMAIL="glitch@glitchwrks.com"