summaryrefslogtreecommitdiffstats
path: root/system/patool
diff options
context:
space:
mode:
Diffstat (limited to 'system/patool')
-rw-r--r--system/patool/patool.SlackBuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/system/patool/patool.SlackBuild b/system/patool/patool.SlackBuild
index 4466bc65d5..d31a96201c 100644
--- a/system/patool/patool.SlackBuild
+++ b/system/patool/patool.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for patool
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=patool
VERSION=${VERSION:-1.12}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,6 +83,7 @@ find -L . \
sed -i 's/share\/man/\/usr\/man/' setup.py
python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true