summaryrefslogtreecommitdiffstats
path: root/system/radeontop
diff options
context:
space:
mode:
Diffstat (limited to 'system/radeontop')
-rw-r--r--system/radeontop/README8
-rw-r--r--system/radeontop/git.patch24
-rw-r--r--system/radeontop/man.patch32
-rw-r--r--system/radeontop/radeontop.SlackBuild31
-rw-r--r--system/radeontop/radeontop.info10
-rw-r--r--system/radeontop/slack-desc4
6 files changed, 28 insertions, 81 deletions
diff --git a/system/radeontop/README b/system/radeontop/README
index c023fbd4a3..ed497d0e13 100644
--- a/system/radeontop/README
+++ b/system/radeontop/README
@@ -1,5 +1,5 @@
-Radeon cards monitoring utilty for viewing GPU utilization, show both
-for the total activity percent and individual blocks.
+radeontop is a monitoring utilty for viewing Radeon GPU utilization,
+showing both the total activity percentage and individual blocks.
-R600 and more recent cards are supported. Works with both the open
-drivers and AMD Catalyst.
+R600 and more recent cards are supported. radeontop works with both the
+open drivers and AMD Catalyst.
diff --git a/system/radeontop/git.patch b/system/radeontop/git.patch
deleted file mode 100644
index e3fbfc5042..0000000000
--- a/system/radeontop/git.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From c7518550fc8b0e62f1c7ea96495eec621bc395ef Mon Sep 17 00:00:00 2001
-From: orbea <orbea@fredslev.dk>
-Date: Sun, 9 Dec 2018 13:42:49 -0800
-Subject: [PATCH] getver.sh: Only use git if its a git repo.
-
----
- getver.sh | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/getver.sh b/getver.sh
-index 7bb1889..45261dd 100755
---- a/getver.sh
-+++ b/getver.sh
-@@ -2,7 +2,9 @@
-
- ver=unknown
-
--[ -n "`which git`" ] && ver=`git describe`
-+if [ -n "`which git`" ] && git rev-parse HEAD 2>/dev/null; then
-+ ver=`git describe`
-+fi
-
- cat > include/version.h << EOF
- #ifndef VER_H
diff --git a/system/radeontop/man.patch b/system/radeontop/man.patch
deleted file mode 100644
index b9f26245a9..0000000000
--- a/system/radeontop/man.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From dfbff6274ce25814a4357a8a788c404425cecb69 Mon Sep 17 00:00:00 2001
-From: orbea <orbea@fredslev.dk>
-Date: Sat, 1 Dec 2018 07:43:12 -0800
-Subject: [PATCH] Makefile: Add MANDIR.
-
-Not all Linux distros install manpages to $(PREFIX)/share/man.
-For example Slackware installs manpages to /usr/man/.
----
- Makefile | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 6010bc9..4cb7093 100644
---- a/Makefile
-+++ b/Makefile
-@@ -13,6 +13,7 @@
- PREFIX ?= /usr
- INSTALL ?= install
- LIBDIR ?= lib
-+MANDIR ?= share/man
-
- nls ?= 1
- xcb ?= 1
-@@ -103,7 +104,7 @@ install: all
- ifeq ($(xcb), 1)
- $(INSTALL) -D -m755 $(xcblib) $(DESTDIR)/$(PREFIX)/$(LIBDIR)/$(xcblib)
- endif
-- $(INSTALL) -D -m644 radeontop.1 $(DESTDIR)/$(PREFIX)/share/man/man1/radeontop.1
-+ $(INSTALL) -D -m644 radeontop.1 $(DESTDIR)/$(PREFIX)/$(MANDIR)/man1/radeontop.1
- ifeq ($(nls), 1)
- $(MAKE) -C translations install PREFIX=$(PREFIX)
- endif
diff --git a/system/radeontop/radeontop.SlackBuild b/system/radeontop/radeontop.SlackBuild
index 15718a8317..0d1d2b2878 100644
--- a/system/radeontop/radeontop.SlackBuild
+++ b/system/radeontop/radeontop.SlackBuild
@@ -1,8 +1,10 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for radeontop
# Copyright 2018 Hunter Sezen California, USA
+# Copyright 2023 K. Eugene Carlson Tsukuba, JP
+#
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +24,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=radeontop
-VERSION=${VERSION:-1.1}
+VERSION=${VERSION:-1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -72,19 +84,10 @@ find -L . \
# Include the correct version number.
sed -i "s/ver=unknown/ver=$VERSION/" ./getver.sh
-# Makefile: Add MANDIR.
-# https://github.com/clbr/radeontop/commit/dfbff6274ce25814a4357a8a788c404425cecb69
-# https://github.com/clbr/radeontop/pull/79
-patch -p1 < $CWD/man.patch
-
-# getver.sh: Only use git if its a git repo.
-# https://github.com/clbr/radeontop/commit/c7518550fc8b0e62f1c7ea96495eec621bc395ef
-# https://github.com/clbr/radeontop/pull/80
-patch -p1 < $CWD/git.patch
-
CFLAGS="$SLKCFLAGS" \
make amdgpu=1
+# BINDIR no longer needed
make install \
PREFIX=/usr \
LIBDIR=lib${LIBDIRSUFFIX} \
@@ -105,4 +108,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/radeontop/radeontop.info b/system/radeontop/radeontop.info
index 8652cbfc76..45de516e9b 100644
--- a/system/radeontop/radeontop.info
+++ b/system/radeontop/radeontop.info
@@ -1,10 +1,10 @@
PRGNAM="radeontop"
-VERSION="1.1"
+VERSION="1.4"
HOMEPAGE="https://github.com/clbr/radeontop"
-DOWNLOAD="https://github.com/clbr/radeontop/archive/v1.1/radeontop-1.1.tar.gz"
-MD5SUM="51bbca383b72855ff1c6d4e7d1f4f657"
+DOWNLOAD="https://github.com/clbr/radeontop/archive/v1.4/radeontop-1.4.tar.gz"
+MD5SUM="a6402ee26ebcdc4177725a1299a11a0d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Hunter Sezen"
-EMAIL="orbea@riseup.net"
+MAINTAINER="K. Eugene Carlson"
+EMAIL="kvngncrlsn@gmail.com"
diff --git a/system/radeontop/slack-desc b/system/radeontop/slack-desc
index 96b4e6623e..00449f7c7e 100644
--- a/system/radeontop/slack-desc
+++ b/system/radeontop/slack-desc
@@ -8,8 +8,8 @@
|-----handy-ruler------------------------------------------------------|
radeontop: radeontop (Radeon cards monitoring utility)
radeontop:
-radeontop: Radeon cards monitoring utilty for viewing GPU utilization, show both
-radeontop: for the total activity percent and individual blocks.
+radeontop: Monitoring utilty for viewing Radeon GPU utilization, showing both
+radeontop: the total activity percentage and individual blocks.
radeontop:
radeontop: Homepage: https://github.com/clbr/radeontop
radeontop: