summaryrefslogtreecommitdiffstats
path: root/system/sdltrs/sdltrs.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/sdltrs/sdltrs.SlackBuild')
-rw-r--r--system/sdltrs/sdltrs.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/system/sdltrs/sdltrs.SlackBuild b/system/sdltrs/sdltrs.SlackBuild
index 88b5e381a0..0ce5123722 100644
--- a/system/sdltrs/sdltrs.SlackBuild
+++ b/system/sdltrs/sdltrs.SlackBuild
@@ -75,7 +75,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# include -lX11 in the Makefile (sw-14.0)
sed "/^LIBS/s/= /= -lX11 /" -i src/linux/Makefile
@@ -102,6 +102,7 @@ cp -a BUILDING README $PKG/usr/doc/$PRGNAM-$VERSION
cp -a docs/* $PKG/usr/doc/$PRGNAM-$VERSION/html/
find $PKG/usr/doc/$PRGNAM-$VERSION/ -type f -exec chmod 644 {} \;
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+chmod 755 $PKG/usr/doc/$PRGNAM-$VERSION/html/images/
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc