summaryrefslogtreecommitdiffstats
path: root/system/xen/patches/use_already_present_ipxe.diff
diff options
context:
space:
mode:
Diffstat (limited to 'system/xen/patches/use_already_present_ipxe.diff')
-rw-r--r--system/xen/patches/use_already_present_ipxe.diff15
1 files changed, 15 insertions, 0 deletions
diff --git a/system/xen/patches/use_already_present_ipxe.diff b/system/xen/patches/use_already_present_ipxe.diff
new file mode 100644
index 0000000000..6962616f71
--- /dev/null
+++ b/system/xen/patches/use_already_present_ipxe.diff
@@ -0,0 +1,15 @@
+--- xen-4.2.0/tools/firmware/etherboot/Makefile.ORIG 2012-09-17 12:21:18.000000000 +0200
++++ xen-4.2.0/tools/firmware/etherboot/Makefile 2012-09-18 13:39:39.466352815 +0200
+@@ -28,12 +28,6 @@
+ $(MAKE) -C $D/src bin/$(*F).rom
+
+ $T:
+- if ! wget -O _$T $(IPXE_TARBALL_URL); then \
+- $(GIT) clone $(IPXE_GIT_URL) $D.git; \
+- (cd $D.git && $(GIT) archive --format=tar --prefix=$D/ \
+- $(IPXE_GIT_TAG) | gzip >../_$T); \
+- rm -rf $D.git; \
+- fi
+ mv _$T $T
+
+ $D/src/arch/i386/Makefile: $T Config