summaryrefslogtreecommitdiffstats
path: root/system/xen/patches
diff options
context:
space:
mode:
Diffstat (limited to 'system/xen/patches')
-rw-r--r--system/xen/patches/configuration_goes_to_system_etc.diff10
-rw-r--r--system/xen/patches/symlinks_instead_of_hardlinks.diff20
-rw-r--r--system/xen/patches/use_already_present_ipxe.diff15
3 files changed, 45 insertions, 0 deletions
diff --git a/system/xen/patches/configuration_goes_to_system_etc.diff b/system/xen/patches/configuration_goes_to_system_etc.diff
new file mode 100644
index 0000000000..07e673d195
--- /dev/null
+++ b/system/xen/patches/configuration_goes_to_system_etc.diff
@@ -0,0 +1,10 @@
+--- xen-4.2.0/tools/Makefile.ORIG 2012-09-17 12:21:18.000000000 +0200
++++ xen-4.2.0/tools/Makefile 2012-09-18 13:37:55.410462850 +0200
+@@ -200,6 +200,7 @@
+ --datadir=$(SHAREDIR)/qemu-xen \
+ --disable-kvm \
+ --python=$(PYTHON) \
++ --sysconfdir=/etc \
+ $(IOEMU_CONFIGURE_CROSS); \
+ $(MAKE) all
+
diff --git a/system/xen/patches/symlinks_instead_of_hardlinks.diff b/system/xen/patches/symlinks_instead_of_hardlinks.diff
new file mode 100644
index 0000000000..50af6c3254
--- /dev/null
+++ b/system/xen/patches/symlinks_instead_of_hardlinks.diff
@@ -0,0 +1,20 @@
+--- xen-4.2.0/tools/xenstore/Makefile.ORIG 2012-09-17 12:21:19.000000000 +0200
++++ xen-4.2.0/tools/xenstore/Makefile 2012-10-21 22:59:54.585759242 +0200
+@@ -64,7 +64,7 @@
+ $(AR) cr $@ $^
+
+ $(CLIENTS): xenstore
+- ln -f xenstore $@
++ ln -sf xenstore $@
+
+ xenstore: xenstore_client.o $(LIBXENSTORE)
+ $(CC) $(LDFLAGS) $< $(LDLIBS_libxenstore) $(SOCKET_LIBS) -o $@ $(APPEND_LDFLAGS)
+@@ -116,7 +116,7 @@
+ $(INSTALL_PROG) xenstore-control $(DESTDIR)$(BINDIR)
+ $(INSTALL_PROG) xenstore $(DESTDIR)$(BINDIR)
+ set -e ; for c in $(CLIENTS) ; do \
+- ln -f $(DESTDIR)$(BINDIR)/xenstore $(DESTDIR)$(BINDIR)/$${c} ; \
++ ln -sf xenstore $(DESTDIR)$(BINDIR)/$${c} ; \
+ done
+ $(INSTALL_DIR) $(DESTDIR)$(LIBDIR)
+ $(INSTALL_PROG) libxenstore.so.$(MAJOR).$(MINOR) $(DESTDIR)$(LIBDIR)
diff --git a/system/xen/patches/use_already_present_ipxe.diff b/system/xen/patches/use_already_present_ipxe.diff
new file mode 100644
index 0000000000..6962616f71
--- /dev/null
+++ b/system/xen/patches/use_already_present_ipxe.diff
@@ -0,0 +1,15 @@
+--- xen-4.2.0/tools/firmware/etherboot/Makefile.ORIG 2012-09-17 12:21:18.000000000 +0200
++++ xen-4.2.0/tools/firmware/etherboot/Makefile 2012-09-18 13:39:39.466352815 +0200
+@@ -28,12 +28,6 @@
+ $(MAKE) -C $D/src bin/$(*F).rom
+
+ $T:
+- if ! wget -O _$T $(IPXE_TARBALL_URL); then \
+- $(GIT) clone $(IPXE_GIT_URL) $D.git; \
+- (cd $D.git && $(GIT) archive --format=tar --prefix=$D/ \
+- $(IPXE_GIT_TAG) | gzip >../_$T); \
+- rm -rf $D.git; \
+- fi
+ mv _$T $T
+
+ $D/src/arch/i386/Makefile: $T Config