summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/keylaunch/README5
-rw-r--r--system/keylaunch/keylaunch.SlackBuild100
-rw-r--r--system/keylaunch/keylaunch.info10
-rw-r--r--system/keylaunch/slack-desc19
4 files changed, 134 insertions, 0 deletions
diff --git a/system/keylaunch/README b/system/keylaunch/README
new file mode 100644
index 0000000000..628d0bf3fb
--- /dev/null
+++ b/system/keylaunch/README
@@ -0,0 +1,5 @@
+KeyLaunch is a small utility for binding commands to a hot key.
+It reads a configuration file in ~/.keylaunchrc. KeyLaunch uses
+Ctrl, Alt and Shift as modifier keys, the hotkey is up to the user.
+
+See example_rc in the documentation directory for more information.
diff --git a/system/keylaunch/keylaunch.SlackBuild b/system/keylaunch/keylaunch.SlackBuild
new file mode 100644
index 0000000000..a5146d965f
--- /dev/null
+++ b/system/keylaunch/keylaunch.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/sh
+
+# Slackware build script for KeyLaunch
+
+# Copyright 2012 Bryan Harris <bryanhlarris@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=keylaunch
+VERSION=${VERSION:-1.3.9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --disable-debug \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+strip --strip-unneeded 2>/dev/null $PKG/usr/bin/keylaunch
+
+mv $PKG/usr/share/man $PKG/usr
+gzip -9 $PKG/usr/man/man1/keylaunch.1
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/copyright debian/changelog INSTALL LICENSE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm -rf $PKG/usr/share
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/keylaunch/keylaunch.info b/system/keylaunch/keylaunch.info
new file mode 100644
index 0000000000..78cadaeb46
--- /dev/null
+++ b/system/keylaunch/keylaunch.info
@@ -0,0 +1,10 @@
+PRGNAM="keylaunch"
+VERSION="1.3.9"
+HOMEPAGE="http://www.oroborus.org/"
+DOWNLOAD="http://ftp.debian.org/debian/pool/main/k/keylaunch/keylaunch_1.3.9.tar.gz"
+MD5SUM="710f68a3e7026b4139cc94ea790576c3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Bryan Harris"
+EMAIL="bryanlharris@gmail.com"
diff --git a/system/keylaunch/slack-desc b/system/keylaunch/slack-desc
new file mode 100644
index 0000000000..6576156c1b
--- /dev/null
+++ b/system/keylaunch/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+keylaunch: KeyLaunch (bind commands to a hot key)
+keylaunch:
+keylaunch: KeyLaunch is a small utility for binding commands to a hot key. It
+keylaunch: reads a configuration file in ${HOME}.keylaunchrc. KeyLaunch uses
+keylaunch: Ctrl, Alt and Shift as modifier keys, the hotkey is up to the user.
+keylaunch: See /usr/doc/keylaunch-1.3.3/example_rc to get started.
+keylaunch:
+keylaunch: Homepage: http://www.oroborus.org/
+keylaunch:
+keylaunch:
+keylaunch: