summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-25 00:09:12 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-30 11:16:31 +0700
commit06a310f20c1d9d32dcb5b3961dd20c9847540e42 (patch)
tree231b68816b716ba8d6b450fc468c5a1e1cdd2952
parent7a8b6f3db776785ce2925f1113a6ab137291935f (diff)
downloadslackbuilds-06a310f20c1d9d32dcb5b3961dd20c9847540e42.tar.gz
slackbuilds-06a310f20c1d9d32dcb5b3961dd20c9847540e42.tar.xz
python/passlib: Removed (renamed python3-passlib).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/passlib/README6
-rw-r--r--python/passlib/passlib.SlackBuild101
-rw-r--r--python/passlib/passlib.info10
-rw-r--r--python/passlib/slack-desc19
4 files changed, 0 insertions, 136 deletions
diff --git a/python/passlib/README b/python/passlib/README
deleted file mode 100644
index d3618f7ac9..0000000000
--- a/python/passlib/README
+++ /dev/null
@@ -1,6 +0,0 @@
-Passlib is a password hashing library for Python 2 & 3, which provides
-cross-platform implementations of over 30 password hashing algorithms,
-as well as a framework for managing existing password hashes. It's
-designed to be useful for a wide range of tasks, from verifying a hash
-found in /etc/shadow, to providing full-strength password hashing for
-multi-user applications.
diff --git a/python/passlib/passlib.SlackBuild b/python/passlib/passlib.SlackBuild
deleted file mode 100644
index 12be2e0eb8..0000000000
--- a/python/passlib/passlib.SlackBuild
+++ /dev/null
@@ -1,101 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for passlib
-
-# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
-# Copyright 2015-2017, 2020 Brenton Earl <brent@exitstatusone.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=passlib
-VERSION=${VERSION:-1.7.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-# Python 3 support
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/passlib/passlib.info b/python/passlib/passlib.info
deleted file mode 100644
index 4bed649604..0000000000
--- a/python/passlib/passlib.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="passlib"
-VERSION="1.7.2"
-HOMEPAGE="https://pypi.org/project/passlib/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/passlib/passlib-1.7.2.tar.gz"
-MD5SUM="b908529cfd4c33057c244324c692eae7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="fourtysixandtwo"
-EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/passlib/slack-desc b/python/passlib/slack-desc
deleted file mode 100644
index 1377a74acc..0000000000
--- a/python/passlib/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-passlib: passlib (comprehensive password hashing framework)
-passlib:
-passlib: Passlib is a password hashing library for Python 2 & 3, which
-passlib: provides cross-platform implementations of over 30 password hashing
-passlib: algorithms, as well as a framework for managing existing password
-passlib: hashes. It's designed to be useful for a wide range of tasks, from
-passlib: verifying a hash found in /etc/shadow, to providing full-strength
-passlib: password hashing for multi-user applications.
-passlib:
-passlib: Home page: https://pypi.org/project/passlib/
-passlib: