summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-13 22:27:46 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-17 00:10:34 +0700
commit5881303c007ee3209dca1ddd8f7442643009ad15 (patch)
tree01bb166246b75de31b91611d0a94a67d17c00424
parentef1d43a3c6ee44d075d4e151917337dcaa71d2ff (diff)
downloadslackbuilds-5881303c007ee3209dca1ddd8f7442643009ad15.tar.gz
slackbuilds-5881303c007ee3209dca1ddd8f7442643009ad15.tar.xz
development/Sphinx: Updated for version 4.5.0, new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/Sphinx/Sphinx.SlackBuild27
-rw-r--r--development/Sphinx/Sphinx.SlackBuild.rej12
-rw-r--r--development/Sphinx/Sphinx.info12
3 files changed, 39 insertions, 12 deletions
diff --git a/development/Sphinx/Sphinx.SlackBuild b/development/Sphinx/Sphinx.SlackBuild
index 87caf8736b..9c3f86f3a7 100644
--- a/development/Sphinx/Sphinx.SlackBuild
+++ b/development/Sphinx/Sphinx.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for Sphinx
+# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2013 Mikko Värri, Finland
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Sphinx
-VERSION=${VERSION:-4.2.0}
+VERSION=${VERSION:-4.5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,6 +49,23 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
set -e
rm -rf $PKG
@@ -62,9 +77,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/development/Sphinx/Sphinx.SlackBuild.rej b/development/Sphinx/Sphinx.SlackBuild.rej
new file mode 100644
index 0000000000..a0c8fc33c7
--- /dev/null
+++ b/development/Sphinx/Sphinx.SlackBuild.rej
@@ -0,0 +1,12 @@
+--- /dev/null
++++ /dev/null
+@@ -57,6 +57,9 @@ elif [ "$ARCH" = "i686" ]; then
+ elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
++elif [ "$ARCH" = "aarch64" ]; then
++ SLKCFLAGS="-O2 -fPIC"
++ LIBDIRSUFFIX="64"
+ else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
diff --git a/development/Sphinx/Sphinx.info b/development/Sphinx/Sphinx.info
index f2c4274ca9..e2d298c077 100644
--- a/development/Sphinx/Sphinx.info
+++ b/development/Sphinx/Sphinx.info
@@ -1,10 +1,10 @@
PRGNAM="Sphinx"
-VERSION="4.2.0"
+VERSION="4.5.0"
HOMEPAGE="http://www.sphinx-doc.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-4.2.0.tar.gz"
-MD5SUM="6af34550e36dd6d58a496e47ec67280f"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-4.5.0.tar.gz"
+MD5SUM="ed63e60d798d212c1afdecf8acda690e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="alabaster imagesize python3-babel snowballstemmer sphinxcontrib-applehelp sphinxcontrib-devhelp sphinxcontrib-htmlhelp sphinxcontrib-jsmath sphinxcontrib-qthelp sphinxcontrib-serializinghtml"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="alabaster imagesize python3-babel snowballstemmer sphinxcontrib-applehelp sphinxcontrib-devhelp sphinxcontrib-htmlhelp sphinxcontrib-jsmath sphinxcontrib-qthelp sphinxcontrib-serializinghtml python-importlib_metadata"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"