summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:17 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:48 +0700
commit6d4e9fd78e63d6761fb2acb2a7b19ea2f4c352cf (patch)
treebd69c4dd79de812d83adf16de5e895c17b075268
parent81d369fb691369fefc8e78a21e214c0e6286d254 (diff)
downloadslackbuilds-6d4e9fd78e63d6761fb2acb2a7b19ea2f4c352cf.tar.gz
slackbuilds-6d4e9fd78e63d6761fb2acb2a7b19ea2f4c352cf.tar.xz
python/python-editor: Renamed python2-editor.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-editor/python-editor.info10
-rw-r--r--python/python-editor/slack-desc19
-rw-r--r--python/python2-editor/README (renamed from python/python-editor/README)0
-rw-r--r--python/python2-editor/python2-editor.SlackBuild (renamed from python/python-editor/python-editor.SlackBuild)16
-rw-r--r--python/python2-editor/python2-editor.info10
-rw-r--r--python/python2-editor/slack-desc19
6 files changed, 37 insertions, 37 deletions
diff --git a/python/python-editor/python-editor.info b/python/python-editor/python-editor.info
deleted file mode 100644
index 917aeff1fb..0000000000
--- a/python/python-editor/python-editor.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-editor"
-VERSION="1.0.4"
-HOMEPAGE="https://github.com/fmoo/python-editor"
-DOWNLOAD="https://files.pythonhosted.org/packages/0a/85/78f4a216d28343a67b7397c99825cff336330893f00601443f7c7b2f2234/python-editor-1.0.4.tar.gz"
-MD5SUM="0e52648a4a6e7c89e3be44e9456530b4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-six"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-editor/slack-desc b/python/python-editor/slack-desc
deleted file mode 100644
index 5a3d9ccf67..0000000000
--- a/python/python-editor/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-editor: python-editor (Programmatically open an editor)
-python-editor:
-python-editor: python-editor is a library that provides the editor module for
-python-editor: programmatically interfacing with your system's $EDITOR.
-python-editor:
-python-editor: Homepage: https://github.com/fmoo/python-editor
-python-editor:
-python-editor:
-python-editor:
-python-editor:
-python-editor:
diff --git a/python/python-editor/README b/python/python2-editor/README
index be307e07e9..be307e07e9 100644
--- a/python/python-editor/README
+++ b/python/python2-editor/README
diff --git a/python/python-editor/python-editor.SlackBuild b/python/python2-editor/python2-editor.SlackBuild
index 56382da85a..32ee26f8d8 100644
--- a/python/python-editor/python-editor.SlackBuild
+++ b/python/python2-editor/python2-editor.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-editor
-# Copyright 2016-2021 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,8 +22,9 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-editor
-VERSION=${VERSION:-1.0.4}
+PRGNAM=python2-editor
+SRCNAM=python-editor
+VERSION=${VERSION:-1.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +60,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,8 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python2-editor/python2-editor.info b/python/python2-editor/python2-editor.info
new file mode 100644
index 0000000000..98cab251fc
--- /dev/null
+++ b/python/python2-editor/python2-editor.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-editor"
+VERSION="1.0.3"
+HOMEPAGE="https://github.com/fmoo/python-editor"
+DOWNLOAD="https://pypi.python.org/packages/65/1e/adf6e000ea5dc909aa420352d6ba37f16434c8a3c2fa030445411a1ed545/python-editor-1.0.3.tar.gz"
+MD5SUM="0aca5f2ef176ce68e98a5b7e31372835"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python2-editor/slack-desc b/python/python2-editor/slack-desc
new file mode 100644
index 0000000000..b433e5e13a
--- /dev/null
+++ b/python/python2-editor/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-editor: python2-editor (Programmatically open an editor)
+python2-editor:
+python2-editor: python2-editor is a library that provides the editor module for
+python2-editor: programmatically interfacing with your system's $EDITOR.
+python2-editor:
+python2-editor: Homepage: https://github.com/fmoo/python2-editor
+python2-editor:
+python2-editor:
+python2-editor:
+python2-editor:
+python2-editor: