summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2023-10-09 09:04:25 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-09 19:00:35 +0700
commit7cfb8698f59ff9b95a62b7c59fdf5e3b4b9f429a (patch)
treea84b9e519700424eaee5015ef75c27417400efb7
parentdcfc39d340fca8edaa64652b25c38037575fef5c (diff)
downloadslackbuilds-7cfb8698f59ff9b95a62b7c59fdf5e3b4b9f429a.tar.gz
slackbuilds-7cfb8698f59ff9b95a62b7c59fdf5e3b4b9f429a.tar.xz
libraries/DateTime: Removed. Unmaintained - python2 build with python3 dependencies.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/DateTime/DateTime.SlackBuild95
-rw-r--r--libraries/DateTime/DateTime.info10
-rw-r--r--libraries/DateTime/README3
-rw-r--r--libraries/DateTime/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/libraries/DateTime/DateTime.SlackBuild b/libraries/DateTime/DateTime.SlackBuild
deleted file mode 100644
index 6d2cf05cb6..0000000000
--- a/libraries/DateTime/DateTime.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for DateTime
-
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=DateTime
-VERSION=${VERSION:-4.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst PKG-INFO *.txt src/DateTime/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/DateTime/DateTime.info b/libraries/DateTime/DateTime.info
deleted file mode 100644
index a895a8a0fe..0000000000
--- a/libraries/DateTime/DateTime.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="DateTime"
-VERSION="4.2"
-HOMEPAGE="https://pypi.python.org/pypi/DateTime"
-DOWNLOAD="https://pypi.python.org/packages/c2/fd/6f12e58cf25b71a0941e882f030650e040c1990355371a3d51ed3c379449/DateTime-4.2.tar.gz"
-MD5SUM="edbe70fb2b057e338a3c88a77c503418"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="zope.interface pytz"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/DateTime/README b/libraries/DateTime/README
deleted file mode 100644
index 4b543430d5..0000000000
--- a/libraries/DateTime/README
+++ /dev/null
@@ -1,3 +0,0 @@
-This package provides a DateTime data type, as known from Zope 2.
-Unless you need to communicate with Zope 2 APIs, you're probably
-better off using Python's built-in datetime module.
diff --git a/libraries/DateTime/slack-desc b/libraries/DateTime/slack-desc
deleted file mode 100644
index 10e634d687..0000000000
--- a/libraries/DateTime/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-DateTime: DateTime (DateTime data type)
-DateTime:
-DateTime: This package provides a DateTime data type, as known from Zope 2.
-DateTime: Unless you need to communicate with Zope 2 APIs, you're probably
-DateTime: better off using Python's built-in datetime module.
-DateTime:
-DateTime: Homepage: https://pypi.python.org/pypi/DateTime
-DateTime:
-DateTime:
-DateTime:
-DateTime: