summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-05-27 08:06:22 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-10 09:23:02 +0700
commit9cc7a36cbfe5f405c6382e882aefc6b78c9ee806 (patch)
treef504d7850619c45d0c24e21e999690ac1b29f24f
parenta7e8b949f35ab3f903768685c00de1ab85cbb747 (diff)
downloadslackbuilds-9cc7a36cbfe5f405c6382e882aefc6b78c9ee806.tar.gz
slackbuilds-9cc7a36cbfe5f405c6382e882aefc6b78c9ee806.tar.xz
python/jsonschema: Removed: (replaced by python3-jsonschema)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/jsonschema/README2
-rw-r--r--python/jsonschema/jsonschema.SlackBuild95
-rw-r--r--python/jsonschema/jsonschema.info10
-rw-r--r--python/jsonschema/slack-desc19
4 files changed, 0 insertions, 126 deletions
diff --git a/python/jsonschema/README b/python/jsonschema/README
deleted file mode 100644
index 183c7daf0f..0000000000
--- a/python/jsonschema/README
+++ /dev/null
@@ -1,2 +0,0 @@
-jsonschema is an implementation of JSON Schema for Python.
-(supporting 2.6+ including Python 3).
diff --git a/python/jsonschema/jsonschema.SlackBuild b/python/jsonschema/jsonschema.SlackBuild
deleted file mode 100644
index 74e2b20869..0000000000
--- a/python/jsonschema/jsonschema.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for jsonschema
-
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=jsonschema
-VERSION=${VERSION:-2.5.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING *.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/jsonschema/jsonschema.info b/python/jsonschema/jsonschema.info
deleted file mode 100644
index 1a2db636ee..0000000000
--- a/python/jsonschema/jsonschema.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="jsonschema"
-VERSION="2.5.1"
-HOMEPAGE="https://github.com/Julian/jsonschema"
-DOWNLOAD="https://pypi.python.org/packages/source/j/jsonschema/jsonschema-2.5.1.tar.gz"
-MD5SUM="374e848fdb69a3ce8b7e778b47c30640"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="vcversioner functools32"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/jsonschema/slack-desc b/python/jsonschema/slack-desc
deleted file mode 100644
index e6674aeaf2..0000000000
--- a/python/jsonschema/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-jsonschema: jsonschema (Implementation of JSON Schema)
-jsonschema:
-jsonschema: jsonschema is an implementation of JSON Schema
-jsonschema: for Python (supporting 2.6+ including Python 3).
-jsonschema:
-jsonschema: Homepage: https://github.com/Julian/jsonschema
-jsonschema:
-jsonschema:
-jsonschema:
-jsonschema:
-jsonschema: