summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2016-08-09 16:05:03 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-13 07:22:19 +0700
commitac818b091eb0d2992722083503a5c78fc80f34d2 (patch)
treef432e0e14b4e74697c86233977ad1514a39181e0
parent9e9270ea8b6b3d8d129e1f74562e0616ae9d45c6 (diff)
downloadslackbuilds-ac818b091eb0d2992722083503a5c78fc80f34d2.tar.gz
slackbuilds-ac818b091eb0d2992722083503a5c78fc80f34d2.tar.xz
python/python-patch: Added (library to parse+apply unified diffs).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--python/python-patch/README17
-rw-r--r--python/python-patch/python-patch.SlackBuild75
-rw-r--r--python/python-patch/python-patch.info10
-rw-r--r--python/python-patch/setup.py3
-rw-r--r--python/python-patch/slack-desc19
5 files changed, 124 insertions, 0 deletions
diff --git a/python/python-patch/README b/python/python-patch/README
new file mode 100644
index 0000000000..c16a8c4059
--- /dev/null
+++ b/python/python-patch/README
@@ -0,0 +1,17 @@
+Library to parse and apply unified diffs
+
+Features
+
+ - Automatic correction of * Linefeeds according to patched file *
+ Diffs broken by stripping trailing whitespace * a/ and b/ prefixes
+ - Single file, which is a command line tool and a library
+ - No dependencies outside Python stdlib
+ - Patch format detection (SVN, HG, GIT)
+ - Nice diffstat histogram
+
+Things that don't work out of the box:
+
+ - File renaming, creation and removal
+ - Directory tree operations
+ - Version control specific properties
+ - Non-unified diff formats
diff --git a/python/python-patch/python-patch.SlackBuild b/python/python-patch/python-patch.SlackBuild
new file mode 100644
index 0000000000..63e2cae6ef
--- /dev/null
+++ b/python/python-patch/python-patch.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for python-patch
+
+# Copyright 2016 Andre Barboza, Belo Horizonte, Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-patch
+VERSION=${VERSION:-1.16}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cp $CWD/setup.py .
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-patch/python-patch.info b/python/python-patch/python-patch.info
new file mode 100644
index 0000000000..077e042b42
--- /dev/null
+++ b/python/python-patch/python-patch.info
@@ -0,0 +1,10 @@
+PRGNAM="python-patch"
+VERSION="1.16"
+HOMEPAGE="https://github.com/techtonik/python-patch/"
+DOWNLOAD="https://github.com/techtonik/python-patch/archive/1.16/python-patch-1.16.tar.gz"
+MD5SUM="fddeb3bbf6e862892ebef579c2c62876"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
diff --git a/python/python-patch/setup.py b/python/python-patch/setup.py
new file mode 100644
index 0000000000..9d6751c3cf
--- /dev/null
+++ b/python/python-patch/setup.py
@@ -0,0 +1,3 @@
+from distutils.core import setup
+
+setup(name='patch', version='1.16', py_modules=['patch'], )
diff --git a/python/python-patch/slack-desc b/python/python-patch/slack-desc
new file mode 100644
index 0000000000..326ca948c5
--- /dev/null
+++ b/python/python-patch/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-patch: python-patch (Python library to parse and apply unified diffs)
+python-patch:
+python-patch: Library to parse and apply unified diffs.
+python-patch:
+python-patch:
+python-patch:
+python-patch:
+python-patch:
+python-patch:
+python-patch: Homepage: https://github.com/techtonik/python-patch
+python-patch: