summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2025-05-08 17:30:16 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2025-05-10 12:09:00 +0700
commitd55c1d72c0fd8cabae78cce46c30f651960df68b (patch)
tree6016de4bb597c24dd02ffeb33ac9fe538bedb791
parent79182e8a640221206adac446f5f33b42bd4b1318 (diff)
downloadslackbuilds-d55c1d72c0fd8cabae78cce46c30f651960df68b.tar.gz
slackbuilds-d55c1d72c0fd8cabae78cce46c30f651960df68b.tar.xz
multimedia/beets: Updated for version 2.3.0.
NOTE: requires the newly submitted python3-lap build Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--multimedia/beets/README5
-rw-r--r--multimedia/beets/beets.SlackBuild20
-rw-r--r--multimedia/beets/beets.info8
3 files changed, 15 insertions, 18 deletions
diff --git a/multimedia/beets/README b/multimedia/beets/README
index 4a0b108c90..3e26d5347a 100644
--- a/multimedia/beets/README
+++ b/multimedia/beets/README
@@ -26,3 +26,8 @@ shockingly simple if you know a little Python.
Optional dependencies (now included by default):
Flask, gst-python, pyacoustid, pylast.
+
+NOTE: beets now requires python3-numpy. While numpy will build without
+ it I highly suggest installing OpenBLAS before building numpy. I
+ would add it to the REQUIRES but it will not be in the proper
+ order for numpy to build against OpenBLAS.
diff --git a/multimedia/beets/beets.SlackBuild b/multimedia/beets/beets.SlackBuild
index b1146c27e5..b2c668f27b 100644
--- a/multimedia/beets/beets.SlackBuild
+++ b/multimedia/beets/beets.SlackBuild
@@ -28,10 +28,12 @@
# 20250412 46and2: Stick with github tagged source for 2.2.0 as there
# are issues with pypi sdist. The extra and docs dirs are not
# included.
+# 20250508 46and2: Back to pypi tarball as 2.3.0 has the fixes for the above.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=beets
-VERSION=${VERSION:-2.2.0}
+VERSION=${VERSION:-2.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -68,14 +70,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# 2.2.0 github tagged source still builds as 2.1.0 so let's fix that
-sed -i 's/2\.1\.0/2.2.0/' pyproject.toml
-
-# temp build man pages as missing from source with 2.1.0
-# switch to github from pypi for now as well
-# https://github.com/beetbox/beets/issues/5513
-make -C docs man
-
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl
@@ -85,10 +79,10 @@ install -m644 $CWD/beet $PKG/usr/share/bash-completion/completions/
mkdir -p $PKG/usr/share/zsh/site-functions
install -m644 extra/_beet $PKG/usr/share/zsh/site-functions/
-install -D -m644 docs/_build/man/beet.1 $PKG/usr/man/man1/beet.1
-install -D -m644 docs/_build/man/beetsconfig.5 $PKG/usr/man/man5/beetsconfig.5
+install -D -m644 man/beet.1 $PKG/usr/man/man1/beet.1
+install -D -m644 man/beetsconfig.5 $PKG/usr/man/man5/beetsconfig.5
-find $PKG/usr/man -type f -exec gzip -9 {} \+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -96,8 +90,6 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst LICENSE docs/* $PKG/usr/doc/$PRGNAM-$VERSION
-# remove _build and _static dirs we just copied above
-rm -rf $PKG/usr/doc/$PRGNAM-$VERSION/_{build,static}
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/multimedia/beets/beets.info b/multimedia/beets/beets.info
index 4a045c1510..8cbde8c8ae 100644
--- a/multimedia/beets/beets.info
+++ b/multimedia/beets/beets.info
@@ -1,10 +1,10 @@
PRGNAM="beets"
-VERSION="2.2.0"
+VERSION="2.3.0"
HOMEPAGE="http://beets.radbox.org"
-DOWNLOAD="https://github.com/beetbox/beets/archive/v2.2.0/beets-2.2.0.tar.gz"
-MD5SUM="098074919e2c201e98a7f2ced53a47ac"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/b/beets/beets-2.3.0.tar.gz"
+MD5SUM="d372580476e17cbacf0f2524a147ada2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Sphinx munkres Unidecode musicbrainzngs jellyfish python3-confuse python3-mediafile python3-py7zr pylast pyacoustid Flask gst-python python3-platformdirs"
+REQUIRES="Sphinx munkres Unidecode musicbrainzngs jellyfish python3-confuse python3-mediafile python3-py7zr pylast pyacoustid Flask gst-python python3-platformdirs python3-lap"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"