summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Lockywolf <for_sbo.python3-inotify-simple_2023-11-29@lockywolf.net>2023-11-30 22:37:51 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-11-30 23:00:12 +0700
commitdf8cf1df4d088cc7d80cc1b7a91f72104e1787ea (patch)
treeb5b0370e7460800cf68efb5dac9973daa1f743c5
parent4481e8774704d67c5bf33079c386cbf6aa6cd3d9 (diff)
downloadslackbuilds-df8cf1df4d088cc7d80cc1b7a91f72104e1787ea.tar.gz
slackbuilds-df8cf1df4d088cc7d80cc1b7a91f72104e1787ea.tar.xz
python/python3-inotify-simple: Added (inotify wrapper).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-inotify-simple/README13
-rw-r--r--python/python3-inotify-simple/python3-inotify-simple.SlackBuild96
-rw-r--r--python/python3-inotify-simple/python3-inotify-simple.info10
-rw-r--r--python/python3-inotify-simple/slack-desc19
4 files changed, 138 insertions, 0 deletions
diff --git a/python/python3-inotify-simple/README b/python/python3-inotify-simple/README
new file mode 100644
index 0000000000..900ee4f89e
--- /dev/null
+++ b/python/python3-inotify-simple/README
@@ -0,0 +1,13 @@
+inotify-simple
+
+inotify_simple is a simple Python wrapper around inotify. No fancy bells
+and whistles, just a literal wrapper with ctypes. Only ~100 lines of
+code!
+
+inotify_init1() is wrapped as a file-like object, INotify(), holding the
+inotify file descriptor. INotify().read() reads available data from the
+file descriptor and returns events as namedtuple objects after unpacking
+them with the struct module. inotify_add_watch() and inotify_rm_watch()
+are wrapped with no changes at all, taking and returning watch
+descriptor integers that calling code is expected to keep track of
+itself, just as one would use inotify from C.
diff --git a/python/python3-inotify-simple/python3-inotify-simple.SlackBuild b/python/python3-inotify-simple/python3-inotify-simple.SlackBuild
new file mode 100644
index 0000000000..7bb35fe139
--- /dev/null
+++ b/python/python3-inotify-simple/python3-inotify-simple.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for python3-inotify-simple
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-inotify-simple
+TARNAM=inotify_simple
+VERSION=${VERSION:-1.3.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TARNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-inotify-simple/python3-inotify-simple.info b/python/python3-inotify-simple/python3-inotify-simple.info
new file mode 100644
index 0000000000..64e0ed6cee
--- /dev/null
+++ b/python/python3-inotify-simple/python3-inotify-simple.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-inotify-simple"
+VERSION="1.3.5"
+HOMEPAGE="https://pypi.org/project/inotify-simple/"
+DOWNLOAD="https://files.pythonhosted.org/packages/51/41/59ca6011f5463d5e5eefcfed2e7fe470922d3a958b7f3aad95eda208d7d3/inotify_simple-1.3.5.tar.gz"
+MD5SUM="b7ca2ffa816dea85ef5023cde4e72b8b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-inotify-simple_2023-11-29@lockywolf.net"
diff --git a/python/python3-inotify-simple/slack-desc b/python/python3-inotify-simple/slack-desc
new file mode 100644
index 0000000000..7a8fef0e98
--- /dev/null
+++ b/python/python3-inotify-simple/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-inotify-simple: python3-inotify-simple (Python wrapper around inotify)
+python3-inotify-simple:
+python3-inotify-simple: inotify_simple is a simple Python wrapper around inotify. No fancy
+python3-inotify-simple: bells and whistles, just a literal wrapper with ctypes.
+python3-inotify-simple:
+python3-inotify-simple:
+python3-inotify-simple:
+python3-inotify-simple:
+python3-inotify-simple:
+python3-inotify-simple:
+python3-inotify-simple: