summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2022-06-04 03:02:36 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-06-04 10:37:13 +0700
commite1fddc6de1d3dd74823ca00eb4b2c3b4f4cced5f (patch)
tree822a1996588856cab1092b7833a9660ff6e1a29d
parentca85f526ed34f9daf7f00ca32cf8e983fd1e3f38 (diff)
downloadslackbuilds-e1fddc6de1d3dd74823ca00eb4b2c3b4f4cced5f.tar.gz
slackbuilds-e1fddc6de1d3dd74823ca00eb4b2c3b4f4cced5f.tar.xz
python/python3-jaraco.functools: Added (Additional functools)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-jaraco.functools/README1
-rw-r--r--python/python3-jaraco.functools/python3-jaraco.functools.SlackBuild96
-rw-r--r--python/python3-jaraco.functools/python3-jaraco.functools.info10
-rw-r--r--python/python3-jaraco.functools/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/python3-jaraco.functools/README b/python/python3-jaraco.functools/README
new file mode 100644
index 0000000000..e26a187379
--- /dev/null
+++ b/python/python3-jaraco.functools/README
@@ -0,0 +1 @@
+python3-jaraco.functools (Additional functools like stdlibs functools)
diff --git a/python/python3-jaraco.functools/python3-jaraco.functools.SlackBuild b/python/python3-jaraco.functools/python3-jaraco.functools.SlackBuild
new file mode 100644
index 0000000000..726eccd15d
--- /dev/null
+++ b/python/python3-jaraco.functools/python3-jaraco.functools.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for python3-jaraco.functools
+
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-jaraco.functools
+SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
+VERSION=${VERSION:-3.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-jaraco.functools/python3-jaraco.functools.info b/python/python3-jaraco.functools/python3-jaraco.functools.info
new file mode 100644
index 0000000000..9ec941fbf3
--- /dev/null
+++ b/python/python3-jaraco.functools/python3-jaraco.functools.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-jaraco.functools"
+VERSION="3.5.0"
+HOMEPAGE="https://github.com/jaraco/jaraco.functools"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jaraco.functools/jaraco.functools-3.5.0.tar.gz"
+MD5SUM="4577c96918dffc0c61ad9ce18edfb13d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-more-itertools"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-jaraco.functools/slack-desc b/python/python3-jaraco.functools/slack-desc
new file mode 100644
index 0000000000..fadbe338d9
--- /dev/null
+++ b/python/python3-jaraco.functools/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-jaraco.functools: python3-jaraco.functools (Additional functools like stdlibs functools)
+python3-jaraco.functools:
+python3-jaraco.functools: Additional functools in the spirit of stdlib's functools.
+python3-jaraco.functools:
+python3-jaraco.functools: Homepage: https://github.com/jaraco/jaraco.functools
+python3-jaraco.functools:
+python3-jaraco.functools:
+python3-jaraco.functools:
+python3-jaraco.functools:
+python3-jaraco.functools:
+python3-jaraco.functools: