summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-05-23 23:40:41 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-05-23 23:40:41 +0700
commitf9b270ccc5a6b21fdc420f2cf4752d8a4a1e6465 (patch)
tree3a22a0649f8de802c24b9971adf7fdcb8c7d1f42
parent7024257cfff8c57bf2f69e95a332b9faff1643fb (diff)
downloadslackbuilds-f9b270ccc5a6b21fdc420f2cf4752d8a4a1e6465.tar.gz
slackbuilds-f9b270ccc5a6b21fdc420f2cf4752d8a4a1e6465.tar.xz
python/python-futures: Removed (duplicate).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-futures/README3
-rw-r--r--python/python-futures/python-futures.SlackBuild91
-rw-r--r--python/python-futures/python-futures.info10
-rw-r--r--python/python-futures/slack-desc19
4 files changed, 0 insertions, 123 deletions
diff --git a/python/python-futures/README b/python/python-futures/README
deleted file mode 100644
index 6d34208749..0000000000
--- a/python/python-futures/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Backport of the concurrent.futures package to Python 2.6 and 2.7.
-The concurrent.futures module provides a high-level interface for
-asynchronously executing callables.
diff --git a/python/python-futures/python-futures.SlackBuild b/python/python-futures/python-futures.SlackBuild
deleted file mode 100644
index eb9da7d282..0000000000
--- a/python/python-futures/python-futures.SlackBuild
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-futures
-
-# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-futures
-SRCNAM=futures
-VERSION=${VERSION:-3.0.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Add link to online documentation
-cat > $PKG/usr/doc/$PRGNAM-$VERSION/DOCS <<EOF
-Documentation: https://pythonhosted.org/futures/
-EOF
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-futures/python-futures.info b/python/python-futures/python-futures.info
deleted file mode 100644
index a66d90cd16..0000000000
--- a/python/python-futures/python-futures.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-futures"
-VERSION="3.0.3"
-HOMEPAGE="https://github.com/agronholm/pythonfutures"
-DOWNLOAD="https://pypi.python.org/packages/source/f/futures/futures-3.0.3.tar.gz"
-MD5SUM="32171f72af7e80c266310794adc4db46"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Brenton Earl"
-EMAIL="brent@exitstatusone.com"
diff --git a/python/python-futures/slack-desc b/python/python-futures/slack-desc
deleted file mode 100644
index d602cdd945..0000000000
--- a/python/python-futures/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-futures: python-futures (Backport of the concurrent.futures package)
-python-futures:
-python-futures: Backport of the concurrent.futures package to Python 2.6
-python-futures: and 2.7. The concurrent.futures module provides a high-level
-python-futures: interface for asynchronously executing callables.
-python-futures:
-python-futures: Home page: https://github.com/agronholm/pythonfutures
-python-futures:
-python-futures:
-python-futures:
-python-futures: