summaryrefslogtreecommitdiffstats
path: root/academic/bowtie/patches
diff options
context:
space:
mode:
author Petar Petrov <petar.petrov@student.oulu.fi>2013-12-14 07:31:21 +0700
committer Erik Hanson <erik@slackbuilds.org>2013-12-14 10:53:05 -0600
commit70013017755f78c0636a880522351dc5b588277e (patch)
treeeac41e23ff997e41eb9b813e8fed747f6d8ac8ea /academic/bowtie/patches
parentca3a131931b1c0a9fca77630daddd3349048a569 (diff)
downloadslackbuilds-70013017755f78c0636a880522351dc5b588277e.tar.gz
slackbuilds-70013017755f78c0636a880522351dc5b588277e.tar.xz
academic/bowtie: Updated for version 1.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/bowtie/patches')
-rw-r--r--academic/bowtie/patches/disable_bits_flag.patch20
-rw-r--r--academic/bowtie/patches/no_hash_style_both_for_mips.patch20
-rw-r--r--academic/bowtie/patches/seqan-fix-setBegin-call.patch42
-rw-r--r--academic/bowtie/patches/use-dpkg-buildflags.patch17
4 files changed, 99 insertions, 0 deletions
diff --git a/academic/bowtie/patches/disable_bits_flag.patch b/academic/bowtie/patches/disable_bits_flag.patch
new file mode 100644
index 0000000000..3d849240e7
--- /dev/null
+++ b/academic/bowtie/patches/disable_bits_flag.patch
@@ -0,0 +1,20 @@
+Description: Disable architecture bits detection.
+ In Debian, you can use multiarch facilities for choosing which version
+ to run.
+Author: Ognyan Kulev <ogi@debian.org>
+Forwarded: not-needed
+Last-Update: 2013-04-24
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- bowtie-1.0.0.orig/Makefile
++++ bowtie-1.0.0/Makefile
+@@ -121,6 +121,9 @@
+ BITS_FLAG = -m64
+ endif
+
++# Debian: Disable selection of 32/64-bits. Use multiarch instead.
++BITS_FLAG =
++
+ DEBUG_FLAGS = -O0 -g3 $(BITS_FLAG)
+ RELEASE_FLAGS = -O3 $(BITS_FLAG)
+ NOASSERT_FLAGS = -DNDEBUG
diff --git a/academic/bowtie/patches/no_hash_style_both_for_mips.patch b/academic/bowtie/patches/no_hash_style_both_for_mips.patch
new file mode 100644
index 0000000000..c7f8ab32e1
--- /dev/null
+++ b/academic/bowtie/patches/no_hash_style_both_for_mips.patch
@@ -0,0 +1,20 @@
+Description: Disable -Wl,--hash-style=both on mips machines.
+ It's not supported on mips and mipsel ports and leads to build errors.
+Author: Ognyan Kulev <ogi@debian.org>
+Forwarded: not-needed
+Last-Update: 2013-04-24
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- bowtie-1.0.0.orig/Makefile
++++ bowtie-1.0.0/Makefile
+@@ -45,7 +45,9 @@
+ LINUX = 0
+ ifneq (,$(findstring Linux,$(shell uname)))
+ LINUX = 1
+- EXTRA_FLAGS += -Wl,--hash-style=both
++ ifeq (,$(findstring mips,$(shell uname -m)))
++ EXTRA_FLAGS += -Wl,--hash-style=both
++ endif
+ endif
+
+ MM_DEF =
diff --git a/academic/bowtie/patches/seqan-fix-setBegin-call.patch b/academic/bowtie/patches/seqan-fix-setBegin-call.patch
new file mode 100644
index 0000000000..56c8763117
--- /dev/null
+++ b/academic/bowtie/patches/seqan-fix-setBegin-call.patch
@@ -0,0 +1,42 @@
+Description: Proper type-casting in using seqan::_setBegin().
+ Required by newer versions of GCC.
+Forwarded: no
+Author: Ognyan Kulev <ogi@debian.org>
+Last-Update: 2013-04-18
+
+--- a/pat.h
++++ b/pat.h
+@@ -82,20 +82,20 @@
+ ~ReadBuf() {
+ clearAll(); reset();
+ // Prevent seqan from trying to free buffers
+- _setBegin(patFw, NULL);
+- _setBegin(patRc, NULL);
+- _setBegin(qual, NULL);
+- _setBegin(patFwRev, NULL);
+- _setBegin(patRcRev, NULL);
+- _setBegin(qualRev, NULL);
+- _setBegin(name, NULL);
++ _setBegin(patFw, (Dna5*)NULL);
++ _setBegin(patRc, (Dna5*)NULL);
++ _setBegin(qual, (char*)NULL);
++ _setBegin(patFwRev, (Dna5*)NULL);
++ _setBegin(patRcRev, (Dna5*)NULL);
++ _setBegin(qualRev, (char*)NULL);
++ _setBegin(name, (char*)NULL);
+ for(int j = 0; j < 3; j++) {
+- _setBegin(altPatFw[j], NULL);
+- _setBegin(altPatFwRev[j], NULL);
+- _setBegin(altPatRc[j], NULL);
+- _setBegin(altPatRcRev[j], NULL);
+- _setBegin(altQual[j], NULL);
+- _setBegin(altQualRev[j], NULL);
++ _setBegin(altPatFw[j], (Dna5*)NULL);
++ _setBegin(altPatFwRev[j], (Dna5*)NULL);
++ _setBegin(altPatRc[j], (Dna5*)NULL);
++ _setBegin(altPatRcRev[j], (Dna5*)NULL);
++ _setBegin(altQual[j], (char*)NULL);
++ _setBegin(altQualRev[j], (char*)NULL);
+ }
+ }
+
diff --git a/academic/bowtie/patches/use-dpkg-buildflags.patch b/academic/bowtie/patches/use-dpkg-buildflags.patch
new file mode 100644
index 0000000000..7225d19af2
--- /dev/null
+++ b/academic/bowtie/patches/use-dpkg-buildflags.patch
@@ -0,0 +1,17 @@
+Description: Use build flags from environment (dpkg-buildflags).
+ Necessary for hardening flags.
+Author: Simon Ruderich <simon@ruderich.org>
+Last-Update: 2012-04-24
+Bug-Closed: http://bugs.debian.org/670230
+
+--- a/Makefile
++++ b/Makefile
+@@ -173,7 +173,7 @@
+ $(MM_DEF) \
+ $(SHMEM_DEF)
+
+-ALL_FLAGS = $(EXTRA_FLAGS) $(CFLAGS) $(CXXFLAGS)
++ALL_FLAGS = $(EXTRA_FLAGS) $(CPPFLAGS) $(CFLAGS) $(CXXFLAGS) $(LDFLAGS)
+ DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(DEBUG_FLAGS) $(ALL_FLAGS)\""
+ RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(RELEASE_FLAGS) $(ALL_FLAGS)\""
+