summaryrefslogtreecommitdiffstats
path: root/academic/octave/octave.SlackBuild
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2013-04-14 21:35:05 -0500
committer Robby Workman <rworkman@slackbuilds.org>2013-04-15 17:20:36 -0500
commitad069ff4531060ef8cd0b0bf44b1bf592c4b4914 (patch)
tree1f6509a1d522060b2851a60227644beef74c8a4e /academic/octave/octave.SlackBuild
parentc9dc74aebd8115e2e600b5baa47c7ef8f68a02e6 (diff)
downloadslackbuilds-ad069ff4531060ef8cd0b0bf44b1bf592c4b4914.tar.gz
slackbuilds-ad069ff4531060ef8cd0b0bf44b1bf592c4b4914.tar.xz
academic/octave: Updated for version 3.6.4.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic/octave/octave.SlackBuild')
-rw-r--r--academic/octave/octave.SlackBuild26
1 files changed, 8 insertions, 18 deletions
diff --git a/academic/octave/octave.SlackBuild b/academic/octave/octave.SlackBuild
index 0e2b9552c9..3f85721317 100644
--- a/academic/octave/octave.SlackBuild
+++ b/academic/octave/octave.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for octave
-# Copyright 2012 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2012-2013 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=octave
-VERSION=${VERSION:-3.6.3}
+VERSION=${VERSION:-3.6.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -67,6 +67,10 @@ fi
# Larger values will make your Magick package slower and use more memory.
WITH_MAGICK=${WITH_MAGICK:-ImageMagick} # alternatively, "GraphicsMagick"
+# umfpack.h includes amd.h, which may be installed outside of the standard
+# search dirs if you use the SBo packages. This ensures UMFPACK is found.
+WITH_AMD_INCLUDEDIR=${WITH_AMD_INCLUDEDIR:-/usr/include/amd}
+
set -e
rm -rf $PKG
@@ -76,21 +80,7 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-st .
-
-# Several configure checks look for headers in the 'amd' directory
-# instead of 'cxsparse', 'camd', 'colamd', and 'ccolamd' directories
-# as liboctave/oct-sparse.h expects. Fix the typos and reconfigure.
-# Note that camd.h doesn't appear to be included anywhere, but is used
-# to determine if the CAMD library is present.
-sed -i -e 's| amd/cs\.h| cxsparse/cs.h|' \
- -e 's| amd/camd\.h| camd/camd.h|' \
- -e 's| amd/colamd\.h| colamd/colamd.h|' \
- -e 's| amd/ccolamd\.h| ccolamd/ccolamd.h|' configure.ac
-autoreconf -vif
-# If you have amd.h in some non-default location (e.g. /usr/include/amd/amd.h)
-# now the check for umfpack.h will fail because umfpack.h includes "amd.h"
-# instead of "amd/amd.h". The --with-amd-includedir option below fixes this.
+chmod -R u+w,go-w,a+rX-st .
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -107,7 +97,7 @@ FFLAGS="$SLKCFLAGS" \
--disable-static \
--enable-strict-warning-flags \
--with-magick=$WITH_MAGICK \
- --with-amd-includedir=/usr/include/amd \
+ --with-amd-includedir=$WITH_AMD_INCLUDEDIR \
--build=$ARCH-slackware-linux
make