summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2017-07-04 16:09:14 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-08 07:11:37 +0700
commit791c6a8c344ada57c8a24ed99161d6279ac3b546 (patch)
tree662954b3fb38ef6450d2d7338ecf754dab5c4cc1 /academic
parentdb0d30e8dbcf3f1ee415bcc3b7ed40af50279a16 (diff)
downloadslackbuilds-791c6a8c344ada57c8a24ed99161d6279ac3b546.tar.gz
slackbuilds-791c6a8c344ada57c8a24ed99161d6279ac3b546.tar.xz
academic/umfpack: BUILD bump for SuiteSparse 4.5.5.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
Diffstat (limited to 'academic')
-rw-r--r--academic/umfpack/patches/autoconfiscate.diff (renamed from academic/umfpack/patches/autotoolize.diff)605
-rw-r--r--academic/umfpack/umfpack.SlackBuild14
-rw-r--r--academic/umfpack/umfpack.info4
3 files changed, 522 insertions, 101 deletions
diff --git a/academic/umfpack/patches/autotoolize.diff b/academic/umfpack/patches/autoconfiscate.diff
index 12ebc41fc2..ccc8ee5596 100644
--- a/academic/umfpack/patches/autotoolize.diff
+++ b/academic/umfpack/patches/autoconfiscate.diff
@@ -2,9 +2,8 @@ diff --git a/Demo/Makefile.am b/Demo/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Demo/Makefile.am
-@@ -0,0 +1,152 @@
+@@ -0,0 +1,162 @@
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(AMD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
-+LDADD = $(top_builddir)/Source/libumfpack.la
+
+EXTRA_DIST = \
+ umfpack_di_demo.out \
@@ -78,41 +77,52 @@ new file mode 100644
+ libumf4_f77zwrapper64.la
+
+umfpack_simple_SOURCES = umfpack_simple.c
++umfpack_simple_LDADD = $(top_builddir)/Source/libumfpack.la
++
+umfpack_di_demo_SOURCES = umfpack_di_demo.c
++umfpack_di_demo_LDADD = $(top_builddir)/Source/libumfpack.la
++
+umfpack_dl_demo_SOURCES = umfpack_dl_demo.c
++umfpack_dl_demo_LDADD = $(top_builddir)/Source/libumfpack.la
++
+umfpack_zi_demo_SOURCES = umfpack_zi_demo.c
++umfpack_zi_demo_LDADD = $(top_builddir)/Source/libumfpack.la
++
+umfpack_zl_demo_SOURCES = umfpack_zl_demo.c
++umfpack_zl_demo_LDADD = $(top_builddir)/Source/libumfpack.la
+
+readhb_SOURCES = readhb.f
-+readhb_LDADD =
+
+readhb_nozeros_SOURCES = readhb_nozeros.f
-+readhb_nozeros_LDADD =
+
+readhb_size_SOURCES = readhb_size.f
-+readhb_size_LDADD =
+
+umf4_SOURCES = umf4.c
++umf4_LDADD = $(top_builddir)/Source/libumfpack.la $(AMD_LIBS)
+
+umf4hb_SOURCES = umf4hb.f
-+umf4hb_LDADD = libumf4_f77wrapper.la $(LDADD)
++umf4hb_LDADD = libumf4_f77wrapper.la
+
+umf4zhb_SOURCES = umf4zhb.f
-+umf4zhb_LDADD = libumf4_f77zwrapper.la $(LDADD)
++umf4zhb_LDADD = libumf4_f77zwrapper.la
+
+umf4hb64_SOURCES = umf4hb64.f
-+umf4hb64_LDADD = libumf4_f77wrapper64.la $(LDADD)
++umf4hb64_LDADD = libumf4_f77wrapper64.la
+
+libumf4_f77wrapper_la_SOURCES = umf4_f77wrapper.c
++libumf4_f77wrapper_la_LIBADD = $(top_builddir)/Source/libumfpack.la
+libumf4_f77wrapper_la_CPPFLAGS = $(AM_CPPFLAGS)
+
+libumf4_f77zwrapper_la_SOURCES = umf4_f77zwrapper.c
++libumf4_f77zwrapper_la_LIBADD = $(top_builddir)/Source/libumfpack.la
+libumf4_f77zwrapper_la_CPPFLAGS = $(AM_CPPFLAGS)
+
+libumf4_f77wrapper64_la_SOURCES = umf4_f77wrapper.c
++libumf4_f77wrapper64_la_LIBADD = $(top_builddir)/Source/libumfpack.la
+libumf4_f77wrapper64_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
+
+libumf4_f77zwrapper64_la_SOURCES = umf4_f77zwrapper.c
++libumf4_f77zwrapper64_la_LIBADD = $(top_builddir)/Source/libumfpack.la
+libumf4_f77zwrapper64_la_CPPFLAGS = $(AM_CPPFLAGS) -DZLONG
+
+check-local: $(SIMPLE) $(DEMO) $(DEMO:=.out) $(READHB) $(HB) $(UMF4) $(UMF4HB) $(UMF4HB:=.out)
@@ -304,17 +314,27 @@ diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
-@@ -0,0 +1,4 @@
-+SUBDIRS = Include Source Demo Doc
+@@ -0,0 +1,9 @@
++ACLOCAL_AMFLAGS = -I m4
++
++SUBDIRS = Include Source Demo Tcov Doc
+EXTRA_DIST = README.txt
+
+pkgconfig_DATA = umfpack.pc
++
++CODE_COVERAGE_BRANCH_COVERAGE = 1
++@CODE_COVERAGE_RULES@
diff --git a/Source/Makefile.am b/Source/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Source/Makefile.am
-@@ -0,0 +1,318 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include $(CHOLMOD_CFLAGS) $(AMD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
+@@ -0,0 +1,323 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(CHOLMOD_CFLAGS) $(AMD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS) $(CODE_COVERAGE_CPPFLAGS)
++AM_CFLAGS = $(CODE_COVERAGE_CFLAGS)
++
++if CODE_COVERAGE_ENABLED
++AM_CPPFLAGS += -DTESTING
++endif
+
+# non-user-callable umf_*.[ch] files:
+UMF = \
@@ -630,15 +650,225 @@ new file mode 100644
+ libumf_dl.la libumfpack_dl.la \
+ libumf_zi.la libumfpack_zi.la \
+ libumf_zl.la libumfpack_zl.la \
-+ $(AMD_LIBS) $(SUITESPARSECONFIG_LIBS) $(BLAS_LIBS) -lm
++ $(AMD_LIBS) $(SUITESPARSECONFIG_LIBS) $(BLAS_LIBS) -lm $(CODE_COVERAGE_LIBS)
+libumfpack_la_LDFLAGS = -no-undefined -release $(PACKAGE_VERSION)
-diff --git a/ax_blas.m4 b/ax_blas.m4
+diff --git a/Tcov/Makefile.am b/Tcov/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Tcov/Makefile.am
+@@ -0,0 +1,83 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include -I$(top_srcdir)/Source $(AMD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
++
++EXTRA_DIST = \
++ README.txt
++
++dist_noinst_DATA = \
++ badnum.umf \
++ badnum2.umf \
++ badsym.umf \
++ badsym2.umf \
++ TestMat/S_d2q06c \
++ TestMat/adlittle \
++ TestMat/arc130 \
++ TestMat/cage3 \
++ TestMat/d_dyn \
++ TestMat/galenet \
++ TestMat/matrix1 \
++ TestMat/matrix2 \
++ TestMat/matrix3 \
++ TestMat/matrix4 \
++ TestMat/matrix5 \
++ TestMat/matrix6 \
++ TestMat/matrix7 \
++ TestMat/matrix8 \
++ TestMat/matrix10 \
++ TestMat/matrix11 \
++ TestMat/matrix12 \
++ TestMat/matrix13 \
++ TestMat/matrix14 \
++ TestMat/matrix15 \
++ TestMat/matrix16 \
++ TestMat/matrix17 \
++ TestMat/matrix18 \
++ TestMat/matrix19 \
++ TestMat/matrix20 \
++ TestMat/matrix21 \
++ TestMat/matrix22 \
++ TestMat/matrix23 \
++ TestMat/matrix24 \
++ TestMat/matrix25 \
++ TestMat/matrix26 \
++ TestMat/matrix27 \
++ TestMat/matrix28 \
++ TestMat/matrix29 \
++ TestMat/matrix30 \
++ TestMat/nug07 \
++ TestMat/shl0
++
++if CODE_COVERAGE_ENABLED
++# TODO: Support the various flag combinations in the Make.# files.
++# Probably requires copying them to Source/Makefile.am and rebuilding all.
++AM_CPPFLAGS += -DTESTING
++
++check_PROGRAMS = \
++ ut_di \
++ ut_dl \
++ ut_zi \
++ ut_zl
++
++ut_di_SOURCES = ut.c
++ut_di_LDADD = $(top_builddir)/Source/libumfpack.la $(AMD_LIBS) $(SUITESPARSECONFIG_LIBS) -lm
++ut_di_CPPFLAGS = $(AM_CPPFLAGS) -DDINT
++
++ut_dl_SOURCES = ut.c
++ut_dl_LDADD = $(top_builddir)/Source/libumfpack.la $(AMD_LIBS) $(SUITESPARSECONFIG_LIBS) -lm
++ut_dl_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++ut_zi_SOURCES = ut.c
++ut_zi_LDADD = $(top_builddir)/Source/libumfpack.la $(AMD_LIBS) $(SUITESPARSECONFIG_LIBS) -lm
++ut_zi_CPPFLAGS = $(AM_CPPFLAGS) -DZINT
++
++ut_zl_SOURCES = ut.c
++ut_zl_LDADD = $(top_builddir)/Source/libumfpack.la $(AMD_LIBS) $(SUITESPARSECONFIG_LIBS) -lm
++ut_zl_CPPFLAGS = $(AM_CPPFLAGS) -DZLONG
++
++check-local: $(check_PROGRAMS)
++ ./ut_di > ut_di.out
++ ./ut_dl > ut_dl.out
++ ./ut_zi > ut_zi.out
++ ./ut_zl > ut_zl.out
++endif
++
++CLEANFILES = A500 n.umf numeric.umf s.umf symbolic.umf debug.amd debug.umf *.out
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,117 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([UMFPACK],[5.7.6],[DrTimothyAldenDavis@gmail.com],[umfpack],[http://www.suitesparse.com/])
++AC_CONFIG_SRCDIR([Source/umfpack_solve.c])
++AC_CONFIG_AUX_DIR([build-aux])
++AC_CONFIG_MACRO_DIR([m4])
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE([foreign])
++AM_SILENT_RULES([yes])
++LT_INIT([disable-static])
++
++# Checks for programs.
++PKG_PROG_PKG_CONFIG
++AC_PROG_INSTALL
++AC_PROG_CC
++AC_PROG_F77
++AX_CODE_COVERAGE
++
++AC_ARG_WITH([cholmod],
++ [AS_HELP_STRING(
++ [--without-cholmod],
++ [do not use CHOLMOD for ordering methods])],
++ [],
++ [AS_VAR_SET([with_cholmod], [yes])])
++
++AS_VAR_SET([LIBS_SAVED], [$LIBS])
++
++# Checks for libraries.
++AC_CHECK_LIB([m], [sqrt])
++
++AX_BLAS(
++ [],
++ [AC_MSG_ERROR([cannot find BLAS])])
++
++PKG_CHECK_MODULES([SUITESPARSECONFIG], [suitesparseconfig])
++PKG_CHECK_MODULES([AMD], [amd])
++AS_VAR_SET([UMFPACK_REQUIRES], ["suitesparseconfig amd"])
++
++AS_IF([test "x$with_cholmod" = "xyes"], [
++ PKG_CHECK_MODULES([CHOLMOD], [cholmod])
++ AS_VAR_APPEND([UMFPACK_REQUIRES], [" cholmod"])
++])
++
++# Checks for header files.
++AC_CHECK_HEADERS([float.h stdlib.h string.h])
++
++# Checks for typedefs, structures, and compiler characteristics.
++AC_TYPE_SIZE_T
++
++# Checks for library functions.
++AC_FUNC_ERROR_AT_LINE
++AC_FUNC_MALLOC
++AC_CHECK_FUNCS([pow sqrt])
++
++AS_VAR_SET([LIBS], [$LIBS_SAVED])
++
++AC_MSG_CHECKING([whether to use CHOLMOD for ordering methods])
++AC_MSG_RESULT([$with_cholmod])
++AM_CONDITIONAL([CHOLMOD], [test "x$with_cholmod" = "xyes"])
++
++AC_SUBST([UMFPACK_REQUIRES])
++
++PKG_INSTALLDIR
++AC_CONFIG_FILES([
++ umfpack.pc
++ Makefile
++ Demo/Makefile
++ Doc/Makefile
++ Include/Makefile
++ Source/Makefile
++ Tcov/Makefile
++])
++AC_CONFIG_LINKS([Tcov/badnum.umf:Tcov/badnum.umf])
++AC_CONFIG_LINKS([Tcov/badnum2.umf:Tcov/badnum2.umf])
++AC_CONFIG_LINKS([Tcov/badsym.umf:Tcov/badsym.umf])
++AC_CONFIG_LINKS([Tcov/badsym2.umf:Tcov/badsym2.umf])
++#AC_CONFIG_LINKS([Tcov/TestMat:Tcov/TestMat]) # Can't link an entire directory?
++AC_CONFIG_LINKS([Tcov/TestMat/S_d2q06c:Tcov/TestMat/S_d2q06c])
++AC_CONFIG_LINKS([Tcov/TestMat/adlittle:Tcov/TestMat/adlittle])
++AC_CONFIG_LINKS([Tcov/TestMat/arc130:Tcov/TestMat/arc130])
++AC_CONFIG_LINKS([Tcov/TestMat/cage3:Tcov/TestMat/cage3])
++AC_CONFIG_LINKS([Tcov/TestMat/d_dyn:Tcov/TestMat/d_dyn])
++AC_CONFIG_LINKS([Tcov/TestMat/galenet:Tcov/TestMat/galenet])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix1:Tcov/TestMat/matrix1])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix2:Tcov/TestMat/matrix2])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix3:Tcov/TestMat/matrix3])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix4:Tcov/TestMat/matrix4])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix5:Tcov/TestMat/matrix5])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix6:Tcov/TestMat/matrix6])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix7:Tcov/TestMat/matrix7])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix8:Tcov/TestMat/matrix8])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix10:Tcov/TestMat/matrix10])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix11:Tcov/TestMat/matrix11])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix12:Tcov/TestMat/matrix12])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix13:Tcov/TestMat/matrix13])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix14:Tcov/TestMat/matrix14])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix15:Tcov/TestMat/matrix15])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix16:Tcov/TestMat/matrix16])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix17:Tcov/TestMat/matrix17])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix18:Tcov/TestMat/matrix18])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix19:Tcov/TestMat/matrix19])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix20:Tcov/TestMat/matrix20])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix21:Tcov/TestMat/matrix21])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix22:Tcov/TestMat/matrix22])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix23:Tcov/TestMat/matrix23])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix24:Tcov/TestMat/matrix24])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix25:Tcov/TestMat/matrix25])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix26:Tcov/TestMat/matrix26])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix27:Tcov/TestMat/matrix27])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix28:Tcov/TestMat/matrix28])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix29:Tcov/TestMat/matrix29])
++AC_CONFIG_LINKS([Tcov/TestMat/matrix30:Tcov/TestMat/matrix30])
++AC_CONFIG_LINKS([Tcov/TestMat/nug07:Tcov/TestMat/nug07])
++AC_CONFIG_LINKS([Tcov/TestMat/shl0:Tcov/TestMat/shl0])
++AC_OUTPUT
+diff --git a/m4/ax_blas.m4 b/m4/ax_blas.m4
new file mode 100644
--- /dev/null
-+++ b/ax_blas.m4
++++ b/m4/ax_blas.m4
@@ -0,0 +1,238 @@
+# ===========================================================================
-+# http://www.gnu.org/software/autoconf-archive/ax_blas.html
++# https://www.gnu.org/software/autoconf-archive/ax_blas.html
+# ===========================================================================
+#
+# SYNOPSIS
@@ -687,7 +917,7 @@ new file mode 100644
+# Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
-+# with this program. If not, see <http://www.gnu.org/licenses/>.
++# with this program. If not, see <https://www.gnu.org/licenses/>.
+#
+# As a special exception, the respective Autoconf Macro's copyright owner
+# gives unlimited permission to copy, distribute and modify the configure
@@ -702,7 +932,7 @@ new file mode 100644
+# modified version of the Autoconf Macro, you may extend this special
+# exception to the GPL to apply to your modified version as well.
+
-+#serial 14
++#serial 15
+
+AU_ALIAS([ACX_BLAS], [AX_BLAS])
+AC_DEFUN([AX_BLAS], [
@@ -875,82 +1105,275 @@ new file mode 100644
+ $2
+fi
+])dnl AX_BLAS
-diff --git a/configure.ac b/configure.ac
+diff --git a/m4/ax_code_coverage.m4 b/m4/ax_code_coverage.m4
new file mode 100644
--- /dev/null
-+++ b/configure.ac
-@@ -0,0 +1,71 @@
-+# -*- Autoconf -*-
-+# Process this file with autoconf to produce a configure script.
-+
-+AC_PREREQ([2.69])
-+AC_INIT([UMFPACK],[5.7.6],[DrTimothyAldenDavis@gmail.com],[umfpack],[http://www.suitesparse.com/])
-+AC_CONFIG_SRCDIR([Source/umfpack_solve.c])
-+AC_CONFIG_HEADERS([config.h])
-+AM_INIT_AUTOMAKE([foreign])
-+LT_INIT
-+
-+# Checks for programs.
-+PKG_PROG_PKG_CONFIG
-+AC_PROG_INSTALL
-+AC_PROG_CC
-+AC_PROG_F77
-+
-+AC_ARG_WITH([cholmod],
-+ [AS_HELP_STRING(
-+ [--without-cholmod],
-+ [do not use CHOLMOD for ordering methods])],
-+ [],
-+ [AS_VAR_SET([with_cholmod], [yes])])
-+
-+AS_VAR_SET([LIBS_SAVED], [$LIBS])
-+
-+# Checks for libraries.
-+AC_CHECK_LIB([m], [sqrt])
-+
-+sinclude(ax_blas.m4)
-+AX_BLAS(
-+ [],
-+ [AC_MSG_ERROR([cannot find BLAS])])
-+
-+PKG_CHECK_MODULES([SUITESPARSECONFIG], [suitesparseconfig])
-+PKG_CHECK_MODULES([AMD], [amd])
-+AS_VAR_SET([UMFPACK_REQUIRES], ["suitesparseconfig amd"])
-+
-+AS_IF([test "x$with_cholmod" = "xyes"], [
-+ PKG_CHECK_MODULES([CHOLMOD], [cholmod])
-+ AS_VAR_APPEND([UMFPACK_REQUIRES], [" cholmod"])
-+])
-+
-+# Checks for header files.
-+AC_CHECK_HEADERS([float.h stdlib.h string.h])
-+
-+# Checks for typedefs, structures, and compiler characteristics.
-+AC_TYPE_SIZE_T
-+
-+# Checks for library functions.
-+AC_FUNC_ERROR_AT_LINE
-+AC_FUNC_MALLOC
-+AC_CHECK_FUNCS([pow sqrt])
-+
-+AS_VAR_SET([LIBS], [$LIBS_SAVED])
-+
-+AC_MSG_CHECKING([whether to use CHOLMOD for ordering methods])
-+AC_MSG_RESULT([$with_cholmod])
-+AM_CONDITIONAL([CHOLMOD], [test "x$with_cholmod" = "xyes"])
-+
-+AC_SUBST([UMFPACK_REQUIRES])
-+
-+PKG_INSTALLDIR
-+AC_CONFIG_FILES([
-+ umfpack.pc
-+ Makefile
-+ Demo/Makefile
-+ Doc/Makefile
-+ Include/Makefile
-+ Source/Makefile
++++ b/m4/ax_code_coverage.m4
+@@ -0,0 +1,264 @@
++# ===========================================================================
++# https://www.gnu.org/software/autoconf-archive/ax_code_coverage.html
++# ===========================================================================
++#
++# SYNOPSIS
++#
++# AX_CODE_COVERAGE()
++#
++# DESCRIPTION
++#
++# Defines CODE_COVERAGE_CPPFLAGS, CODE_COVERAGE_CFLAGS,
++# CODE_COVERAGE_CXXFLAGS and CODE_COVERAGE_LIBS which should be included
++# in the CPPFLAGS, CFLAGS CXXFLAGS and LIBS/LIBADD variables of every
++# build target (program or library) which should be built with code
++# coverage support. Also defines CODE_COVERAGE_RULES which should be
++# substituted in your Makefile; and $enable_code_coverage which can be
++# used in subsequent configure output. CODE_COVERAGE_ENABLED is defined
++# and substituted, and corresponds to the value of the
++# --enable-code-coverage option, which defaults to being disabled.
++#
++# Test also for gcov program and create GCOV variable that could be
++# substituted.
++#
++# Note that all optimization flags in CFLAGS must be disabled when code
++# coverage is enabled.
++#
++# Usage example:
++#
++# configure.ac:
++#
++# AX_CODE_COVERAGE
++#
++# Makefile.am:
++#
++# @CODE_COVERAGE_RULES@
++# my_program_LIBS = ... $(CODE_COVERAGE_LIBS) ...
++# my_program_CPPFLAGS = ... $(CODE_COVERAGE_CPPFLAGS) ...
++# my_program_CFLAGS = ... $(CODE_COVERAGE_CFLAGS) ...
++# my_program_CXXFLAGS = ... $(CODE_COVERAGE_CXXFLAGS) ...
++#
++# This results in a "check-code-coverage" rule being added to any
++# Makefile.am which includes "@CODE_COVERAGE_RULES@" (assuming the module
++# has been configured with --enable-code-coverage). Running `make
++# check-code-coverage` in that directory will run the module's test suite
++# (`make check`) and build a code coverage report detailing the code which
++# was touched, then print the URI for the report.
++#
++# In earlier versions of this macro, CODE_COVERAGE_LDFLAGS was defined
++# instead of CODE_COVERAGE_LIBS. They are both still defined, but use of
++# CODE_COVERAGE_LIBS is preferred for clarity; CODE_COVERAGE_LDFLAGS is
++# deprecated. They have the same value.
++#
++# This code was derived from Makefile.decl in GLib, originally licenced
++# under LGPLv2.1+.
++#
++# LICENSE
++#
++# Copyright (c) 2012, 2016 Philip Withnall
++# Copyright (c) 2012 Xan Lopez
++# Copyright (c) 2012 Christian Persch
++# Copyright (c) 2012 Paolo Borelli
++# Copyright (c) 2012 Dan Winship
++# Copyright (c) 2015 Bastien ROUCARIES
++#
++# This library is free software; you can redistribute it and/or modify it
++# under the terms of the GNU Lesser General Public License as published by
++# the Free Software Foundation; either version 2.1 of the License, or (at
++# your option) any later version.
++#
++# This library is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
++# General Public License for more details.
++#
++# You should have received a copy of the GNU Lesser General Public License
++# along with this program. If not, see <https://www.gnu.org/licenses/>.
++
++#serial 24
++
++AC_DEFUN([AX_CODE_COVERAGE],[
++ dnl Check for --enable-code-coverage
++ AC_REQUIRE([AC_PROG_SED])
++
++ # allow to override gcov location
++ AC_ARG_WITH([gcov],
++ [AS_HELP_STRING([--with-gcov[=GCOV]], [use given GCOV for coverage (GCOV=gcov).])],
++ [_AX_CODE_COVERAGE_GCOV_PROG_WITH=$with_gcov],
++ [_AX_CODE_COVERAGE_GCOV_PROG_WITH=gcov])
++
++ AC_MSG_CHECKING([whether to build with code coverage support])
++ AC_ARG_ENABLE([code-coverage],
++ AS_HELP_STRING([--enable-code-coverage],
++ [Whether to enable code coverage support]),,
++ enable_code_coverage=no)
++
++ AM_CONDITIONAL([CODE_COVERAGE_ENABLED], [test x$enable_code_coverage = xyes])
++ AC_SUBST([CODE_COVERAGE_ENABLED], [$enable_code_coverage])
++ AC_MSG_RESULT($enable_code_coverage)
++
++ AS_IF([ test "$enable_code_coverage" = "yes" ], [
++ # check for gcov
++ AC_CHECK_TOOL([GCOV],
++ [$_AX_CODE_COVERAGE_GCOV_PROG_WITH],
++ [:])
++ AS_IF([test "X$GCOV" = "X:"],
++ [AC_MSG_ERROR([gcov is needed to do coverage])])
++ AC_SUBST([GCOV])
++
++ dnl Check if gcc is being used
++ AS_IF([ test "$GCC" = "no" ], [
++ AC_MSG_ERROR([not compiling with gcc, which is required for gcov code coverage])
++ ])
++
++ AC_CHECK_PROG([LCOV], [lcov], [lcov])
++ AC_CHECK_PROG([GENHTML], [genhtml], [genhtml])
++
++ AS_IF([ test -z "$LCOV" ], [
++ AC_MSG_ERROR([To enable code coverage reporting you must have lcov installed])
++ ])
++
++ AS_IF([ test -z "$GENHTML" ], [
++ AC_MSG_ERROR([Could not find genhtml from the lcov package])
++ ])
++
++ dnl Build the code coverage flags
++ dnl Define CODE_COVERAGE_LDFLAGS for backwards compatibility
++ CODE_COVERAGE_CPPFLAGS="-DNDEBUG"
++ CODE_COVERAGE_CFLAGS="-O0 -g -fprofile-arcs -ftest-coverage"
++ CODE_COVERAGE_CXXFLAGS="-O0 -g -fprofile-arcs -ftest-coverage"
++ CODE_COVERAGE_LIBS="-lgcov"
++ CODE_COVERAGE_LDFLAGS="$CODE_COVERAGE_LIBS"
++
++ AC_SUBST([CODE_COVERAGE_CPPFLAGS])
++ AC_SUBST([CODE_COVERAGE_CFLAGS])
++ AC_SUBST([CODE_COVERAGE_CXXFLAGS])
++ AC_SUBST([CODE_COVERAGE_LIBS])
++ AC_SUBST([CODE_COVERAGE_LDFLAGS])
++
++ [CODE_COVERAGE_RULES_CHECK='
++ -$(A''M_V_at)$(MAKE) $(AM_MAKEFLAGS) -k check
++ $(A''M_V_at)$(MAKE) $(AM_MAKEFLAGS) code-coverage-capture
++']
++ [CODE_COVERAGE_RULES_CAPTURE='
++ $(code_coverage_v_lcov_cap)$(LCOV) $(code_coverage_quiet) $(addprefix --directory ,$(CODE_COVERAGE_DIRECTORY)) --capture --output-file "$(CODE_COVERAGE_OUTPUT_FILE).tmp" --test-name "$(call code_coverage_sanitize,$(PACKAGE_NAME)-$(PACKAGE_VERSION))" --no-checksum --compat-libtool $(CODE_COVERAGE_LCOV_SHOPTS) $(CODE_COVERAGE_LCOV_OPTIONS)
++ $(code_coverage_v_lcov_ign)$(LCOV) $(code_coverage_quiet) $(addprefix --directory ,$(CODE_COVERAGE_DIRECTORY)) --remove "$(CODE_COVERAGE_OUTPUT_FILE).tmp" "/tmp/*" $(CODE_COVERAGE_IGNORE_PATTERN) --output-file "$(CODE_COVERAGE_OUTPUT_FILE)" $(CODE_COVERAGE_LCOV_SHOPTS) $(CODE_COVERAGE_LCOV_RMOPTS)
++ -@rm -f $(CODE_COVERAGE_OUTPUT_FILE).tmp
++ $(code_coverage_v_genhtml)LANG=C $(GENHTML) $(code_coverage_quiet) $(addprefix --prefix ,$(CODE_COVERAGE_DIRECTORY)) --output-directory "$(CODE_COVERAGE_OUTPUT_DIRECTORY)" --title "$(PACKAGE_NAME)-$(PACKAGE_VERSION) Code Coverage" --legend --show-details "$(CODE_COVERAGE_OUTPUT_FILE)" $(CODE_COVERAGE_GENHTML_OPTIONS)
++ @echo "file://$(abs_builddir)/$(CODE_COVERAGE_OUTPUT_DIRECTORY)/index.html"
++']
++ [CODE_COVERAGE_RULES_CLEAN='
++clean: code-coverage-clean
++distclean: code-coverage-clean
++code-coverage-clean:
++ -$(LCOV) --directory $(top_builddir) -z
++ -rm -rf $(CODE_COVERAGE_OUTPUT_FILE) $(CODE_COVERAGE_OUTPUT_FILE).tmp $(CODE_COVERAGE_OUTPUT_DIRECTORY)
++ -find . \( -name "*.gcda" -o -name "*.gcno" -o -name "*.gcov" \) -delete
++']
++ ], [
++ [CODE_COVERAGE_RULES_CHECK='
++ @echo "Need to reconfigure with --enable-code-coverage"
++']
++ CODE_COVERAGE_RULES_CAPTURE="$CODE_COVERAGE_RULES_CHECK"
++ CODE_COVERAGE_RULES_CLEAN=''
++ ])
++
++[CODE_COVERAGE_RULES='
++# Code coverage
++#
++# Optional:
++# - CODE_COVERAGE_DIRECTORY: Top-level directory for code coverage reporting.
++# Multiple directories may be specified, separated by whitespace.
++# (Default: $(top_builddir))
++# - CODE_COVERAGE_OUTPUT_FILE: Filename and path for the .info file generated
++# by lcov for code coverage. (Default:
++# $(PACKAGE_NAME)-$(PACKAGE_VERSION)-coverage.info)
++# - CODE_COVERAGE_OUTPUT_DIRECTORY: Directory for generated code coverage
++# reports to be created. (Default:
++# $(PACKAGE_NAME)-$(PACKAGE_VERSION)-coverage)
++# - CODE_COVERAGE_BRANCH_COVERAGE: Set to 1 to enforce branch coverage,
++# set to 0 to disable it and leave empty to stay with the default.
++# (Default: empty)
++# - CODE_COVERAGE_LCOV_SHOPTS_DEFAULT: Extra options shared between both lcov
++# instances. (Default: based on $CODE_COVERAGE_BRANCH_COVERAGE)
++# - CODE_COVERAGE_LCOV_SHOPTS: Extra options to shared between both lcov
++# instances. (Default: $CODE_COVERAGE_LCOV_SHOPTS_DEFAULT)
++# - CODE_COVERAGE_LCOV_OPTIONS_GCOVPATH: --gcov-tool pathtogcov
++# - CODE_COVERAGE_LCOV_OPTIONS_DEFAULT: Extra options to pass to the
++# collecting lcov instance. (Default: $CODE_COVERAGE_LCOV_OPTIONS_GCOVPATH)
++# - CODE_COVERAGE_LCOV_OPTIONS: Extra options to pass to the collecting lcov
++# instance. (Default: $CODE_COVERAGE_LCOV_OPTIONS_DEFAULT)
++# - CODE_COVERAGE_LCOV_RMOPTS_DEFAULT: Extra options to pass to the filtering
++# lcov instance. (Default: empty)
++# - CODE_COVERAGE_LCOV_RMOPTS: Extra options to pass to the filtering lcov
++# instance. (Default: $CODE_COVERAGE_LCOV_RMOPTS_DEFAULT)
++# - CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT: Extra options to pass to the
++# genhtml instance. (Default: based on $CODE_COVERAGE_BRANCH_COVERAGE)
++# - CODE_COVERAGE_GENHTML_OPTIONS: Extra options to pass to the genhtml
++# instance. (Default: $CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT)
++# - CODE_COVERAGE_IGNORE_PATTERN: Extra glob pattern of files to ignore
++#
++# The generated report will be titled using the $(PACKAGE_NAME) and
++# $(PACKAGE_VERSION). In order to add the current git hash to the title,
++# use the git-version-gen script, available online.
++
++# Optional variables
++CODE_COVERAGE_DIRECTORY ?= $(top_builddir)
++CODE_COVERAGE_OUTPUT_FILE ?= $(PACKAGE_NAME)-$(PACKAGE_VERSION)-coverage.info
++CODE_COVERAGE_OUTPUT_DIRECTORY ?= $(PACKAGE_NAME)-$(PACKAGE_VERSION)-coverage
++CODE_COVERAGE_BRANCH_COVERAGE ?=
++CODE_COVERAGE_LCOV_SHOPTS_DEFAULT ?= $(if $(CODE_COVERAGE_BRANCH_COVERAGE),\
++--rc lcov_branch_coverage=$(CODE_COVERAGE_BRANCH_COVERAGE))
++CODE_COVERAGE_LCOV_SHOPTS ?= $(CODE_COVERAGE_LCOV_SHOPTS_DEFAULT)
++CODE_COVERAGE_LCOV_OPTIONS_GCOVPATH ?= --gcov-tool "$(GCOV)"
++CODE_COVERAGE_LCOV_OPTIONS_DEFAULT ?= $(CODE_COVERAGE_LCOV_OPTIONS_GCOVPATH)
++CODE_COVERAGE_LCOV_OPTIONS ?= $(CODE_COVERAGE_LCOV_OPTIONS_DEFAULT)
++CODE_COVERAGE_LCOV_RMOPTS_DEFAULT ?=
++CODE_COVERAGE_LCOV_RMOPTS ?= $(CODE_COVERAGE_LCOV_RMOPTS_DEFAULT)
++CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT ?=\
++$(if $(CODE_COVERAGE_BRANCH_COVERAGE),\
++--rc genhtml_branch_coverage=$(CODE_COVERAGE_BRANCH_COVERAGE))
++CODE_COVERAGE_GENHTML_OPTIONS ?= $(CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT)
++CODE_COVERAGE_IGNORE_PATTERN ?=
++
++code_coverage_v_lcov_cap = $(code_coverage_v_lcov_cap_$(V))
++code_coverage_v_lcov_cap_ = $(code_coverage_v_lcov_cap_$(AM_DEFAULT_VERBOSITY))
++code_coverage_v_lcov_cap_0 = @echo " LCOV --capture"\
++ $(CODE_COVERAGE_OUTPUT_FILE);
++code_coverage_v_lcov_ign = $(code_coverage_v_lcov_ign_$(V))
++code_coverage_v_lcov_ign_ = $(code_coverage_v_lcov_ign_$(AM_DEFAULT_VERBOSITY))
++code_coverage_v_lcov_ign_0 = @echo " LCOV --remove /tmp/*"\
++ $(CODE_COVERAGE_IGNORE_PATTERN);
++code_coverage_v_genhtml = $(code_coverage_v_genhtml_$(V))
++code_coverage_v_genhtml_ = $(code_coverage_v_genhtml_$(AM_DEFAULT_VERBOSITY))
++code_coverage_v_genhtml_0 = @echo " GEN " $(CODE_COVERAGE_OUTPUT_DIRECTORY);
++code_coverage_quiet = $(code_coverage_quiet_$(V))
++code_coverage_quiet_ = $(code_coverage_quiet_$(AM_DEFAULT_VERBOSITY))
++code_coverage_quiet_0 = --quiet
++
++# sanitizes the test-name: replaces with underscores: dashes and dots
++code_coverage_sanitize = $(subst -,_,$(subst .,_,$(1)))
++
++# Use recursive makes in order to ignore errors during check
++check-code-coverage:'"$CODE_COVERAGE_RULES_CHECK"'
++
++# Capture code coverage data
++code-coverage-capture: code-coverage-capture-hook'"$CODE_COVERAGE_RULES_CAPTURE"'
++
++# Hook rule executed before code-coverage-capture, overridable by the user
++code-coverage-capture-hook:
++
++'"$CODE_COVERAGE_RULES_CLEAN"'
++
++GITIGNOREFILES ?=
++GITIGNOREFILES += $(CODE_COVERAGE_OUTPUT_FILE) $(CODE_COVERAGE_OUTPUT_DIRECTORY)
++
++A''M_DISTCHECK_CONFIGURE_FLAGS ?=
++A''M_DISTCHECK_CONFIGURE_FLAGS += --disable-code-coverage
++
++.PHONY: check-code-coverage code-coverage-capture code-coverage-capture-hook code-coverage-clean
++']
++
++ AC_SUBST([CODE_COVERAGE_RULES])
++ m4_ifdef([_AM_SUBST_NOTMAKE], [_AM_SUBST_NOTMAKE([CODE_COVERAGE_RULES])])
+])
-+AC_OUTPUT
diff --git a/umfpack.pc.in b/umfpack.pc.in
new file mode 100644
--- /dev/null
diff --git a/academic/umfpack/umfpack.SlackBuild b/academic/umfpack/umfpack.SlackBuild
index df3c7fddd1..6ced64c4d5 100644
--- a/academic/umfpack/umfpack.SlackBuild
+++ b/academic/umfpack/umfpack.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for UMFPACK
-# Copyright 2013-2016 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2013-2017 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,8 @@ PRGNAM=umfpack
SRCNAM=SuiteSparse
SUBDIR=UMFPACK
VERSION=${VERSION:-5.7.6}
-SRCVER=${SRCVER:-4.5.3}
-BUILD=${BUILD:-1}
+SRCVER=${SRCVER:-4.5.5}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -40,7 +40,7 @@ fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
+PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}
DOCS="README.txt Doc/ChangeLog Doc/License.txt Doc/gpl.txt"
@@ -76,8 +76,8 @@ cd $SRCNAM/$SUBDIR
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .
-patch -p1 < $CWD/patches/autotoolize.diff
-patch -p2 < $CWD/patches/atlas-lib-rename.diff
+patch -p1 < $CWD/patches/autoconfiscate.diff
+patch -p1 < $CWD/patches/atlas-lib-rename.diff
autoreconf -vif
# Avoid rebuilding the docs.
@@ -92,8 +92,6 @@ touch Doc/UMFPACK_UserGuide.pdf
--mandir=/usr/man \
--infodir=/usr/info \
--docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-shared \
- --disable-static \
--disable-dependency-tracking \
--build=$ARCH-slackware-linux \
CFLAGS="$SLKCFLAGS" \
diff --git a/academic/umfpack/umfpack.info b/academic/umfpack/umfpack.info
index 13bdea94b9..6e9507a76e 100644
--- a/academic/umfpack/umfpack.info
+++ b/academic/umfpack/umfpack.info
@@ -1,8 +1,8 @@
PRGNAM="umfpack"
VERSION="5.7.6"
HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
-DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.3.tar.gz"
-MD5SUM="8ec57324585df3c6483ad7f556afccbd"
+DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.5.tar.gz"
+MD5SUM="0a5b38af0016f009409a9606d2f1b555"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="blas suitesparseconfig amd cholmod"