summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-02-11 22:39:04 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-03-06 09:30:22 +0700
commit95008b5649feb6a0244b7852739ec66b9b2d0034 (patch)
treeedcf8703dcd0f6b294b78f9dced0764a17868fca /audio
parenta39c419977add00995983b090907698b0aa168dc (diff)
downloadslackbuilds-95008b5649feb6a0244b7852739ec66b9b2d0034.tar.gz
slackbuilds-95008b5649feb6a0244b7852739ec66b9b2d0034.tar.xz
audio/audtty: Removed (No longer build).
It depends on older version of audacious. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/audtty/README10
-rw-r--r--audio/audtty/audtty.SlackBuild112
-rw-r--r--audio/audtty/audtty.info10
-rw-r--r--audio/audtty/doinst.sh14
-rw-r--r--audio/audtty/patches/01-fix_segfault_in_playlist_creation.patch36
-rw-r--r--audio/audtty/patches/02-fix_possible_overflow.patch22
-rw-r--r--audio/audtty/patches/03-fix_segfault_and_possible_overflow.patch37
-rw-r--r--audio/audtty/patches/04-code_refactoring.patch91
-rw-r--r--audio/audtty/patches/audtty-0.1.12-cc-and-destdir.patch49
-rw-r--r--audio/audtty/slack-desc19
10 files changed, 0 insertions, 400 deletions
diff --git a/audio/audtty/README b/audio/audtty/README
deleted file mode 100644
index 3e51d02ba7..0000000000
--- a/audio/audtty/README
+++ /dev/null
@@ -1,10 +0,0 @@
-audtty is a simple application for controlling Audacious from the command line
-whether locally or remotely with a friendly ncurses interface.
-
-It is designed to make common, simple tasks fast and easy to do.
-It is operated using arrow keys and standard Audacious keys, to make it easy
-and intuitive to learn. It is a fork of xmms-curses.
-
-To run audtty over ssh or on a separete TTY locally download and run:
-http://audtty.alioth.debian.org/audtty/dbus.sh in a terminal on your desktop,
-Once run add ~/.dbus-session to your ~/.bashrc file.
diff --git a/audio/audtty/audtty.SlackBuild b/audio/audtty/audtty.SlackBuild
deleted file mode 100644
index bb7a4f0139..0000000000
--- a/audio/audtty/audtty.SlackBuild
+++ /dev/null
@@ -1,112 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for audtty
-
-# Copyright 2009 Manuel Mantilla, Veracruz, Mexico.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=audtty
-VERSION=${VERSION:-0.1.12}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Add latest patches from git and one fixing DESTDIR from gentoo (adapted)
-for i in $CWD/patches/* ; do patch -p1 < $i ; done
-
-sed -i \
- -e "s|@LIBDIRSUFFIX@|${LIBDIRSUFFIX}|" \
- -e "s|@SLKCFLAGS@|${SLKCFLAGS}|" \
- Makefile.in
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-make install DESTDIR=$PKG
-
-mv $PKG/etc/audtty.conf $PKG/etc/audtty.conf.new
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README ChangeLog COPYING \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/audtty/audtty.info b/audio/audtty/audtty.info
deleted file mode 100644
index 4bd76c682a..0000000000
--- a/audio/audtty/audtty.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="audtty"
-VERSION="0.1.12"
-HOMEPAGE="http://audtty.alioth.debian.org"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/audtty-0.1.12.tar.gz"
-MD5SUM="d14d996c0425748c73bb009f6d78121b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Manuel Mantilla"
-EMAIL="mannynix@megared.net.mx"
diff --git a/audio/audtty/doinst.sh b/audio/audtty/doinst.sh
deleted file mode 100644
index f0fb925c6d..0000000000
--- a/audio/audtty/doinst.sh
+++ /dev/null
@@ -1,14 +0,0 @@
- config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-config etc/audtty.conf.new
diff --git a/audio/audtty/patches/01-fix_segfault_in_playlist_creation.patch b/audio/audtty/patches/01-fix_segfault_in_playlist_creation.patch
deleted file mode 100644
index c0b426c91d..0000000000
--- a/audio/audtty/patches/01-fix_segfault_in_playlist_creation.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 3122210cbe3ccd5e83d1a2d1415d370d46834052 Mon Sep 17 00:00:00 2001
-From: Chris Taylor <chris@code-monkeys.org>
-Date: Fri, 05 Mar 2010 06:09:20 +0000
-Subject: Fix segfault in playlist creation.
-
-Audtty would segfault if buffer length was 0 and ENTER was pressed.
-
-
-Signed-off-by: Chris Taylor <chris@code-monkeys.org>
----
-diff --git a/playlist_create.c b/playlist_create.c
-index 0cd0088..475a494 100644
---- a/playlist_create.c
-+++ b/playlist_create.c
-@@ -48,6 +48,11 @@ void playlist_create( void )
- case ESCAPE:
- return;
- case ENTER:
-+
-+ if(strlen(buffer)==0) {
-+ return;
-+ }
-+ else {
- file=fopen(buffer,"w");
- for(i=0;i<list.length;i++)
- {
-@@ -55,6 +60,7 @@ void playlist_create( void )
- fputs("\n",file);
- }
- fclose(file);
-+ }
- return;
- case KEY_BACKSPACE:
- if (len == 0) break;
---
-cgit v0.8.3.4-115-g1759
diff --git a/audio/audtty/patches/02-fix_possible_overflow.patch b/audio/audtty/patches/02-fix_possible_overflow.patch
deleted file mode 100644
index 2d71ee304f..0000000000
--- a/audio/audtty/patches/02-fix_possible_overflow.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 92bcd204331ba673073acc25c7480cddce1e2b87 Mon Sep 17 00:00:00 2001
-From: Chris Taylor <chris@code-monkeys.org>
-Date: Fri, 05 Mar 2010 06:11:41 +0000
-Subject: Fix possible overflow.
-
-Signed-off-by: Chris Taylor <chris@code-monkeys.org>
----
-diff --git a/playlist_create.c b/playlist_create.c
-index 475a494..f8f84c5 100644
---- a/playlist_create.c
-+++ b/playlist_create.c
-@@ -67,7 +67,7 @@ void playlist_create( void )
- buffer[--len] = '\0';
- break;
- default:
-- if (len == 1025) break;
-+ if (len >= 1024) break;
- if (c < 32) break;
- buffer[len] = c;
- buffer[++len] = '\0';
---
-cgit v0.8.3.4-115-g1759
diff --git a/audio/audtty/patches/03-fix_segfault_and_possible_overflow.patch b/audio/audtty/patches/03-fix_segfault_and_possible_overflow.patch
deleted file mode 100644
index e196954c9b..0000000000
--- a/audio/audtty/patches/03-fix_segfault_and_possible_overflow.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From c688fa3851263dc29075182ffdb1ab83051a7213 Mon Sep 17 00:00:00 2001
-From: Chris Taylor <chris@code-monkeys.org>
-Date: Fri, 05 Mar 2010 06:13:15 +0000
-Subject: Fix segfault and possible overflow.
-
--Fix segfault when opening directory, and the buffer length is 0.
--Fix possible overflow in buffer.
-
-Signed-off-by: Chris Taylor <chris@code-monkeys.org>
----
-diff --git a/browse.c b/browse.c
-index fd06dee..c736e64 100644
---- a/browse.c
-+++ b/browse.c
-@@ -399,16 +399,19 @@ void open_directory( void )
- get_contents();
- return;
- case ENTER:
-+ if(strlen(buffer)==0) return;
-+ else {
- cont.location=g_strdup(buffer);
- g_chdir(buffer);
- get_contents();
-+ }
- return;
- case KEY_BACKSPACE:
- if (len == 0) break;
- buffer[--len] = '\0';
- break;
- default:
-- if (len == 1025) break;
-+ if (len >= 1024) break;
- if (c < 32) break;
- buffer[len] = c;
- buffer[++len] = '\0';
---
-cgit v0.8.3.4-115-g1759
diff --git a/audio/audtty/patches/04-code_refactoring.patch b/audio/audtty/patches/04-code_refactoring.patch
deleted file mode 100644
index 022d68c7c2..0000000000
--- a/audio/audtty/patches/04-code_refactoring.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From ead43f353675d4c8952facf57920ce79533955a6 Mon Sep 17 00:00:00 2001
-From: Chris Taylor <chris@code-monkeys.org>
-Date: Fri, 05 Mar 2010 06:24:05 +0000
-Subject: Code refactoring.
-
--Split browser creation code off into its own object. update_browser.
--If exiting from opening creation use update_browser() to repaint browser.
-
-
-Signed-off-by: Chris Taylor <chris@code-monkeys.org>
----
-diff --git a/browse.c b/browse.c
-index c736e64..232d374 100644
---- a/browse.c
-+++ b/browse.c
-@@ -50,7 +50,7 @@ void add_file(gboolean dir);
- void remove_win( void );
- void display_error(gchar *message, gchar *name, gboolean type);
- void open_directory( void );
--
-+void update_browser(void);
-
- void file_browser(gint height)
- {
-@@ -63,28 +63,15 @@ void file_browser(gint height)
- cont.length = 1;
- cont.first=0;
- cont.pos_height=0;
-- clear();
-+ clear();
- refresh();
--
-+
- browser.location = newwin(1, 0, 0, 0);
- browser.title = newwin(1, 0, 1, 0);
- browser.list = newwin(cont.height, 0, 3, 0);
-
--
-- wcolor_set(browser.location, 1, NULL);
-- wcolor_set(browser.title, 1, NULL);
-- wcolor_set(browser.list, 1, NULL);
--
-- mvwtitledhline(browser.title, 0, "File Browser");
-- wnoutrefresh(browser.title);
-- wnoutrefresh(browser.list);
--
-- doupdate();
--
--
-- get_contents();
-- browser_paint(&cont);
--
-+ update_browser();
-+
- while((c=getch()))
- {
- switch(c)
-@@ -399,7 +386,10 @@ void open_directory( void )
- get_contents();
- return;
- case ENTER:
-- if(strlen(buffer)==0) return;
-+ if(strlen(buffer)==0) {
-+ update_browser();
-+ return;
-+ }
- else {
- cont.location=g_strdup(buffer);
- g_chdir(buffer);
-@@ -429,4 +419,18 @@ void open_directory( void )
- doupdate();
- }
- return;
-+}
-+
-+void update_browser(void)
-+{
-+ wcolor_set(browser.location, 1, NULL);
-+ wcolor_set(browser.title, 1, NULL);
-+ wcolor_set(browser.list, 1, NULL);
-+ mvwtitledhline(browser.title, 0, "File Browser");
-+ wnoutrefresh(browser.title);
-+ wnoutrefresh(browser.list);
-+ doupdate();
-+ get_contents();
-+ browser_paint(&cont);
-+ return;
- }
-\ No newline at end of file
---
-cgit v0.8.3.4-115-g1759
diff --git a/audio/audtty/patches/audtty-0.1.12-cc-and-destdir.patch b/audio/audtty/patches/audtty-0.1.12-cc-and-destdir.patch
deleted file mode 100644
index 7ffdedba08..0000000000
--- a/audio/audtty/patches/audtty-0.1.12-cc-and-destdir.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -Naur audtty-0.1.12.orig/Makefile.in audtty-0.1.12/Makefile.in
---- audtty-0.1.12.orig/Makefile.in 2010-02-28 19:10:48.000000000 +0100
-+++ audtty-0.1.12/Makefile.in 2012-09-15 09:06:34.570080268 +0200
-@@ -2,15 +2,14 @@
- #
- # A fork of xmms-curses
-
--DESTDIR=
- # autoconf is dumb.
--prefix=${DESTDIR}
-+prefix=/usr
- exec_prefix=@prefix@
- bindir=@bindir@
--mandir=@prefix@/share/man/man1
-+mandir=@prefix@/man/man1
- sysconfdir=@sysconfdir@
-
--AUDACIOUS_CFLAGS=@AUDACIOUS_CFLAGS@ -I/usr/include/dbus-1.0
-+AUDACIOUS_CFLAGS=@AUDACIOUS_CFLAGS@ -I/usr/include/dbus-1.0 -I/usr/lib@LIBDIRSUFFIX@/glib-2.0/include -I/usr/include/glib-2.0
-
- SOURCES=main.c curses_printf.c playlist.c playlist_jump.c playlist_addurl.c settings.c connect.c browse.c playlist_create.c
- BINS=$(SOURCES:.c=.o)
-@@ -20,18 +19,18 @@
- all: audtty
-
- audtty: ${BINS}
-- cc -g -O2 -g2 -Wall -Werror -lncursesw -laudclient ${LDFLAGS} -o audtty $(BINS)
-+ $(CC) @SLKCFLAGS@ -Wall ${LDFLAGS} -lncursesw -laudclient -lglib-2.0 -ldbus-glib-1 -lgobject-2.0 -o audtty $(BINS)
-
- .c.o:
-- cc -g -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
-+ $(CC) -g -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
-
- install: audtty
-- mkdir -p ${bindir}
-- install -m 0755 audtty ${bindir}/audtty
-- mkdir -p ${mandir}
-- install -m 0644 audtty.1 ${mandir}/audtty.1
-- mkdir -p ${sysconfdir}
-- install -m 0644 audtty.conf ${sysconfdir}/audtty.conf
-+ mkdir -p $(DESTDIR)${bindir}
-+ install -m 0755 audtty $(DESTDIR)${bindir}/audtty
-+ mkdir -p $(DESTDIR)${mandir}
-+ install -m 0644 audtty.1 $(DESTDIR)${mandir}/audtty.1
-+ mkdir -p $(DESTDIR)${sysconfdir}
-+ install -m 0644 audtty.conf $(DESTDIR)${sysconfdir}/audtty.conf
-
- uninstall:
- rm ${bindir}/audtty || false
diff --git a/audio/audtty/slack-desc b/audio/audtty/slack-desc
deleted file mode 100644
index 6bb2f1d1bb..0000000000
--- a/audio/audtty/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-audtty: audtty (ncurses terminal frontend to the Audacious Media Player)
-audtty:
-audtty: audtty makes it easy to control the Audacious Media Player from the
-audtty: command line whether locally or remotely with a friendly ncurses
-audtty: interface.
-audtty:
-audtty: It is a fork of xmms-curses and is designed to be lightweight and
-audtty: intuitive to use.
-audtty:
-audtty: Homepage: http://audtty.alioth.debian.org
-audtty: