summaryrefslogtreecommitdiffstats
path: root/desktop/fusion-icon
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2021-07-25 20:45:48 -0500
committer Robby Workman <rworkman@slackbuilds.org>2021-07-25 20:45:48 -0500
commitb07ce4cceee97d82623c9384dd633b74b65b8a16 (patch)
treeec94110e25ea2ce0f5253c606b7a4f95d61f91d8 /desktop/fusion-icon
parentf1e0f881e68306c8fc18b68bb2b4ac683fdfd2cc (diff)
downloadslackbuilds-b07ce4cceee97d82623c9384dd633b74b65b8a16.tar.gz
slackbuilds-b07ce4cceee97d82623c9384dd633b74b65b8a16.tar.xz
desktop/fusion-icon: Build with python3 instead of python2
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'desktop/fusion-icon')
-rw-r--r--desktop/fusion-icon/README33
-rw-r--r--desktop/fusion-icon/README.Slackware46
-rw-r--r--desktop/fusion-icon/fusion-icon.SlackBuild8
-rw-r--r--desktop/fusion-icon/fusion-icon.info2
4 files changed, 16 insertions, 73 deletions
diff --git a/desktop/fusion-icon/README b/desktop/fusion-icon/README
index 3e34b0b114..b37096d610 100644
--- a/desktop/fusion-icon/README
+++ b/desktop/fusion-icon/README
@@ -1,24 +1,17 @@
Fusion Icon is a simple system tray applet for starting and controlling
-Compiz Fusion. Upon launch, it will attempt to start Compiz Fusion
-automatically. You may need to select a window decorator if one does not
+Compiz. Upon launch, it will attempt to start Compiz automatically.
+You may need to select a window decorator if one does not
appear.
-PLEASE read the README.Slackware file BEFORE you install any of the
-compiz packages. The install order is listed below but there are
-some important notes you need to be aware of before you install/use
-compiz.
-
For correct installation, build in this order:
- 1. compiz (not available at SBo, see the README.Slackware file)
- 2. compiz-bcop
- 3. protobuf (optional but recommended)
- 4. libcompizconfig
- 5. compiz (optional, see the README.Slackware file)
- 6. compizconfig-python
- 7. ccsm
- 8. compiz-plugins-main
- 9. compiz-plugins-extra (optional)
-10. compiz-plugins-experimental (optional)
-11. emerald (optional)
-12. emerald-themes (optional)
-13. fusion-icon (optional)
+compiz-bcop
+protobuf3 (optional but recommended)
+libcompizconfig
+compizconfig-python
+ccsm
+compiz-plugins-main
+compiz-plugins-extra (optional)
+compiz-plugins-experimental (optional)
+emerald (optional)
+emerald-themes (optional)
+fusion-icon (optional)
diff --git a/desktop/fusion-icon/README.Slackware b/desktop/fusion-icon/README.Slackware
deleted file mode 100644
index cb4f9f8c01..0000000000
--- a/desktop/fusion-icon/README.Slackware
+++ /dev/null
@@ -1,46 +0,0 @@
-1) Slackware still ships the old 0.8.8 release of compiz that was
- released back in 2011. The project has recently been picked up
- and is being actively maintained by the compiz-reloaded team.
- You can still use the 0.8.8 version of the compiz that ships
- with Slackware with the companion packages since there has not been
- any ABI changes to the code. But there is a good chance you will run
- into stabilty issues if you do, so it is HIGHLY recommended you use
- the version of compiz that matches the companion packages. Because
- you will be replacing a stock Slackware package the SlackBuild is
- not hosted at www.slackbuilds.org. You can download the SlackBuild
- from the link below.
-
- https://www.dropbox.com/s/t08cb1u00he4cyo/compiz-0.8.14-SlackBuild.tar.gz
-
- This SlackBuild is based off the 14.2 stock Slackware SlackBuild so you
- shouldn't run into any problems. If you do use this version of compiz you
- will need to blacklist compiz in your /etc/slackpkg/blacklist file to keep
- slackpkg from reverting the package back to 0.8.8
-
-2) Compiz now has basic support for the MATE desktop. You will have to install
- MATE before you install compiz for support. The MATE slackware project
- website is located here https://mateslackbuilds.github.io/
-
-3) The compizconfig-backend-kconfig4 package has been removed from the
- project so if you are upgrading from a previous version you will want
- to remove this package. Also compiz-plugins-unsupported has now been
- renamed to compiz-plugins-experimental so you will need to remove
- compiz-plugins-unsupported before you upgrade to the newest packages.
-
-4) The install order has compiz listed twice. libcompizconfig depends
- on compiz, but compiz has some extra window decorator related features
- that depend on libcompizconfig. So if you want these extra features you
- will have to recompile compiz again AFTER you build and install
- libcompizconfig. This is not required it is just an option if you want
- to do it.
-
-5) After you install compiz and the companion packages you will need to
- launch CCSM and enable "Move", "Resize Window", and "Window Decorations"
- before you start compiz. This way you can manage your windows. After
- you enable those three options you can start compiz and customize to
- your liking.
-
-
-
-
-
diff --git a/desktop/fusion-icon/fusion-icon.SlackBuild b/desktop/fusion-icon/fusion-icon.SlackBuild
index 0f02f63698..962af356a1 100644
--- a/desktop/fusion-icon/fusion-icon.SlackBuild
+++ b/desktop/fusion-icon/fusion-icon.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for fusion-icon
-# Copyright 2016 Matt Dinslage, Springfield, MO
+# Copyright 2021 Matt Dinslage, Springfield, MO
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -79,15 +79,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build install --prefix=/usr --with-qt=4.0 --with-gtk=2.0 --root=$PKG
+python3 setup.py build install --prefix=/usr --with-qt=5.0 --with-gtk=3.0 --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Fix desktop icon to launch qt interface instead of gtk+ which is not supported
-# due to lack of dependencies.
-sed -i 's,Exec=fusion-icon,Exec=/usr/bin/fusion-icon -i qt,g' $TMP/package-fusion-icon/usr/share/applications/fusion-icon.desktop
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING VERSION \
$PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/desktop/fusion-icon/fusion-icon.info b/desktop/fusion-icon/fusion-icon.info
index 0c6c97ff5e..d480d00069 100644
--- a/desktop/fusion-icon/fusion-icon.info
+++ b/desktop/fusion-icon/fusion-icon.info
@@ -1,6 +1,6 @@
PRGNAM="fusion-icon"
VERSION="0.2.4"
-HOMEPAGE="https://github.com/raveit65/fusion-icon"
+HOMEPAGE="https://github.com/compiz-reloaded/fusion-icon"
DOWNLOAD="https://github.com/compiz-reloaded/fusion-icon/releases/download/v0.2.4/fusion-icon-0.2.4.tar.xz"
MD5SUM="cef25857317f94dfdcc4b289e39a7382"
DOWNLOAD_x86_64=""