summaryrefslogtreecommitdiffstats
path: root/desktop/wmii
diff options
context:
space:
mode:
author eroc <eroc@linuxmail.org>2010-05-11 19:44:09 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 19:44:09 +0200
commit40f0fe7514cb187e9f84d6d74626320b9cce5183 (patch)
treea3e37cf7d38c80eeec0947ffad0b3c96c0482489 /desktop/wmii
parentf0786ec7dbca42862d44e65f40630eb317dd55fe (diff)
downloadslackbuilds-40f0fe7514cb187e9f84d6d74626320b9cce5183.tar.gz
slackbuilds-40f0fe7514cb187e9f84d6d74626320b9cce5183.tar.xz
desktop/wmii: Updated for version 3.5.1
Diffstat (limited to 'desktop/wmii')
-rw-r--r--desktop/wmii/README3
-rw-r--r--desktop/wmii/slack-desc10
-rw-r--r--desktop/wmii/wmii.SlackBuild12
-rw-r--r--desktop/wmii/wmii.info2
-rw-r--r--desktop/wmii/xinitrc.wmii4
5 files changed, 20 insertions, 11 deletions
diff --git a/desktop/wmii/README b/desktop/wmii/README
index 709fdc68f3..9d62750f48 100644
--- a/desktop/wmii/README
+++ b/desktop/wmii/README
@@ -7,5 +7,4 @@ with a new tagging approach. Its minimalist philosophy attempts to
not exceed 10.000 lines of code (including all shipped utilities and
libraries), to enforce simplicity and clarity.
-NOTE: It requires libixp and it is a good idea to install dmenu too.
-
+NOTE: This requires libixp and it is a good idea to install dmenu too.
diff --git a/desktop/wmii/slack-desc b/desktop/wmii/slack-desc
index 8411b8f3d5..8aff8ff54e 100644
--- a/desktop/wmii/slack-desc
+++ b/desktop/wmii/slack-desc
@@ -1,4 +1,12 @@
-wmii: wmii - window manager improved 2
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+wmii: wmii (window manager improved 2)
wmii:
wmii: wmii is a dynamic window manager for X11. It supports classic and
wmii: dynamic window management with extended keyboard, mouse, and
diff --git a/desktop/wmii/wmii.SlackBuild b/desktop/wmii/wmii.SlackBuild
index 46ee5e49ad..7e82401fdb 100644
--- a/desktop/wmii/wmii.SlackBuild
+++ b/desktop/wmii/wmii.SlackBuild
@@ -11,7 +11,7 @@ VERSION=3.5.1
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CWD=`pwd`
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -28,7 +28,6 @@ cd $TMP || exit 1
rm -rf $PRGNAM-$VERSION
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM-$VERSION || exit 1
-
chown -R root:root .
chmod -R a-s,u+rw,go-w .
@@ -38,15 +37,18 @@ sed -i s#'CONFPREFIX = ${PREFIX}/etc'#'CONFPREFIX = /etc/X11'# config.mk || exit
sed -i s#'MANPREFIX = ${PREFIX}/share/man'#'MANPREFIX = ${PREFIX}/man'# config.mk || exit 1
# Fix the CFLAGS
sed -i 's/CFLAGS = -Os /CFLAGS += /g' config.mk || exit 1
+
CFLAGS="$SLKCFLAGS" make || exit 1
make install DESTDIR=$PKG || exit 1
-find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
- for i in `find . -type l` ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+ for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/desktop/wmii/wmii.info b/desktop/wmii/wmii.info
index 7b19baf7c5..cb51480f66 100644
--- a/desktop/wmii/wmii.info
+++ b/desktop/wmii/wmii.info
@@ -5,4 +5,4 @@ DOWNLOAD="http://suckless.org/download/wmii-3.5.1.tar.gz"
MD5SUM="26705a7b59945b7d269921b45ac15cdf"
MAINTAINER="eroc"
EMAIL="eroc@linuxmail.org"
-APPROVED="robw810"
+APPROVED="rworkman"
diff --git a/desktop/wmii/xinitrc.wmii b/desktop/wmii/xinitrc.wmii
index 5a06604df1..7e37464916 100644
--- a/desktop/wmii/xinitrc.wmii
+++ b/desktop/wmii/xinitrc.wmii
@@ -3,8 +3,8 @@
userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
-sysresources=/usr/X11R6/lib/X11/xinit/.Xresources
-sysmodmap=/usr/X11R6/lib/X11/xinit/.Xmodmap
+sysresources=/usr/lib/X11/xinit/.Xresources
+sysmodmap=/usr/lib/X11/xinit/.Xmodmap
# merge in defaults and keymaps