summaryrefslogtreecommitdiffstats
path: root/development/acpica
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@liwjatan.at>2010-05-11 22:22:17 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 22:22:17 +0200
commite0de3fc6bfba3fd606cdf5c04198ccfa37ee7d94 (patch)
tree9d92e0a559ab9040ed4716c824f3031567f56169 /development/acpica
parentac8c74ab403e370e63657cd70860b44933e4aefa (diff)
downloadslackbuilds-e0de3fc6bfba3fd606cdf5c04198ccfa37ee7d94.tar.gz
slackbuilds-e0de3fc6bfba3fd606cdf5c04198ccfa37ee7d94.tar.xz
development/acpica: Updated for version 20080829
Diffstat (limited to 'development/acpica')
-rw-r--r--development/acpica/acpica-unix-20060512-buildfixup.patch177
-rw-r--r--development/acpica/acpica.SlackBuild39
-rw-r--r--development/acpica/acpica.info10
-rw-r--r--development/acpica/slack-desc2
4 files changed, 28 insertions, 200 deletions
diff --git a/development/acpica/acpica-unix-20060512-buildfixup.patch b/development/acpica/acpica-unix-20060512-buildfixup.patch
deleted file mode 100644
index 5a08da4f5a..0000000000
--- a/development/acpica/acpica-unix-20060512-buildfixup.patch
+++ /dev/null
@@ -1,177 +0,0 @@
-Patches by Robin H. Johnson <robbat2@gentoo.org> - 2006/05/29
-
-Previously using GCC you had to do make clean between making each of the
-seperate utilities. This was due to the fact that depending on what compiler
-defines were passed, the output was different.
-The following patch makes the output files reflect which utility they are
-compiled for, so they don't conflict, and no make clean is needed.
-
-This patch also adds a top level Makefile to allow quick building of the entire
-package.
-
-Also fixes parallel build issues in compiler/, where the yacc generated data
-might used before it was ready.
-
-diff -Nuar --exclude '*~' acpica-unix-20060512.orig/Makefile acpica-unix-20060512/Makefile
---- acpica-unix-20060512.orig/Makefile 1969-12-31 16:00:00.000000000 -0800
-+++ acpica-unix-20060512/Makefile 2006-05-29 16:28:55.560238471 -0700
-@@ -0,0 +1,31 @@
-+PROGS= compiler/iasl tools/acpiexec/acpiexec tools/acpixtract/acpixtract tools/acpisrc/acpisrc
-+ifndef CFLAGS
-+CFLAGS= -O2 -g
-+endif
-+# warnings always important
-+CFLAGS += -Wall -Wstrict-prototypes
-+
-+all: $(PROGS)
-+
-+iasl: compiler
-+acpiexec: tools/acpiexec
-+acpixtract: tools/acpixtract
-+acpisrc: tools/acpisrc
-+
-+SUBDIRS = $(dir $(PROGS))
-+.PHONY: $(SUBDIRS) all
-+
-+compiler: compiler/iasl
-+tools/acpiexec: tools/acpiexec/acpiexec
-+tools/acpixtract: tools/acpixtract/acpixtract
-+tools/acpisrc: tools/acpisrc/acpisrc
-+
-+
-+$(PROGS):
-+ CFLAGS="$(CFLAGS)" $(MAKE) -C $(dir $(@))
-+
-+clean: clean-subdirs
-+clean-subdirs:
-+ for dir in $(SUBDIRS); do \
-+ $(MAKE) -C $$dir clean; \
-+ done
-diff -Nuar --exclude '*~' acpica-unix-20060512.orig/compiler/Makefile acpica-unix-20060512/compiler/Makefile
---- acpica-unix-20060512.orig/compiler/Makefile 2006-05-12 14:13:31.000000000 -0700
-+++ acpica-unix-20060512/compiler/Makefile 2006-05-29 16:34:25.050744637 -0700
-@@ -87,7 +87,7 @@
- ../osunixxf.c
-
- NOMAN= YES
--CFLAGS+= -Wall -O2 -Wstrict-prototypes -D_LINUX -DACPI_ASL_COMPILER -I../include
-+CFLAGS+= -D_LINUX -DACPI_ASL_COMPILER -I../include
-
- #YACC= yacc
- YACC= bison
-@@ -101,14 +101,22 @@
- #CFLAGS+= -D_USE_BERKELEY_YACC
- #.endif
-
--aslmain : $(patsubst %.c,%.o, $(SRCS))
-- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) \
-- $(LOADLIBES) $(LDLIBS) -o iasl
-+OBJNAME = iasl
-+OBJS= $(patsubst %.c,%.$(OBJNAME).o, $(SRCS))
-+%.$(OBJNAME).o: %.c
-+ $(COMPILE.c) $(OUTPUT_OPTION) $<
-+
-+$(PROG) : $(OBJS)
-+ $(CC) $(LDFLAGS) $(OBJS) \
-+ $(LOADLIBES) $(LDLIBS) -o $(PROG)
-
- CLEANFILES= y.output y.tab.c y.tab.h aslcompiler.y.h \
-- aslcompilerparse.c aslcompilerlex.c iasl
-+ aslcompilerparse.c aslcompilerlex.c $(PROG)
-
--aslcompilerparse.c: aslcompiler.y
-+# force the YACC work to be done before any sources
-+# as they all depend on it.
-+$(SRCS): aslcompiler.y.h
-+aslcompiler.y.h: aslcompiler.y
- ${YACC} ${YFLAGS} aslcompiler.y
- cp y.tab.c aslcompilerparse.c
- cp y.tab.h aslcompiler.y.h
-@@ -117,5 +125,5 @@
- ${LEX} ${LFLAGS} -PAslCompiler -oaslcompilerlex.c aslcompiler.l
-
- clean :
-- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
-+ rm -f $(CLEANFILES) $(OBJS)
-
-diff -Nuar --exclude '*~' acpica-unix-20060512.orig/tools/acpiexec/Makefile acpica-unix-20060512/tools/acpiexec/Makefile
---- acpica-unix-20060512.orig/tools/acpiexec/Makefile 2006-05-12 14:13:43.000000000 -0700
-+++ acpica-unix-20060512/tools/acpiexec/Makefile 2006-05-29 16:33:43.551484557 -0700
-@@ -131,14 +131,19 @@
- ../../osunixxf.c
-
-
--CFLAGS+= -Wall -g -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../include
-+CFLAGS+= -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -I../../include
-
-+OBJNAME = acpiexec
-+OBJS= $(patsubst %.c,%.$(OBJNAME).o, $(SRCS))
-
--acpiexec : $(patsubst %.c,%.o, $(SRCS))
-- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
-+%.$(OBJNAME).o: %.c
-+ $(COMPILE.c) $(OUTPUT_OPTION) $<
-+
-+$(PROG): $(OBJS)
-+ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG)
-
- CLEANFILES= $(PROG)
-
- clean :
-- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
-+ rm -f $(CLEANFILES) $(OBJS)
-
-diff -Nuar --exclude '*~' acpica-unix-20060512.orig/tools/acpisrc/Makefile acpica-unix-20060512/tools/acpisrc/Makefile
---- acpica-unix-20060512.orig/tools/acpisrc/Makefile 2006-05-12 14:13:44.000000000 -0700
-+++ acpica-unix-20060512/tools/acpisrc/Makefile 2006-05-29 16:33:03.300322581 -0700
-@@ -4,14 +4,19 @@
- SRCS= ascase.c asconvrt.c asfile.c asmain.c asremove.c astable.c \
- asutils.c osunixdir.c ../../common/getopt.c
-
--CFLAGS+= -Wall -O2 -D_LINUX -DACPI_APPLICATION -Wstrict-prototypes -I../../include
-+CFLAGS+= -D_LINUX -DACPI_APPLICATION -I../../include
-
-+OBJNAME = acpi_application
-+OBJS= $(patsubst %.c,%.$(OBJNAME).o, $(SRCS))
-
--aslmain : $(patsubst %.c,%.o, $(SRCS))
-- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
-+%.$(OBJNAME).o: %.c
-+ $(COMPILE.c) $(OUTPUT_OPTION) $<
-+
-+$(PROG) : $(OBJS)
-+ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG)
-
- CLEANFILES= $(PROG)
-
- clean :
-- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
-+ rm -f $(CLEANFILES) $(OBJS)
-
-diff -Nuar --exclude '*~' acpica-unix-20060512.orig/tools/acpixtract/Makefile acpica-unix-20060512/tools/acpixtract/Makefile
---- acpica-unix-20060512.orig/tools/acpixtract/Makefile 2006-05-12 14:13:44.000000000 -0700
-+++ acpica-unix-20060512/tools/acpixtract/Makefile 2006-05-29 16:32:50.047281484 -0700
-@@ -3,14 +3,19 @@
- PROG= acpixtract
- SRCS= acpixtract.c
-
--CFLAGS+= -Wall -O2 -D_LINUX -DACPI_APPLICATION -Wstrict-prototypes -I../../include
-+CFLAGS+= -D_LINUX -DACPI_APPLICATION -I../../include
-
-+OBJNAME = acpi_application
-+OBJS= $(patsubst %.c,%.$(OBJNAME).o, $(SRCS))
-
--acpixtract : $(patsubst %.c,%.o, $(SRCS))
-- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
-+%.$(OBJNAME).o: %.c
-+ $(COMPILE.c) $(OUTPUT_OPTION) $<
-+
-+$(PROG) : $(OBJS)
-+ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG)
-
- CLEANFILES= $(PROG)
-
- clean :
-- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
-+ rm -f $(CLEANFILES) $(OBJS)
-
diff --git a/development/acpica/acpica.SlackBuild b/development/acpica/acpica.SlackBuild
index a123b35370..d34021d802 100644
--- a/development/acpica/acpica.SlackBuild
+++ b/development/acpica/acpica.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for acpica
-# Copyright 2008 Heinz Wiesinger <hmwiesinger@gmx.at>
+# Copyright 2008 Heinz Wiesinger <pprkut@liwjatan.at>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=acpica
-VERSION=20080213
+VERSION=20080829
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -37,6 +37,8 @@ if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
fi
set -e
@@ -50,23 +52,26 @@ cd $PRGNAM-unix-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# This is a patch from gentoo, which doesn't change the source
-# but eases the way to build it.
-patch -p1 -i $CWD/acpica-unix-20060512-buildfixup.patch
+cd compiler
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ make MAKEFLAGS="-j1"
+ install -D -m 0755 iasl $PKG/usr/bin/iasl
+ make clean
+cd -
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make
+for i in acpiexec acpisrc acpixtract; do
+ cd tools/$i
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ make
+ install -D -m 0755 $i $PKG/usr/bin/$i
+ make clean
+ cd -
+done
-install -D -m 0755 ./compiler/iasl $PKG/usr/bin/iasl
-install -D -m 0755 ./tools/acpixtract/acpixtract $PKG/usr/bin/acpixtract
-install -D -m 0755 ./tools/acpiexec/acpiexec $PKG/usr/bin/acpiexec
-install -D -m 0755 ./tools/acpisrc/acpisrc $PKG/usr/bin/acpisrc
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a changes.txt README $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/development/acpica/acpica.info b/development/acpica/acpica.info
index 6a6b83521b..d0de987f58 100644
--- a/development/acpica/acpica.info
+++ b/development/acpica/acpica.info
@@ -1,8 +1,8 @@
PRGNAM="acpica"
-VERSION="20080213"
-HOMEPAGE="http://www.acpica.org"
-DOWNLOAD="http://www.acpica.org/download/acpica-unix-20080213.tar.gz"
-MD5SUM="97dc0a043a5b9b76d17277af808e4e26"
+VERSION="20080829"
+HOMEPAGE="http://acpica.org"
+DOWNLOAD="http://acpica.org/download/acpica-unix-20080829.tar.gz"
+MD5SUM="ae9da90dfbc68493a3af0ed7961511b6"
MAINTAINER="ppr:kut"
-EMAIL="HMWiesinger@gmx.at"
+EMAIL="pprkut@liwjatan.at"
APPROVED="rworkman"
diff --git a/development/acpica/slack-desc b/development/acpica/slack-desc
index d250cad70b..586462acd7 100644
--- a/development/acpica/slack-desc
+++ b/development/acpica/slack-desc
@@ -14,6 +14,6 @@ acpica: - acpisrc, a source code conversion tool
acpica: - acpiexec, a user-space AML interpreter
acpica: - acpixtract, convert ascii ACPI tables to binary
acpica:
-acpica: Homepage: http://www.acpica.org
+acpica: Homepage: http://acpica.org
acpica:
acpica: