summaryrefslogtreecommitdiffstats
path: root/development/qt-creator
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2010-05-13 00:25:26 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:25:26 +0200
commit5acf20e2a16a2c5a22481a90c58394b95832286e (patch)
tree9c8f0a40f486bc7cda3b76b3d97ce238255d4efa /development/qt-creator
parent47d63a92821782d9bcdd2a1affc7f3fc73058700 (diff)
downloadslackbuilds-5acf20e2a16a2c5a22481a90c58394b95832286e.tar.gz
slackbuilds-5acf20e2a16a2c5a22481a90c58394b95832286e.tar.xz
development/qt-creator: Updated for version 1.2.1
Diffstat (limited to 'development/qt-creator')
-rw-r--r--development/qt-creator/Makefile.diff11
-rw-r--r--development/qt-creator/README13
-rw-r--r--development/qt-creator/qt-creator.SlackBuild44
-rw-r--r--development/qt-creator/qt-creator.info12
-rw-r--r--development/qt-creator/qt-creator.pro.diff10
-rw-r--r--development/qt-creator/slack-desc8
6 files changed, 47 insertions, 51 deletions
diff --git a/development/qt-creator/Makefile.diff b/development/qt-creator/Makefile.diff
deleted file mode 100644
index bf3740e40b..0000000000
--- a/development/qt-creator/Makefile.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile 2009-05-05 12:04:53.863056970 -0300
-+++ Makefile.new 2009-05-05 12:05:45.556052356 -0300
-@@ -147,7 +147,7 @@
- -$(DEL_DIR) $(INSTALL_ROOT)/share/doc/qtcreator/
-
-
--install: install_subtargets install_qch_docs FORCE
-+install: install_subtargets FORCE
-
- uninstall: uninstall_qch_docs uninstall_subtargets FORCE
-
diff --git a/development/qt-creator/README b/development/qt-creator/README
index fd2915fe60..9a1c270b74 100644
--- a/development/qt-creator/README
+++ b/development/qt-creator/README
@@ -1,10 +1,5 @@
-qt-creator (Cross-Platform Qt IDE)
+qt-creator is a Cross-Platform Qt IDE.
-Qt Creator is a new cross-platform integrated development environment
-(IDE) tailored to the needs of Qt developers.
-
-Note:
-qdoc3 must be installed to build docs (This should be considered a bug).
-If you intend to install docs you have to build qt4 from source applying
-a patch to enable building qdoc3. There is an online version of the
-docs here: http://doc.trolltech.com/qtcreator-1.1/
+The goal of Qt Creator is to provide a cross-platform, complete Integrated
+Development Environment (IDE) to develop Qt projects. It is available for
+the Linux, Mac OS X and Windows platforms.
diff --git a/development/qt-creator/qt-creator.SlackBuild b/development/qt-creator/qt-creator.SlackBuild
index f023e43bb9..430c0d0760 100644
--- a/development/qt-creator/qt-creator.SlackBuild
+++ b/development/qt-creator/qt-creator.SlackBuild
@@ -4,10 +4,10 @@
# Copyright 2009 Andre Barboza
# All rights reserved.
-#
+#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
-#
+#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
@@ -26,23 +26,25 @@
# Modified by the SlackBuilds.org project.
PRGNAM=qt-creator
-VERSION=${VERSION:-1.1.0}
+VERSION=${VERSION:-1.2.1}
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-QTDIR=${QT4DIR:-$QT4DIR}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -60,22 +62,21 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-mkdir build
-cd build
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- qmake-qt4 ../qtcreator.pro
-
- # qdoc3 must be installed to build docs.
- # if you intend to install docs you should patch qt4
- if [ ! -x /usr/lib/qt4/tools/qdoc3/qdoc3 ]
- then
- patch < $CWD/Makefile.diff
- fi
+# qdoc3 must be installed to build docs.
+# if you intent to install docs you should patch qt4
+if [ ! -x $QT4DIR/tools/qdoc3/qdoc3 ]
+then
+ patch -p0 < $CWD/qt-creator.pro.diff
+fi
- make
- make install INSTALL_ROOT=$PKG/usr
-cd -
+# We are intentionally using an in-source build here,
+# because the out-of-source build was causing errors
+qmake \
+ IDE_LIBRARY_BASENAME="lib$LIBDIRSUFFIX" \
+ QMAKE_CXXFLAGS="$SLKCFLAGS" \
+ qtcreator.pro
+make
+make install INSTALL_ROOT=$PKG/usr
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
@@ -98,5 +99,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
-
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/qt-creator/qt-creator.info b/development/qt-creator/qt-creator.info
index 0bc2d8e89a..36eb6f4abd 100644
--- a/development/qt-creator/qt-creator.info
+++ b/development/qt-creator/qt-creator.info
@@ -1,8 +1,10 @@
PRGNAM="qt-creator"
-VERSION="1.1.0"
-HOMEPAGE="http://www.qtsoftware.com/products/developer-tools"
-DOWNLOAD="http://get.qtsoftware.com/qtcreator/qt-creator-1.1.0-src.zip"
-MD5SUM="f0fd01f7c5a1f50c479bed13db2134bf"
+VERSION="1.2.1"
+HOMEPAGE="http://qt.nokia.com/"
+DOWNLOAD="http://get.qt.nokia.com/qtcreator/qt-creator-1.2.1-src.zip"
+MD5SUM="41f044cf567db09153161403fbab4076"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="Andre Barboza"
EMAIL="bmg.andre@gmail.com"
-APPROVED="dsomero"
+APPROVED="dsomero,pprkut"
diff --git a/development/qt-creator/qt-creator.pro.diff b/development/qt-creator/qt-creator.pro.diff
new file mode 100644
index 0000000000..70d3e3db3c
--- /dev/null
+++ b/development/qt-creator/qt-creator.pro.diff
@@ -0,0 +1,10 @@
+--- qtcreator.pro 2009-07-10 09:38:08.000000000 -0300
++++ qtcreator.pro.new 2009-09-08 23:30:48.166867037 -0300
+@@ -5,7 +5,6 @@
+ }
+
+ include(qtcreator.pri)
+-include(doc/doc.pri)
+
+ TEMPLATE = subdirs
+ CONFIG += ordered
diff --git a/development/qt-creator/slack-desc b/development/qt-creator/slack-desc
index ca18ae39e4..0a912bec46 100644
--- a/development/qt-creator/slack-desc
+++ b/development/qt-creator/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
qt-creator: qt-creator (Cross-Platform Qt IDE)
qt-creator:
-qt-creator: Qt Creator is a new cross-platform integrated development environment
-qt-creator: (IDE) tailored to the needs of Qt developers.
+qt-creator: The goal of Qt Creator is to provide a cross-platform, complete
+qt-creator: Integrated Development Environment (IDE) to develop Qt projects.
+qt-creator: It is available for the Linux, Mac OS X and Windows platforms.
qt-creator:
qt-creator:
qt-creator:
qt-creator:
-qt-creator:
-qt-creator: Homepage: http://http://www.qtsoftware.com/products/developer-tools
+qt-creator: Homepage: http://qt.nokia.com/
qt-creator: