summaryrefslogtreecommitdiffstats
path: root/development/setuptools-git
diff options
context:
space:
mode:
author Mikko Värri <vmj@linuxbox.fi>2011-07-15 19:34:29 -0300
committer Robby Workman <rworkman@slackbuilds.org>2011-07-21 22:52:08 -0500
commitc70d16285bf62fab30d0b0d157d185fed794e22a (patch)
treeeb20bc2d6d5bd9ab7920a83213ab2fbe71637496 /development/setuptools-git
parentbc2fd331fc3bb9c4b2d9df6cc1959ac6b4149b6d (diff)
downloadslackbuilds-c70d16285bf62fab30d0b0d157d185fed794e22a.tar.gz
slackbuilds-c70d16285bf62fab30d0b0d157d185fed794e22a.tar.xz
development/setuptools-git: Updated for version 0.4.2 + name change
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'development/setuptools-git')
-rw-r--r--development/setuptools-git/README10
-rw-r--r--development/setuptools-git/setuptools-git.SlackBuild51
-rw-r--r--development/setuptools-git/setuptools-git.info10
-rw-r--r--development/setuptools-git/slack-desc19
4 files changed, 90 insertions, 0 deletions
diff --git a/development/setuptools-git/README b/development/setuptools-git/README
new file mode 100644
index 0000000000..e97deaa02d
--- /dev/null
+++ b/development/setuptools-git/README
@@ -0,0 +1,10 @@
+This is a plugin for setuptools that enables Git integration. Once
+installed, setuptools can be told to include in a module
+distribution all the files tracked by git. This is an alternative
+to explicit inclusion specifications with MANIFEST.in.
+
+This package was formerly known as gitlsfiles. The name change is
+the result of an effort by the setuptools plugin developers to
+provide a uniform naming convention.
+
+This requires pysetuptools.
diff --git a/development/setuptools-git/setuptools-git.SlackBuild b/development/setuptools-git/setuptools-git.SlackBuild
new file mode 100644
index 0000000000..19eabcf865
--- /dev/null
+++ b/development/setuptools-git/setuptools-git.SlackBuild
@@ -0,0 +1,51 @@
+#!/bin/sh
+
+# Slackware build script for setuptools-git
+
+# Written by Mikko Värri (vmj@linuxbox.fi)
+# Public domain.
+
+PRGNAM=setuptools-git
+VERSION=${VERSION:-0.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/setuptools-git/setuptools-git.info b/development/setuptools-git/setuptools-git.info
new file mode 100644
index 0000000000..3bff083f3f
--- /dev/null
+++ b/development/setuptools-git/setuptools-git.info
@@ -0,0 +1,10 @@
+PRGNAM="setuptools-git"
+VERSION="0.4.2"
+HOMEPAGE="http://pypi.python.org/pypi/setuptools-git/"
+DOWNLOAD="http://pypi.python.org/packages/source/s/setuptools-git/setuptools-git-0.4.2.tar.gz"
+MD5SUM="6e2de2238d768f0197f8c041c1f0f5b5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikko Värri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="Erik Hanson,Niels Horn"
diff --git a/development/setuptools-git/slack-desc b/development/setuptools-git/slack-desc
new file mode 100644
index 0000000000..1f335d3cac
--- /dev/null
+++ b/development/setuptools-git/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+setuptools-git: setuptools-git (Setuptools revision control system plugin for Git)
+setuptools-git:
+setuptools-git: This is a plugin for setuptools that enables Git integration. Once
+setuptools-git: installed, setuptools can be told to include in a module
+setuptools-git: distribution all the files tracked by git. This is an alternative
+setuptools-git: to explicit inclusion specifications with MANIFEST.in.
+setuptools-git:
+setuptools-git: This package was formerly known as gitlsfiles. The name change is
+setuptools-git: the result of an effort by the setuptools plugin developers to
+setuptools-git: provide a uniform naming convention.
+setuptools-git: