summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2010-05-11 20:00:29 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:29 +0200
commitcb3f56fc856ec4d1d90ba767eb6a9c7b0ece45b4 (patch)
tree2b79b7888fdbb41f58da45b1e465bcd13fbc18b7 /development
parent7314adb536cdbe92bbfce38da69441d51e6cb524 (diff)
downloadslackbuilds-cb3f56fc856ec4d1d90ba767eb6a9c7b0ece45b4.tar.gz
slackbuilds-cb3f56fc856ec4d1d90ba767eb6a9c7b0ece45b4.tar.xz
development/python-pmw: Added to 12.0 repository
Diffstat (limited to 'development')
-rw-r--r--development/python-pmw/README12
-rw-r--r--development/python-pmw/python-pmw.SlackBuild69
-rw-r--r--development/python-pmw/python-pmw.info8
-rw-r--r--development/python-pmw/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/development/python-pmw/README b/development/python-pmw/README
new file mode 100644
index 0000000000..8363f1840d
--- /dev/null
+++ b/development/python-pmw/README
@@ -0,0 +1,12 @@
+python-pmw (Python Megawidgets, based on top of Tkinter)
+
+It is a toolkit for building high-level compound widgets in Python
+using the Tkinter module. It consists of a set of base classes and
+a library of flexible and extensible megawidgets built on this
+foundation. These megawidgets include notebooks, comboboxes,
+selection widgets, paned widgets, scrolled widgets and dialog
+windows.
+
+The base classes and most megawidgets were written by Greg McFarlane
+(current maintainer) and Peter Munnings. There are also several
+contributed megawidgets.
diff --git a/development/python-pmw/python-pmw.SlackBuild b/development/python-pmw/python-pmw.SlackBuild
new file mode 100644
index 0000000000..db5a51f01f
--- /dev/null
+++ b/development/python-pmw/python-pmw.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for python-pmw
+
+# Copyright 2007 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Exit on most errors
+set -e
+
+PRGNAM=python-pmw
+VERSION=1.3
+SRC_PRGNAM=Pmw
+SRC_SUBDIR=Pmw_1_3
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+PYTHON_DIR="/usr/lib/python2.5/site-packages/"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir -p $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+tar xvf $CWD/$SRC_PRGNAM.$VERSION.tar.gz
+cd src/$SRC_PRGNAM
+chown -R root:root . || true
+chmod -R u+w,go+r-w,a-s .
+
+# Move documentation files
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv README $PKG/usr/doc/$PRGNAM-$VERSION
+mv $SRC_SUBDIR/doc $PKG/usr/doc/$PRGNAM-$VERSION/html
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Manual installation because python setup.py install seems to not be working
+mkdir -p $PKG/$PYTHON_DIR/$SRC_PRGNAM/$SRC_SUBDIR
+cp -a $SRC_SUBDIR/{bin,contrib,demos,lib,tests,__init__.py} \
+ $PKG/$PYTHON_DIR/$SRC_PRGNAM/$SRC_SUBDIR
+cp -a __init__.py Alpha_99_9_example $PKG/$PYTHON_DIR/$SRC_PRGNAM
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/python-pmw/python-pmw.info b/development/python-pmw/python-pmw.info
new file mode 100644
index 0000000000..b6b7a6ab95
--- /dev/null
+++ b/development/python-pmw/python-pmw.info
@@ -0,0 +1,8 @@
+PRGNAM="python-pmw"
+VERSION="1.3"
+HOMEPAGE="http://pmw.sourceforge.net"
+DOWNLOAD="http://downloads.sourceforge.net/pmw/Pmw.1.3.tar.gz"
+MD5SUM="fc9affbcb1b2b86930464350ac2f0a1d"
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="rworkman"
diff --git a/development/python-pmw/slack-desc b/development/python-pmw/slack-desc
new file mode 100644
index 0000000000..666a206e20
--- /dev/null
+++ b/development/python-pmw/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-pmw: python-pmw (Python Megawidgets, based on top of Tkinter)
+python-pmw:
+python-pmw: It is a toolkit for building high-level compound widgets in
+python-pmw: Python using the Tkinter module. It consists of a set of base
+python-pmw: classes and a library of flexible and extensible megawidgets
+python-pmw: built on this foundation. These megawidgets include notebooks,
+python-pmw: comboboxes, selection widgets, paned widgets, scrolled widgets
+python-pmw: and dialog windows.
+python-pmw:
+python-pmw: http://pmw.sourceforge.net/
+python-pmw: