summaryrefslogtreecommitdiffstats
path: root/games/hatari/hatari.SlackBuild
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2020-12-19 01:02:42 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-12-26 16:40:36 +0700
commit8d27c871171d871ce66d72cc108133a6a24a86a8 (patch)
tree6dc34017d458640b29f7903e69129caf984b5aa9 /games/hatari/hatari.SlackBuild
parent2d25130a97c90345053ff5d32b59e43ffabd0637 (diff)
downloadslackbuilds-8d27c871171d871ce66d72cc108133a6a24a86a8.tar.gz
slackbuilds-8d27c871171d871ce66d72cc108133a6a24a86a8.tar.xz
games/hatari: Updated for version 2.3.0.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/hatari/hatari.SlackBuild')
-rw-r--r--games/hatari/hatari.SlackBuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/games/hatari/hatari.SlackBuild b/games/hatari/hatari.SlackBuild
index 35adec40d0..aad63b65a6 100644
--- a/games/hatari/hatari.SlackBuild
+++ b/games/hatari/hatari.SlackBuild
@@ -6,6 +6,11 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20201218 bkw:
+# - update for v2.3.0. Can't build older versions, sorry.
+# - add new dep, python3.
+# - really fix the man pages.
+
# 20200426 bkw:
# - BUILD=2
# - Include support for IPF and CTR images (copy-protected images),
@@ -58,8 +63,8 @@
# - add mime type and auto-associate ST disk images and executables.
PRGNAM=hatari
-VERSION=${VERSION:-2.2.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.3.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -75,6 +80,8 @@ TMP=${TMP-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+# Note: the -O2 here gets overridden by a -O3 that comes later on the
+# command line. Upstream tests with -O3 so it should be fine.
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
@@ -105,9 +112,8 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
# so let's have hatariui use that instead of failing.
patch -p1 < $CWD/hatariui-create-cfg-if-missing.diff
-# man page hadn't been updated since 2014, it says the config file lives
-# in the old ~/.hatari/ location. also fix a few typos and formatting
-# issues.
+# Man pages go in section 6, fix .TH and see-also refs. Also fix a few
+# typos and formatting issues.
patch -p1 < $CWD/manpage.diff
# cmake doesn't support anything like --bindir, --mandir, --docdir. cheat
@@ -118,9 +124,6 @@ sed -i \
-e "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION," \
CMakeLists.txt
-# man pages should be in section 6
-sed -i '/\.TH/s,"1","6",' doc/*.1 doc/fr/*.1 tools/*.1 python-ui/*.1
-
# Hard-code the doc path in the UI (we don't use /usr/share/doc/hatari)
sed -i \
-e "/path *= *path *+/s,=.*,= \"/usr/doc/$PRGNAM-$VERSION/\"," \
@@ -140,16 +143,23 @@ sed -i 's/ncurses\.h/&;readline.h/' cmake/FindReadline.cmake
# and libcapsimage 5.1 doesn't support a couple of typedefs that
# existed in 4.2.
+# 20201218 bkw: the source says '#include <caps/CapsLibAll.h>' but
+# we need <caps5/CapsLibAll.h>.
sed -i \
-e '1i#include <stdint.h>' \
-e 's,CapsLong,int32_t,g' \
-e 's,CapsULong,uint32_t,g' \
+ -e '/#include/s,caps/,caps5/,' \
src/floppy_ipf.c
# 20200427 bkw: upstream actually runs cmake directly in the source
# dir rather than the "mkdir build; cd build; cmake .." stuff from
# our template. I'm going to do it their way.
+# 20201218 bkw: I really should not have to tell cmake to look in
+# /usr/include for the libcapsimage headers, that is *the systemwide
+# default location* for includes, and has been since the 1970s. Grr.
cmake \
+ -DCAPSIMAGE_INCLUDE_DIR=/usr/include \
-DCMAKE_VERBOSE_MAKEFILE=TRUE \
$SDL2OPT \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \