summaryrefslogtreecommitdiffstats
path: root/games/redeclipse/redeclipse.SlackBuild
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+github@gmail.com>2020-01-01 17:16:36 -0700
committer Robby Workman <rworkman@slackbuilds.org>2020-01-03 02:14:21 -0600
commit70fe7981e25a5456019cedaacefc1e47635465c5 (patch)
tree938bc8cc7cfecc544db5b0d89af536e018f22901 /games/redeclipse/redeclipse.SlackBuild
parent1c5a57aebb820f60606323131dba0338fed527d0 (diff)
downloadslackbuilds-70fe7981e25a5456019cedaacefc1e47635465c5.tar.gz
slackbuilds-70fe7981e25a5456019cedaacefc1e47635465c5.tar.xz
games/redeclipes: Update to 2.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/redeclipse/redeclipse.SlackBuild')
-rw-r--r--games/redeclipse/redeclipse.SlackBuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/games/redeclipse/redeclipse.SlackBuild b/games/redeclipse/redeclipse.SlackBuild
index 9fc132f829..9e079e8177 100644
--- a/games/redeclipse/redeclipse.SlackBuild
+++ b/games/redeclipse/redeclipse.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Red Eclipse
-# Copyright 2017 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
+# Copyright 2017-2020 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
# Copyright 2015 Erik Falor USA
# All rights reserved.
#
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=redeclipse
-VERSION=${VERSION:-1.6.0}
+VERSION=${VERSION:-2.0.0}
SRCNAM=base
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,8 +70,8 @@ for SUBMODULE in `cat $CWD/submodules-list`; do
if [ -d data/$SUBMODULE ]; then
rm -r data/$SUBMODULE
fi
- tar xvf $CWD/${SUBMODULE}-${VERSION}.tar.gz
- mv ${SUBMODULE}-${VERSION} data/${SUBMODULE}
+ tar xvf $CWD/${SUBMODULE}-*.tar.gz
+ mv ${SUBMODULE}-* data/${SUBMODULE}
if [ -e data/${SUBMODULE}/.gitmodules ]; then
rm data/${SUBMODULE}/.gitmodules
fi
@@ -84,6 +84,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Try and fix issue with cube2font not installing properly
+# https://github.com/redeclipse/base/issues/988
+sed -i 's/m755 cube2font/&_linux/' src/system-install.mk
+
export CXXFLAGS="$SLKCFLAGS"
make -C src/ client server cube2font
make -C src/ \