summaryrefslogtreecommitdiffstats
path: root/games/tuxnes
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2010-05-12 17:39:38 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 17:39:38 +0200
commitf01fa50fe20f634dcd4165ac3b4023d34c3be3d1 (patch)
tree47dd3c27a06f2865a3c5724cc80267ba51f67ca0 /games/tuxnes
parent83e64ec7fd5c06b56f3af5a0d855576105d21a89 (diff)
downloadslackbuilds-f01fa50fe20f634dcd4165ac3b4023d34c3be3d1.tar.gz
slackbuilds-f01fa50fe20f634dcd4165ac3b4023d34c3be3d1.tar.xz
games/tuxnes: Updated for version 0.75
Diffstat (limited to 'games/tuxnes')
-rw-r--r--games/tuxnes/README.slack644
-rw-r--r--games/tuxnes/gtuxnes.desktop7
-rw-r--r--games/tuxnes/gtuxnes.pngbin0 -> 10558 bytes
-rw-r--r--games/tuxnes/patches/Makefile.patch (renamed from games/tuxnes/Makefile.patch)0
-rw-r--r--games/tuxnes/patches/configure.in.patch (renamed from games/tuxnes/configure.in.patch)0
-rw-r--r--games/tuxnes/patches/emu.c.patch (renamed from games/tuxnes/emu.c.patch)0
-rw-r--r--games/tuxnes/tuxnes.SlackBuild53
7 files changed, 43 insertions, 21 deletions
diff --git a/games/tuxnes/README.slack64 b/games/tuxnes/README.slack64
new file mode 100644
index 0000000000..69546f0ad8
--- /dev/null
+++ b/games/tuxnes/README.slack64
@@ -0,0 +1,4 @@
+Note to Slackware64 users: although tuxnes.SlackBuild won't work on an
+x86_64 processor, you should be able to build tuxnes on a 32-bit Slackware
+system and install the package on a Slackware64 system, provided you also
+install 32-bit compatibility libraries.
diff --git a/games/tuxnes/gtuxnes.desktop b/games/tuxnes/gtuxnes.desktop
new file mode 100644
index 0000000000..812f55430c
--- /dev/null
+++ b/games/tuxnes/gtuxnes.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=GTuxNES
+Exec=gtuxnes
+Type=Application
+Icon=gtuxnes
+GenericName=Emulator Launcher
+Categories=Game;Emulator;
diff --git a/games/tuxnes/gtuxnes.png b/games/tuxnes/gtuxnes.png
new file mode 100644
index 0000000000..8a0be2e828
--- /dev/null
+++ b/games/tuxnes/gtuxnes.png
Binary files differ
diff --git a/games/tuxnes/Makefile.patch b/games/tuxnes/patches/Makefile.patch
index 041bb27927..041bb27927 100644
--- a/games/tuxnes/Makefile.patch
+++ b/games/tuxnes/patches/Makefile.patch
diff --git a/games/tuxnes/configure.in.patch b/games/tuxnes/patches/configure.in.patch
index 38a91de2cb..38a91de2cb 100644
--- a/games/tuxnes/configure.in.patch
+++ b/games/tuxnes/patches/configure.in.patch
diff --git a/games/tuxnes/emu.c.patch b/games/tuxnes/patches/emu.c.patch
index 0b33a7190c..0b33a7190c 100644
--- a/games/tuxnes/emu.c.patch
+++ b/games/tuxnes/patches/emu.c.patch
diff --git a/games/tuxnes/tuxnes.SlackBuild b/games/tuxnes/tuxnes.SlackBuild
index 15c8270c44..a57e343e01 100644
--- a/games/tuxnes/tuxnes.SlackBuild
+++ b/games/tuxnes/tuxnes.SlackBuild
@@ -2,15 +2,14 @@
# Slackware build script for tuxnes
# Written by Kyle Guinn <elyk03@gmail.com>
-# Modified by the SlackBuilds.org project
-
-set -e
+# Updated slightly by B. Watson <yalhcru@gmail.com>, with permission
PRGNAM=tuxnes
VERSION=0.75
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -20,23 +19,33 @@ if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+else
+ cat <<EOF
+$PRGNAM is partly written in x86 assembly language, therefore cannot
+be built on the current architecture of "$ARCH".
+
+Supported ARCH settings are "i486" and "i686".
+EOF
+ exit 1
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# __FUNCTION__ is now a variable instead of a static string/macro in GCC 3.4+.
# Replace __FUNCTION__ with the actual function names where it appears.
-patch -p0 < $CWD/emu.c.patch
+patch -p0 < $CWD/patches/emu.c.patch
# Regenerate the build system so that it will support $CFLAGS.
-patch -p0 < $CWD/configure.in.patch
+patch -p0 < $CWD/patches/configure.in.patch
rm acconfig.h install-sh missing mkinstalldirs
aclocal
autoheader
@@ -48,7 +57,8 @@ CFLAGS="$SLKCFLAGS -fno-strict-aliasing" \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --with-x
+ --with-x \
+ --build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG
@@ -60,31 +70,32 @@ make install-strip DESTDIR=$PKG
VERSION=0.75
if [ -e $CWD/$PRGNAM-$VERSION.tar.gz ]; then
rm -rf $PRGNAM-$VERSION
- tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# Patch the Makefile to support $CFLAGS
- patch -p0 < $CWD/Makefile.patch
+ patch -p0 < $CWD/patches/Makefile.patch
CFLAGS="$SLKCFLAGS" make
- cp gtuxnes $PKG/usr/bin
- chown root:root $PKG/usr/bin/gtuxnes
- chmod 0755 $PKG/usr/bin/gtuxnes
+ install -s -m0755 -oroot -groot $PRGNAM $PKG/usr/bin
+
+ # Icon by Deleket (Jojo Mendoza), downloaded from:
+ # http://www.iconarchive.com/show/gaming-icons-by-deleket/Nintendo-NES-icon.html
+ mkdir -p $PKG/usr/share/pixmaps
+ cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+ mkdir -p $PKG/usr/share/applications
+ cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a AUTHORS CHANGES COPYING INSTALL README TODO \
+ cp -a AUTHORS CHANGES COPYING README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
fi
-)
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
+) || exit 1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS BUGS CHANGES COPYING ChangeLog INSTALL* NEWS README THANKS \
+cp -a AUTHORS BUGS CHANGES COPYING ChangeLog NEWS README THANKS \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild