summaryrefslogtreecommitdiffstats
path: root/games/zoom/zoom.SlackBuild
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2012-12-16 17:42:38 -0500
committer dsomero <xgizzmo@slackbuilds.org>2012-12-23 09:16:19 -0500
commit776358214ba0f1c9ee3a7d80990623fb4de24608 (patch)
tree850208a5486dea41b4cd5953e3867fd946477add /games/zoom/zoom.SlackBuild
parent70d06d7b87d0ff6f7332aa25228475bf4b58ebf6 (diff)
downloadslackbuilds-776358214ba0f1c9ee3a7d80990623fb4de24608.tar.gz
slackbuilds-776358214ba0f1c9ee3a7d80990623fb4de24608.tar.xz
games/zoom: Added (play interactive fiction games)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'games/zoom/zoom.SlackBuild')
-rw-r--r--games/zoom/zoom.SlackBuild101
1 files changed, 101 insertions, 0 deletions
diff --git a/games/zoom/zoom.SlackBuild b/games/zoom/zoom.SlackBuild
new file mode 100644
index 0000000000..c7bd0d5415
--- /dev/null
+++ b/games/zoom/zoom.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/bash
+
+# Slackware build script for zoom
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://sam.zoy.org/wtfpl/ for details.
+
+PRGNAM=zoom
+VERSION=${VERSION:-1.1.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+else
+ SLKCFLAGS="-O2"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Modern Xft doesn't ship a xft-config script, hack the configure script
+# to use pkg-config.
+patch -p1 < $CWD/config_xft.diff
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install-strip DESTDIR=$PKG
+
+# enable antialiasing by default. The comment in the config file
+# doesn't seem to apply (it was written years ago).
+sed -i '/antialias/s,no,yes,' $PKG/usr/share/$PRGNAM/${PRGNAM}rc
+mv $PKG/usr/share/$PRGNAM/${PRGNAM}rc $PKG/usr/share/$PRGNAM/${PRGNAM}rc.new
+
+# If zoom is run with no arguments, it shows a menu of games from its
+# default location. Let's make this the same location inform installs
+# its example games to.
+mkdir -p $PKG/usr/share/zcode
+ln -s ../zcode $PKG/usr/share/$PRGNAM/games
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+rm -f manual/Makefile*
+cp -a \
+ AUTHORS COPYING ChangeLog NEWS README THANKS TODO manual \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/usr/share/pixmaps/
+cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/usr/share/applications/
+cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/man/man1
+sed "s,@VERSION@,$VERSION,g" < $CWD/$PRGNAM.1 | gzip -9c > $PKG/usr/man/man1/$PRGNAM.1.gz
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}