summaryrefslogtreecommitdiffstats
path: root/games/ztools/patches
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2012-12-16 17:42:41 -0500
committer dsomero <xgizzmo@slackbuilds.org>2012-12-23 09:16:20 -0500
commitbacb4b4024a43478bc1fc93003ab77984402e1b8 (patch)
tree3697e04fb7ce194163a9f156d6b2340033600e0b /games/ztools/patches
parent072a0aa9aa699dbd02b3f530ff95b66d0922ce0e (diff)
downloadslackbuilds-bacb4b4024a43478bc1fc93003ab77984402e1b8.tar.gz
slackbuilds-bacb4b4024a43478bc1fc93003ab77984402e1b8.tar.xz
games/ztools: Added (tools for Infocom and other Z-Code story files)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'games/ztools/patches')
-rw-r--r--games/ztools/patches/zcut-compilefix.diff14
-rw-r--r--games/ztools/patches/zcut-floppy_usage.diff24
-rw-r--r--games/ztools/patches/zcut-zversion.diff11
-rw-r--r--games/ztools/patches/zdebugtool-compilefix.diff35
-rw-r--r--games/ztools/patches/ztools-zcheck.diff103
5 files changed, 187 insertions, 0 deletions
diff --git a/games/ztools/patches/zcut-compilefix.diff b/games/ztools/patches/zcut-compilefix.diff
new file mode 100644
index 0000000000..adcee59901
--- /dev/null
+++ b/games/ztools/patches/zcut-compilefix.diff
@@ -0,0 +1,14 @@
+diff -Naur a/zcut12.c b/zcut12.c
+--- a/zcut12.c 2001-07-24 02:20:32.000000000 -0400
++++ b/zcut12.c 2012-11-30 14:28:39.000000000 -0500
+@@ -1534,8 +1534,8 @@
+
+ int disk, n;
+
+- enum tsystem this_type = UNKNOWN;
+- enum tsystem prev_type = UNKNOWN;
++ tsystem this_type = UNKNOWN;
++ tsystem prev_type = UNKNOWN;
+
+ char extension[4], *p;
+
diff --git a/games/ztools/patches/zcut-floppy_usage.diff b/games/ztools/patches/zcut-floppy_usage.diff
new file mode 100644
index 0000000000..1475818ffd
--- /dev/null
+++ b/games/ztools/patches/zcut-floppy_usage.diff
@@ -0,0 +1,24 @@
+diff -Naur a/zcut12.c b/zcut12.c
+--- a/zcut12.c 2001-07-24 02:20:32.000000000 -0400
++++ b/zcut12.c 2012-11-30 14:48:28.000000000 -0500
+@@ -1556,13 +1556,17 @@
+ "- Atari 800/XL/XE disk images [.ATR]\n"
+ "- Commodore 64/128 disk images [.D64]\n"
+ "- Commodore Amiga ADF format (only Deadline so far) [.ADF]\n"
+- "- IBM PC bootable disks (MS-DOS version only)\n"
++ "- IBM PC bootable disks or disk images\n"
+ "- Oric disk images (after conversion through UnMFM) [.DSK]\n"
+ "- any file if the Z-code is stored in one piece\n"
+ "\n"
+ "Usage: zcut input-file-1 [input-file-2...] output-file\n"
+- " zcut drive: output-file");
+-
++#if defined( __MSDOS__) || defined(_WINNT_)
++ " zcut drive: output-file"
++#else
++ " zcut /dev/fd0 output-file"
++#endif
++ );
+ return EXIT_FAILURE;
+
+ }
diff --git a/games/ztools/patches/zcut-zversion.diff b/games/ztools/patches/zcut-zversion.diff
new file mode 100644
index 0000000000..1c736b0629
--- /dev/null
+++ b/games/ztools/patches/zcut-zversion.diff
@@ -0,0 +1,11 @@
+diff -Naur a/zcut12.c b/zcut12.c
+--- a/zcut12.c 2001-07-24 02:20:32.000000000 -0400
++++ b/zcut12.c 2012-11-30 14:58:22.000000000 -0500
+@@ -362,6 +362,7 @@
+ if (hiscore < 900)
+ error ("Could not find story header");
+
++ printf ("Z-Machine version %d\n", (int) GET_BYTE(header,0));
+ printf ("Story file release %d ", (int) GET_WORD(header,2));
+ printf ("serial %c%c%c%c%c%c.\n",
+ isprint (GET_BYTE(header,18)) ? GET_BYTE(header,18) : ' ',
diff --git a/games/ztools/patches/zdebugtool-compilefix.diff b/games/ztools/patches/zdebugtool-compilefix.diff
new file mode 100644
index 0000000000..872eff9b66
--- /dev/null
+++ b/games/ztools/patches/zdebugtool-compilefix.diff
@@ -0,0 +1,35 @@
+diff -Naur a/Makefile b/Makefile
+--- a/Makefile 1992-10-31 21:52:32.000000000 -0500
++++ b/Makefile 2012-12-01 11:02:49.000000000 -0500
+@@ -1,17 +1,9 @@
+-# Makefile for Infocom Debugging Tool
+-# (works with Aztec 5.2a)
+-
+-CFLAGS = -DAMIGA -ms -so -wlc
+-
+ OBJS = alphabet.o check.o decode.o extern.o header.o macros.o main.o \
+ object.o recog.o stuffing.o tree.o vars.o vocab.o
+
+-all: DebugTool
+-
+-DebugTool: $(OBJS)
+- ln -o DebugTool $(OBJS) -lc
++all: zdebugtool
+
++zdebugtool: $(OBJS)
++ $(CC) $(LDFLAGS) -o zdebugtool $(OBJS)
+
+ $(OBJS): frobnitz.h Makefile
+-
+-# (c) 1992 by Paul David Doherty
+diff -Naur a/frobnitz.h b/frobnitz.h
+--- a/frobnitz.h 1993-05-06 17:33:42.000000000 -0400
++++ b/frobnitz.h 2012-12-01 11:03:40.000000000 -0500
+@@ -51,6 +51,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+
+ /*****************************************************************/
diff --git a/games/ztools/patches/ztools-zcheck.diff b/games/ztools/patches/ztools-zcheck.diff
new file mode 100644
index 0000000000..d69c86066e
--- /dev/null
+++ b/games/ztools/patches/ztools-zcheck.diff
@@ -0,0 +1,103 @@
+diff -Naru a/check.1 b/check.1
+--- a/check.1 1998-11-07 10:07:02.000000000 -0500
++++ b/check.1 2012-12-01 10:56:49.000000000 -0500
+@@ -1,18 +1,18 @@
+-.TH "check" 1 "November 1998" "Ztools 7.3.1"
++.TH "zcheck" 1 "November 1998" "Ztools 7.3.1"
+ .SH NAME
+-check \- integrity checker for infocom format story files
++zcheck \- integrity checker for infocom format story files
+ .SH SYNOPSIS
+-.B check
++.B zcheck
+ story-file
+ .RB "[ new-story-file ]"
+ .SH DESCRIPTION
+-.B Check
++.B ZCheck
+ is a program for checking the integrity of Infocom format story files.
+ It can optionally generate a new story file by trimming the original
+ to the optimal length.
+ .SH OPTIONS
+ There are no command-line options for
+-.B check .
++.B zcheck .
+ .LP
+ If a second argument is given,
+ it is treated as the name for the trimmed story file.
+@@ -25,4 +25,4 @@
+ Mark Howell 7 August 1993 howell_ma@movies.enet.dec.com
+ .SH CURRENT MAINTAINER
+ Matthew Russotto russotto@pond.com
+-.
+\ No newline at end of file
++.
+diff -Naru a/infodump.1 b/infodump.1
+--- a/infodump.1 1998-11-07 10:07:36.000000000 -0500
++++ b/infodump.1 2012-12-01 10:56:30.000000000 -0500
+@@ -60,7 +60,7 @@
+ Display symbols from file in object and grammar displays.
+ Use of this option implies -s.
+ .SH SEE ALSO
+-.BR check (1),
++.BR zcheck (1),
+ .BR inforead (1),
+ .BR pix2gif (1),
+ .BR txd (1)
+@@ -68,4 +68,4 @@
+ Mark Howell 28 August 1992 howell_ma@movies.enet.dec.com
+ .SH CURRENT MAINTAINER
+ Matthew Russotto russotto@pond.com
+-.
+\ No newline at end of file
++.
+diff -Naru a/inforead.1 b/inforead.1
+--- a/inforead.1 1998-11-07 10:06:24.000000000 -0500
++++ b/inforead.1 2012-12-01 10:56:26.000000000 -0500
+@@ -29,7 +29,7 @@
+ not part of the ZTools distribution but available at the Interactive
+ Fiction Archive (ftp://ftp.gmd.de/if-archive)
+ .SH SEE ALSO
+-.BR check (1),
++.BR zcheck (1),
+ .BR infodump (1),
+ .BR pix2gif (1),
+ .BR txd (1)
+@@ -37,4 +37,4 @@
+ Mark Howell 13 September 1992 howell_ma@movies.enet.dec.com
+ .SH CURRENT MAINTAINER
+ Matthew Russotto russotto@pond.com (but see NOTES)
+-.
+\ No newline at end of file
++.
+diff -Naru a/pix2gif.1 b/pix2gif.1
+--- a/pix2gif.1 1998-11-07 10:08:22.000000000 -0500
++++ b/pix2gif.1 2012-12-01 10:55:56.000000000 -0500
+@@ -14,7 +14,7 @@
+ You must provide exactly one argument:
+ the name (or path) of an infocom format picture file.
+ .SH SEE ALSO
+-.BR check (1),
++.BR zcheck (1),
+ .BR infodump (1),
+ .BR inforead (1),
+ .BR txd (1)
+@@ -22,4 +22,4 @@
+ Mark Howell 13 September 1992 howell_ma@movies.enet.dec.com
+ .SH CURRENT MAINTAINER
+ Matthew Russotto russotto@pond.com
+-.
+\ No newline at end of file
++.
+diff -Naru a/txd.1 b/txd.1
+--- a/txd.1 1998-11-07 09:57:04.000000000 -0500
++++ b/txd.1 2012-12-01 10:55:59.000000000 -0500
+@@ -43,7 +43,7 @@
+ .B \-S \fIn\fP
+ Dump high strings only, starting at address \fIn\fP
+ .SH SEE ALSO
+-.BR check (1),
++.BR zcheck (1),
+ .BR infodump (1),
+ .BR inforead (1),
+ .BR pix2gif (1)