summaryrefslogtreecommitdiffstats
path: root/libraries/audioread
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-10-08 10:05:04 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-14 10:32:29 +0700
commit1f33e1c2715ed6d151390d1b3530daead4170866 (patch)
tree42e70b67efd4d740b7758fee659f18113ad30aa7 /libraries/audioread
parent34d497637926727bb9c383cf9516dd80ca93beee (diff)
downloadslackbuilds-1f33e1c2715ed6d151390d1b3530daead4170866.tar.gz
slackbuilds-1f33e1c2715ed6d151390d1b3530daead4170866.tar.xz
libraries/audioread: Updated for version 3.0.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/audioread')
-rw-r--r--libraries/audioread/audioread.SlackBuild30
-rw-r--r--libraries/audioread/audioread.info8
2 files changed, 12 insertions, 26 deletions
diff --git a/libraries/audioread/audioread.SlackBuild b/libraries/audioread/audioread.SlackBuild
index bcc78ce2c6..4f51637417 100644
--- a/libraries/audioread/audioread.SlackBuild
+++ b/libraries/audioread/audioread.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for audioread
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -23,10 +23,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20231008 46and2: Updated version, change to pep517 build process.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=audioread
-VERSION=${VERSION:-3.0.0}
+VERSION=${VERSION:-3.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,11 +61,12 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/audioread/audioread.info b/libraries/audioread/audioread.info
index 4d78b949fe..d5a9820f1e 100644
--- a/libraries/audioread/audioread.info
+++ b/libraries/audioread/audioread.info
@@ -1,10 +1,10 @@
PRGNAM="audioread"
-VERSION="3.0.0"
+VERSION="3.0.1"
HOMEPAGE="https://github.com/sampsyo/audioread"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/a/audioread/audioread-3.0.0.tar.gz"
-MD5SUM="0603e560d44fc9dab00d061ae0ff9206"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/a/audioread/audioread-3.0.1.tar.gz"
+MD5SUM="3de844f9c75b97691da85e0f1ec76e90"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"