summaryrefslogtreecommitdiffstats
path: root/libraries/fltk2
diff options
context:
space:
mode:
author Mikhail Zotov <mikhail dot ru at gmail dot com>2010-05-13 00:58:29 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:58:29 +0200
commit245ebd55dd03f5d0c97fba78706fefd2dcd42131 (patch)
treec5e63cac44ffdc89afd874ff3af3bdad351f3624 /libraries/fltk2
parent93beaaf2381c0939e5ca893b2797bcbbe3407aca (diff)
downloadslackbuilds-245ebd55dd03f5d0c97fba78706fefd2dcd42131.tar.gz
slackbuilds-245ebd55dd03f5d0c97fba78706fefd2dcd42131.tar.xz
libraries/fltk2: Added to 13.0 repository
Diffstat (limited to 'libraries/fltk2')
-rw-r--r--libraries/fltk2/README10
-rw-r--r--libraries/fltk2/fltk2.SlackBuild100
-rw-r--r--libraries/fltk2/fltk2.info10
-rw-r--r--libraries/fltk2/slack-desc19
4 files changed, 139 insertions, 0 deletions
diff --git a/libraries/fltk2/README b/libraries/fltk2/README
new file mode 100644
index 0000000000..3aeca38a2c
--- /dev/null
+++ b/libraries/fltk2/README
@@ -0,0 +1,10 @@
+The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd C++
+graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and Microsoft(r)
+Windows(r). It was originally developed by Mr. Bill Spitzak and is currently
+maintained by a small group of developers across the world with a central
+repository in the US.
+
+The build script is for the development branch (version 2.0.x), thus it is
+named "fltk2" to distinguish from the stable one ("fltk") available at
+SlackBuilds.org. Notice that fltk2 does not overwrite any files of fltk;
+thus, it is possible to have both of them in the system if desired.
diff --git a/libraries/fltk2/fltk2.SlackBuild b/libraries/fltk2/fltk2.SlackBuild
new file mode 100644
index 0000000000..1b75ed82c8
--- /dev/null
+++ b/libraries/fltk2/fltk2.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/sh
+
+# Slackware build script for fltk, version 2
+
+# Copyright 2009-2010 Mikhail Zotov <mikhail dot ru@gmail dot com>
+# All rights reserved.
+#
+# The script is based on the build script for FLTK, version 1, by LukenShiro.
+# The script has been fixed by Robby Workman.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=fltk2
+VERSION=2.0.x_r6970
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRC_PRGNAM=fltk
+SRC_VERSION=$(printf $VERSION | tr _ -)
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="CHANGES COPYING CREDITS README README.unix README_fltk1_to_fltk2.txt"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRC_PRGNAM-$SRC_VERSION
+tar xvf $CWD/$SRC_PRGNAM-$SRC_VERSION.tar.bz2
+cd $SRC_PRGNAM-$SRC_VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Fix linking when --libdir=/usr/lib64
+sed -i \
+ -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
+ src/Makefile || exit
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --enable-shared
+
+make
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+# No manpages are installed
+rm -rf $PKG/usr/man
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/fltk2.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/fltk2.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/fltk2/fltk2.info b/libraries/fltk2/fltk2.info
new file mode 100644
index 0000000000..9fa8cf6e0d
--- /dev/null
+++ b/libraries/fltk2/fltk2.info
@@ -0,0 +1,10 @@
+PRGNAM="fltk2"
+VERSION="2.0.x-r6970"
+HOMEPAGE="http://www.fltk.org/"
+DOWNLOAD="http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/snapshots/fltk-2.0.x-r6970.tar.bz2"
+MD5SUM="f78976d0ba1a5c845e14f4df96d580a0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikhail Zotov"
+EMAIL="mikhail dot ru at gmail dot com"
+APPROVED="dsomero"
diff --git a/libraries/fltk2/slack-desc b/libraries/fltk2/slack-desc
new file mode 100644
index 0000000000..beff5e4e5c
--- /dev/null
+++ b/libraries/fltk2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+fltk2: FLTK (Fast Light Tool Kit), version 2
+fltk2:
+fltk2: The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
+fltk2: C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r),
+fltk2: and Microsoft(r) Windows(r). It was originally developed by Mr. Bill
+fltk2: Spitzak and is currently maintained by a small group of developers
+fltk2: across the world with a central repository in the US.
+fltk2:
+fltk2: Homepage: http://www.fltk.org/
+fltk2:
+fltk2: