summaryrefslogtreecommitdiffstats
path: root/libraries/fltk
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2010-05-12 17:40:37 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 17:40:37 +0200
commit32d0ef6178d8c3dc61b63baeb452a19e26b003b0 (patch)
tree4c65bebc39c23775744f22e3c030f64b0da5f824 /libraries/fltk
parent48b1a79a958e3fac4d4817e9937a52ada4113e0e (diff)
downloadslackbuilds-32d0ef6178d8c3dc61b63baeb452a19e26b003b0.tar.gz
slackbuilds-32d0ef6178d8c3dc61b63baeb452a19e26b003b0.tar.xz
libraries/fltk: Updated for version 1.1.9
Diffstat (limited to 'libraries/fltk')
-rw-r--r--libraries/fltk/README4
-rw-r--r--libraries/fltk/fltk.SlackBuild30
-rw-r--r--libraries/fltk/fltk.info2
3 files changed, 25 insertions, 11 deletions
diff --git a/libraries/fltk/README b/libraries/fltk/README
index da8079462e..9917a85291 100644
--- a/libraries/fltk/README
+++ b/libraries/fltk/README
@@ -8,6 +8,6 @@ currently maintained by a small group of developers across
the world with a central repository in the US.
It is compiled with --enable-shared, --enable-threads,
- --enable-xdbe, --enable-xft, --enable-gl and
- --enable-xinerama.
+ --enable-largefile, --enable-xdbe, --enable-xft, --enable-gl
+ and --enable-xinerama.
diff --git a/libraries/fltk/fltk.SlackBuild b/libraries/fltk/fltk.SlackBuild
index 531aab5e77..6bce4e2dc4 100644
--- a/libraries/fltk/fltk.SlackBuild
+++ b/libraries/fltk/fltk.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for fltk
-# Copyright 2006 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2006-2009 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,14 +22,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Exit on most errors
-set -e
-
PRGNAM=fltk
VERSION=1.1.9
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -39,10 +37,17 @@ DOCFILES="ANNOUNCEMENT CHANGES COPYING CREDITS README"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -52,27 +57,36 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+# Fix linking when --libdir=/usr/lib64
+sed -i \
+ -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
+ src/Makefile || exit
+
# --docdir seems to be ignored
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--localstatedir=/var \
--mandir=/usr/man \
--enable-gl \
+ --enable-largefile \
--enable-shared \
--enable-threads \
--enable-xinerama \
--enable-xft \
--enable-xdbe
-
+
make
make install DESTDIR=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man
diff --git a/libraries/fltk/fltk.info b/libraries/fltk/fltk.info
index 2e9cb60dc0..bb7b4aaccb 100644
--- a/libraries/fltk/fltk.info
+++ b/libraries/fltk/fltk.info
@@ -5,4 +5,4 @@ DOWNLOAD="ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/1.1.9/flt
MD5SUM="e146fd264e1001b1313acfd41ef75552"
MAINTAINER="LukenShiro"
EMAIL="lukenshiro@ngi.it"
-APPROVED="Erik Hanson" \ No newline at end of file
+APPROVED="dsomero,michiel"