summaryrefslogtreecommitdiffstats
path: root/libraries/json-py
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2010-05-12 23:30:23 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:30:23 +0200
commit4e44e15c0a4f5dcde23c49743422a1f8ba16f177 (patch)
tree86eed5b2f255ce538c2e6b5c96d664318e706903 /libraries/json-py
parent91e9b6db1b9b6fd0fce1bb27b9b69ea1612a3036 (diff)
downloadslackbuilds-4e44e15c0a4f5dcde23c49743422a1f8ba16f177.tar.gz
slackbuilds-4e44e15c0a4f5dcde23c49743422a1f8ba16f177.tar.xz
libraries/json-py: Added to 12.2 repository
Diffstat (limited to 'libraries/json-py')
-rw-r--r--libraries/json-py/README6
-rw-r--r--libraries/json-py/json-py.SlackBuild80
-rw-r--r--libraries/json-py/json-py.info8
-rw-r--r--libraries/json-py/setup.py13
-rw-r--r--libraries/json-py/slack-desc19
5 files changed, 126 insertions, 0 deletions
diff --git a/libraries/json-py/README b/libraries/json-py/README
new file mode 100644
index 0000000000..4c62e5fa90
--- /dev/null
+++ b/libraries/json-py/README
@@ -0,0 +1,6 @@
+json-py is a simple, pure-python implementation of a JSON (http://json.org)
+reader and writer. JSON is used to exchange data across systems written
+in various languages. It is particularly suited to dynamic languages
+like Python, Javascript, etc. JSON = Javascript Object Notation implies
+it is suitable for AJAX applications that exchange data from servers to
+Javascript applications running on web browser clients.
diff --git a/libraries/json-py/json-py.SlackBuild b/libraries/json-py/json-py.SlackBuild
new file mode 100644
index 0000000000..695a8ea9be
--- /dev/null
+++ b/libraries/json-py/json-py.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+
+# Slackware build script for json-py.
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=json-py
+SRCNAM=json
+VERSION=3.4
+SRCVERSION=3_4
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="license.txt readme.txt"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$SRCVERSION.zip
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+# fix txts permissions
+chmod 644 *.txt
+
+# Add setup.py
+cat $CWD/setup.py > setup.py
+
+python setup.py bdist
+tar zxvf dist/$SRCNAM-$VERSION.linux-i686.tar.gz -C $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/json-py/json-py.info b/libraries/json-py/json-py.info
new file mode 100644
index 0000000000..5340968ce9
--- /dev/null
+++ b/libraries/json-py/json-py.info
@@ -0,0 +1,8 @@
+PRGNAM="json-py"
+VERSION="3.4"
+HOMEPAGE="http://sourceforge.net/projects/json-py/"
+DOWNLOAD="http://downloads.sourceforge.net/sourceforge/json-py/json-py-3_4.zip"
+MD5SUM="921ebfede886a10ff32d6d4b4e216f8f"
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/libraries/json-py/setup.py b/libraries/json-py/setup.py
new file mode 100644
index 0000000000..02f58089ac
--- /dev/null
+++ b/libraries/json-py/setup.py
@@ -0,0 +1,13 @@
+from distutils.core import setup
+
+import json
+
+setup(name="json",
+ version="3.4",
+ description="JSON (http://json.org) reader and writer.",
+ author="Patrick D. Logan",
+ author_email="patrickdlogan@stardecisions.com",
+ url = "http://sourceforge.net/projects/json-py/",
+ py_modules=['json']
+ )
+
diff --git a/libraries/json-py/slack-desc b/libraries/json-py/slack-desc
new file mode 100644
index 0000000000..d8a71b6f31
--- /dev/null
+++ b/libraries/json-py/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+json-py: json-py (pure-python implementation of a JSON)
+json-py:
+json-py: json-py is a simple, pure-python implementation of a JSON
+json-py: (http://json.org) reader and writer.
+json-py:
+json-py:
+json-py:
+json-py:
+json-py:
+json-py:
+json-py: