summaryrefslogtreecommitdiffstats
path: root/libraries/libexif-gtk
diff options
context:
space:
mode:
author Michael Wagner <lapinours@web.de>2010-05-11 19:45:12 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 19:45:12 +0200
commitb1f7bd22a6d08c8266c4807844768c52b3349ae4 (patch)
tree856821fc21923f8b6d90db1b3e8238160db72e6f /libraries/libexif-gtk
parent0477209d06b85cc4a8a4fe25132a5823173eea1e (diff)
downloadslackbuilds-b1f7bd22a6d08c8266c4807844768c52b3349ae4.tar.gz
slackbuilds-b1f7bd22a6d08c8266c4807844768c52b3349ae4.tar.xz
libraries/libexif-gtk: Updated for version 0.3.5
Diffstat (limited to 'libraries/libexif-gtk')
-rw-r--r--libraries/libexif-gtk/README20
-rw-r--r--libraries/libexif-gtk/gtk+-2.12.x-enable-deprecated.patch48
-rw-r--r--libraries/libexif-gtk/libexif-gtk.SlackBuild46
-rw-r--r--libraries/libexif-gtk/libexif-gtk.info4
-rw-r--r--libraries/libexif-gtk/slack-desc8
5 files changed, 93 insertions, 33 deletions
diff --git a/libraries/libexif-gtk/README b/libraries/libexif-gtk/README
index 93932d8d4f..3f05cb9d36 100644
--- a/libraries/libexif-gtk/README
+++ b/libraries/libexif-gtk/README
@@ -1,9 +1,11 @@
-Libexif-gtk (provides GTK+ widgets to display/edit EXIF tags)
-
-Most digital cameras produce EXIF files, which are JPEG files with
-extra tags that contain information about the image. The EXIF library
-allows you to parse an EXIF file and read the data from those tags.
-
-This library provides GTK+ widgets to display/edit EXIF tags.
-
-Homepage: http://libexif.sourceforge.net
+Libexif-gtk (provides GTK+ widgets to display/edit EXIF tags)
+
+Most digital cameras produce EXIF files, which are JPEG files with
+extra tags that contain information about the image. The EXIF library
+allows you to parse an EXIF file and read the data from those tags.
+
+This library provides GTK+ widgets to display/edit EXIF tags.
+
+NOTE: If you are building against gtk+-2.12.x, you will need to uncomment
+ the patch that re-enables deprecated calls. On a stock 12.0 system,
+ this is not an issue, so don't enable the patch.
diff --git a/libraries/libexif-gtk/gtk+-2.12.x-enable-deprecated.patch b/libraries/libexif-gtk/gtk+-2.12.x-enable-deprecated.patch
new file mode 100644
index 0000000000..45c406d548
--- /dev/null
+++ b/libraries/libexif-gtk/gtk+-2.12.x-enable-deprecated.patch
@@ -0,0 +1,48 @@
+diff -urN a/gtk-extensions/Makefile.am b/gtk-extensions/Makefile.am
+--- a/gtk-extensions/Makefile.am 2004-10-17 07:57:31.000000000 -0700
++++ b/gtk-extensions/Makefile.am 2007-10-03 23:28:22.000000000 -0700
+@@ -1,7 +1,6 @@
+ INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/intl \
+- -DGTK_DISABLE_DEPRECATED \
+ $(GTK_CFLAGS)
+
+ noinst_LTLIBRARIES = libgtk-extensions.la
+diff -urN a/gtk-extensions/Makefile.in b/gtk-extensions/Makefile.in
+--- a/gtk-extensions/Makefile.in 2004-10-18 12:13:46.000000000 -0700
++++ b/gtk-extensions/Makefile.in 2007-10-03 23:28:25.000000000 -0700
+@@ -219,7 +219,6 @@
+ INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/intl \
+- -DGTK_DISABLE_DEPRECATED \
+ $(GTK_CFLAGS)
+
+ noinst_LTLIBRARIES = libgtk-extensions.la
+diff -urN a/libexif-gtk/Makefile.am b/libexif-gtk/Makefile.am
+--- a/libexif-gtk/Makefile.am 2004-10-17 06:48:35.000000000 -0700
++++ b/libexif-gtk/Makefile.am 2007-10-03 23:28:52.000000000 -0700
+@@ -3,8 +3,7 @@
+ -I$(top_srcdir)/intl \
+ -I$(top_srcdir)/gtk-extensions \
+ $(LIBEXIF_GTK_CFLAGS) \
+- -DG_LOG_DOMAIN=\"libexif\" \
+- -DGTK_DISABLE_DEPRECATED
++ -DG_LOG_DOMAIN=\"libexif\"
+
+ lib_LTLIBRARIES = libexif-gtk.la
+
+diff -urN a/libexif-gtk/Makefile.in b/libexif-gtk/Makefile.in
+--- a/libexif-gtk/Makefile.in 2004-10-18 12:13:46.000000000 -0700
++++ b/libexif-gtk/Makefile.in 2007-10-03 23:29:02.000000000 -0700
+@@ -251,8 +251,7 @@
+ -I$(top_srcdir)/intl \
+ -I$(top_srcdir)/gtk-extensions \
+ $(LIBEXIF_GTK_CFLAGS) \
+- -DG_LOG_DOMAIN=\"libexif\" \
+- -DGTK_DISABLE_DEPRECATED
++ -DG_LOG_DOMAIN=\"libexif\"
+
+ lib_LTLIBRARIES = libexif-gtk.la
+ libexif_gtkincludedir = $(includedir)/libexif-gtk
diff --git a/libraries/libexif-gtk/libexif-gtk.SlackBuild b/libraries/libexif-gtk/libexif-gtk.SlackBuild
index 56aa58eaec..fa8b72afdd 100644
--- a/libraries/libexif-gtk/libexif-gtk.SlackBuild
+++ b/libraries/libexif-gtk/libexif-gtk.SlackBuild
@@ -1,30 +1,33 @@
#!/bin/sh
-#
+
# Slackware Build Script for libexif-gtk
+
# (C) 2007 Michael Wagner <lapinours@web.de>
-#
-# This program is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by the
-# Free Software Foundation; either version 2 of the License, or (at your
-# option) any later version.
+# All rights reserved.
#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
-# Public License for more details.
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
#
-
-# Modified by the SlackBuild Project
-
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
PRGNAM=libexif-gtk
VERSION=0.3.5
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -47,17 +50,16 @@ cd $PRGNAM-$VERSION || exit 1
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+# Patch to re-enable depreciated calls in gtk+ (only needed for 2.12.x)
+# See gentoo bug #194680
+# patch -p1 -i $CWD/gtk+-2.12.x-enable-deprecated.patch || exit 1
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
--disable-static \
- --disable-rpath \
--program-prefix="" \
- $ARCH-slackware-linux \
|| exit 1
make || exit 1
@@ -66,7 +68,7 @@ make install-strip DESTDIR=$PKG || exit 1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-chmod 644 $PKG/usr/doc/$PRGNAM-$PVERSION/*
+chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/libraries/libexif-gtk/libexif-gtk.info b/libraries/libexif-gtk/libexif-gtk.info
index 76f9428536..b219aeeb14 100644
--- a/libraries/libexif-gtk/libexif-gtk.info
+++ b/libraries/libexif-gtk/libexif-gtk.info
@@ -1,8 +1,8 @@
PRGNAM="libexif-gtk"
VERSION="0.3.5"
HOMEPAGE="http://libexif.sourceforge.net"
-DOWNLOAD="http://dl.sourceforge.net/libexif/libexif-gtk-0.3.5.tar.bz2"
+DOWNLOAD="http://downloads.sourceforge.net/libexif/libexif-gtk-0.3.5.tar.bz2"
MD5SUM="0ecdba41f3e0f20a11b8555bd2dd2a07"
MAINTAINER="Michael Wagner"
EMAIL="lapinours@web.de"
-APPROVED="BP{k}" \ No newline at end of file
+APPROVED="rworkman"
diff --git a/libraries/libexif-gtk/slack-desc b/libraries/libexif-gtk/slack-desc
index 78980fdae3..9270981183 100644
--- a/libraries/libexif-gtk/slack-desc
+++ b/libraries/libexif-gtk/slack-desc
@@ -1,3 +1,11 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
libexif-gtk: libexif-gtk (provides GTK+ widgets to display/edit EXIF tags)
libexif-gtk:
libexif-gtk: Most digital cameras produce EXIF files, which are JPEG files with