summaryrefslogtreecommitdiffstats
path: root/libraries/musicbrainzngs
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-01-07 07:34:16 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-01-07 11:14:01 -0600
commit1668891aa1912726b3cb028d2d868f0dde3bc3d0 (patch)
tree21a1eac29a636537c35a2a2b9b3227d3add427fe /libraries/musicbrainzngs
parente9c1aabb81983b611f0f0939b8a9f045d4c6c0e3 (diff)
downloadslackbuilds-1668891aa1912726b3cb028d2d868f0dde3bc3d0.tar.gz
slackbuilds-1668891aa1912726b3cb028d2d868f0dde3bc3d0.tar.xz
libraries/musicbrainzngs: Added (Python bindings for musicbrainz).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/musicbrainzngs')
-rw-r--r--libraries/musicbrainzngs/README4
-rw-r--r--libraries/musicbrainzngs/musicbrainzngs.SlackBuild93
-rw-r--r--libraries/musicbrainzngs/musicbrainzngs.info10
-rw-r--r--libraries/musicbrainzngs/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/libraries/musicbrainzngs/README b/libraries/musicbrainzngs/README
new file mode 100644
index 0000000000..fc2de8b065
--- /dev/null
+++ b/libraries/musicbrainzngs/README
@@ -0,0 +1,4 @@
+Python bindings for musicbrainz NGS webservice.
+
+This library implements webservice bindings for the Musicbrainz
+NGS site, also known as /ws/2.
diff --git a/libraries/musicbrainzngs/musicbrainzngs.SlackBuild b/libraries/musicbrainzngs/musicbrainzngs.SlackBuild
new file mode 100644
index 0000000000..16dc1b5aba
--- /dev/null
+++ b/libraries/musicbrainzngs/musicbrainzngs.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for MusicBrainz-ngs
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=musicbrainzngs
+VERSION=${VERSION:-0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md PKG-INFO COPYING docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/musicbrainzngs/musicbrainzngs.info b/libraries/musicbrainzngs/musicbrainzngs.info
new file mode 100644
index 0000000000..c01cebb748
--- /dev/null
+++ b/libraries/musicbrainzngs/musicbrainzngs.info
@@ -0,0 +1,10 @@
+PRGNAM="musicbrainzngs"
+VERSION="0.4"
+HOMEPAGE="https://github.com/alastair/python-musicbrainzngs"
+DOWNLOAD="https://pypi.python.org/packages/source/m/musicbrainzngs/musicbrainzngs-0.4.tar.gz"
+MD5SUM="ec4323fa1ad4938f9376496bc8c27b05"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/musicbrainzngs/slack-desc b/libraries/musicbrainzngs/slack-desc
new file mode 100644
index 0000000000..5734dee597
--- /dev/null
+++ b/libraries/musicbrainzngs/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+musicbrainzngs: musicbrainzngs (Python bindings for musicbrainz NGS webservice)
+musicbrainzngs:
+musicbrainzngs: Musicbrainz NGS bindings
+musicbrainzngs:
+musicbrainzngs: This library implements webservice bindings for the
+musicbrainzngs: Musicbrainz NGS site, also known as /ws/2.
+musicbrainzngs:
+musicbrainzngs:
+musicbrainzngs:
+musicbrainzngs: Homeproject : https://github.com/alastair/python-musicbrainzngs
+musicbrainzngs: