summaryrefslogtreecommitdiffstats
path: root/libraries/nspr
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2012-08-28 23:20:23 -0500
committer Robby Workman <rworkman@slackbuilds.org>2012-08-28 23:20:23 -0500
commitbe30601be215f7fc06795598f4ba52fd6a1095b6 (patch)
tree4f2a35c3527a30f3215a7c7aa7954aa202cbfd57 /libraries/nspr
parent20eb7c439fdec6492ac39971df38b9086d07f7e6 (diff)
downloadslackbuilds-be30601be215f7fc06795598f4ba52fd6a1095b6.tar.gz
slackbuilds-be30601be215f7fc06795598f4ba52fd6a1095b6.tar.xz
libraries/nspr: Removed (part of mozilla-nss package in Slackware)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/nspr')
-rw-r--r--libraries/nspr/README3
-rw-r--r--libraries/nspr/mozilla-nspr.pc.in10
-rw-r--r--libraries/nspr/nspr.SlackBuild126
-rw-r--r--libraries/nspr/nspr.info10
-rw-r--r--libraries/nspr/slack-desc19
5 files changed, 0 insertions, 168 deletions
diff --git a/libraries/nspr/README b/libraries/nspr/README
deleted file mode 100644
index 0795d394e7..0000000000
--- a/libraries/nspr/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Netscape Portable Runtime (NSPR) provides a platform-neutral API for
-system level and libc like functions. The API is used in the Mozilla
-clients and many of Red Hat's, Sun's, and other software offerings.
diff --git a/libraries/nspr/mozilla-nspr.pc.in b/libraries/nspr/mozilla-nspr.pc.in
deleted file mode 100644
index 1d8f4a0cad..0000000000
--- a/libraries/nspr/mozilla-nspr.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
-prefix=%prefix%
-exec_prefix=%exec_prefix%
-libdir=%libdir%
-includedir=%includedir%
-
-Name: NSPR
-Description: The Netscape Portable Runtime
-Version: %NSPR_VERSION%
-Libs: %FULL_NSPR_LIBS%
-Cflags: %FULL_NSPR_CFLAGS%
diff --git a/libraries/nspr/nspr.SlackBuild b/libraries/nspr/nspr.SlackBuild
deleted file mode 100644
index 6417781359..0000000000
--- a/libraries/nspr/nspr.SlackBuild
+++ /dev/null
@@ -1,126 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for nspr
-
-# Copyright 2011 Robby Workman, Northport, Alabama, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Thanks to the Arch folks, and in particular the nspr PKGBUILD author, for
-# some helpful snippets in here :)
-
-PRGNAM=nspr
-VERSION=${VERSION:-4.8.9}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- extra_flags="--enable-64bit"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-sed -e 's/\$(MKSHLIB) \$(OBJS)/\$(MKSHLIB) \$(LDFLAGS) \$(OBJS)/g' \
- -i mozilla/nsprpub/config/rules.mk
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./mozilla/nsprpub/configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --includedir=/usr/include/nspr \
- --enable-optimize \
- --disable-debug \
- --build=$ARCH-slackware-linux \
- ${extra_flags}
-
-make
-make install DESTDIR=$PKG
-
-NSPR_LIBS=$(./config/nspr-config --libs)
-NSPR_CFLAGS=$(./config/nspr-config --cflags)
-NSPR_VERSION=$(./config/nspr-config --version)
-
-mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
-sed $CWD/mozilla-nspr.pc.in \
- -e "s,%libdir%,/usr/lib${LIBDIRSUFFIX}," \
- -e "s,%prefix%,/usr," \
- -e "s,%exec_prefix%,/usr/bin," \
- -e "s,%includedir%,/usr/include/nspr," \
- -e "s,%NSPR_VERSION%,${NSPR_VERSION}," \
- -e "s,%FULL_NSPR_LIBS%,${NSPR_LIBS}," \
- -e "s,%FULL_NSPR_CFLAGS%,${NSPR_CFLAGS}," \
- > "$PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig/mozilla-nspr.pc"
-
-# Fix permissions on static libraries
-chmod 0644 $PKG/usr/lib${LIBDIRSUFFIX}/*.a
-
-# We don't need this stuff:
-rm -rf $PKG/usr/include/nspr/md $PKG/usr/bin/prerr* $PKG/usr/bin/compile*
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/nspr/nspr.info b/libraries/nspr/nspr.info
deleted file mode 100644
index bcf969b164..0000000000
--- a/libraries/nspr/nspr.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="nspr"
-VERSION="4.8.9"
-HOMEPAGE="https://www.mozilla.org/projects/nspr/"
-DOWNLOAD="https://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v4.8.9/src/nspr-4.8.9.tar.gz"
-MD5SUM="60770d45dc08c0f181b22cdfce5be3e8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Robby Workman"
-EMAIL="rworkman@slackbuilds.org"
diff --git a/libraries/nspr/slack-desc b/libraries/nspr/slack-desc
deleted file mode 100644
index 0b64391d52..0000000000
--- a/libraries/nspr/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-nspr: nspr (Netscape Portable Runtime)
-nspr:
-nspr: Netscape Portable Runtime (NSPR) provides a platform-neutral API for
-nspr: system level and libc like functions. The API is used in the Mozilla
-nspr: clients and many of Red Hat's, Sun's, and other software offerings.
-nspr:
-nspr: Homepage: https://www.mozilla.org/projects/nspr/
-nspr:
-nspr:
-nspr:
-nspr: