summaryrefslogtreecommitdiffstats
path: root/libraries/pyacoustid
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-01-20 12:06:54 +0100
committer Erik Hanson <erik@slackbuilds.org>2014-01-29 23:20:27 -0600
commit42ea906b287d4d9ea5a36808b1ff57526d56b5b2 (patch)
tree2687c2a8a3d44bf9658332b00de6fd4f03e00a13 /libraries/pyacoustid
parent40024ce0bc04101dc40c72e0d24f133a3e44a5cf (diff)
downloadslackbuilds-42ea906b287d4d9ea5a36808b1ff57526d56b5b2.tar.gz
slackbuilds-42ea906b287d4d9ea5a36808b1ff57526d56b5b2.tar.xz
libraries/pyacoustid: Added (acoustic fingerprinting).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/pyacoustid')
-rw-r--r--libraries/pyacoustid/README5
-rw-r--r--libraries/pyacoustid/pyacoustid.SlackBuild89
-rw-r--r--libraries/pyacoustid/pyacoustid.info10
-rw-r--r--libraries/pyacoustid/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/libraries/pyacoustid/README b/libraries/pyacoustid/README
new file mode 100644
index 0000000000..97d4973372
--- /dev/null
+++ b/libraries/pyacoustid/README
@@ -0,0 +1,5 @@
+Chromaprint and its associated Acoustid Web service make up a
+high-quality, open-source acoustic fingerprinting system.
+This package provides Python bindings for both the fingerprinting
+algorithm library, which is written in C but portable, and the Web
+service, which provides fingerprint lookups.
diff --git a/libraries/pyacoustid/pyacoustid.SlackBuild b/libraries/pyacoustid/pyacoustid.SlackBuild
new file mode 100644
index 0000000000..b40edf5f64
--- /dev/null
+++ b/libraries/pyacoustid/pyacoustid.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for pyacoustid
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyacoustid
+VERSION=${VERSION:-1.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+PYTHON=python
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+$PYTHON setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.rst PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyacoustid/pyacoustid.info b/libraries/pyacoustid/pyacoustid.info
new file mode 100644
index 0000000000..b31ac51a80
--- /dev/null
+++ b/libraries/pyacoustid/pyacoustid.info
@@ -0,0 +1,10 @@
+PRGNAM="pyacoustid"
+VERSION="1.0.0"
+HOMEPAGE="https://github.com/sampsyo/pyacoustid"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyacoustid/pyacoustid-1.0.0.tar.gz"
+MD5SUM="8c9bb988903b373f78ba4386a75b962f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools audioread"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/pyacoustid/slack-desc b/libraries/pyacoustid/slack-desc
new file mode 100644
index 0000000000..2d08979f51
--- /dev/null
+++ b/libraries/pyacoustid/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyacoustid: pyacoustid (Chromaprint acoustic fingerprinting and the Acoustid API)
+pyacoustid:
+pyacoustid: Chromaprint and its associated Acoustid Web service make up a
+pyacoustid: high-quality, open-source acoustic fingerprinting system.
+pyacoustid: This package provides Python bindings for both the fingerprinting
+pyacoustid: algorithm library, which is written in C but portable, and
+pyacoustid: the Web service, which provides fingerprint lookups.
+pyacoustid:
+pyacoustid: homepage: https://github.com/sampsyo/pyacoustid
+pyacoustid:
+pyacoustid: