summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author ArTourter <artourter@gmail.com>2022-03-09 12:11:45 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 21:29:27 +0700
commit5ec7152f67c7f52d66f957392809ca2b875051a0 (patch)
tree47855a8e92df5ae34e40812a8797aebc5d37a289 /libraries
parent425f779b3280ed416e6f3cdab7bef93c2d77f648 (diff)
downloadslackbuilds-5ec7152f67c7f52d66f957392809ca2b875051a0.tar.gz
slackbuilds-5ec7152f67c7f52d66f957392809ca2b875051a0.tar.xz
python/python3-nltk: renamed from libraries/ntlk
Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/nltk/README10
-rw-r--r--libraries/nltk/nltk.SlackBuild86
-rw-r--r--libraries/nltk/nltk.info10
-rw-r--r--libraries/nltk/slack-desc19
4 files changed, 0 insertions, 125 deletions
diff --git a/libraries/nltk/README b/libraries/nltk/README
deleted file mode 100644
index 8d8102f681..0000000000
--- a/libraries/nltk/README
+++ /dev/null
@@ -1,10 +0,0 @@
-Open source Python modules, linguistic data and documentation for research and
-development in natural language processing, supporting dozens of NLP tasks,
-with distributions for Windows, Mac OSX and Linux.
-
-NLTK comes with many corpora, toy grammars, trained models, etc. A complete
-list is posted at: http://nltk.org/nltk_data/. To retrieve all the data, use
-"python3 -m nltk.downloader all". To ensure system wideinstallation, you can
-run the command "python3 -m nltk.downloader -d /usr/share/nltk_data all" as
-root. Note that the 'regex' package, also available on SBo, is required to run
-this command.
diff --git a/libraries/nltk/nltk.SlackBuild b/libraries/nltk/nltk.SlackBuild
deleted file mode 100644
index 90915519ad..0000000000
--- a/libraries/nltk/nltk.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for nltk.
-#
-# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2015-2022 Gregory J. L. Tourte <artourter@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=nltk
-VERSION=${VERSION:-3.7}
-SRCVER=$VERSION
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="AUTHORS.md ChangeLog CONTRIBUTING.md LICENSE.txt PKG-INFO README.md RELEASE-HOWTO.txt SECURITY.md"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$SRCVER
-unzip $CWD/$PRGNAM-$VERSION.zip
-cd $PRGNAM-$SRCVER
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/nltk/nltk.info b/libraries/nltk/nltk.info
deleted file mode 100644
index d83ef645ef..0000000000
--- a/libraries/nltk/nltk.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="nltk"
-VERSION="3.7"
-HOMEPAGE="http://www.nltk.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/n/nltk/nltk-3.7.zip"
-MD5SUM="fbb8e6fce2d614b65bacfeb9880bcb44"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="regex"
-MAINTAINER="ArTourter"
-EMAIL="artourter@gmail.com"
diff --git a/libraries/nltk/slack-desc b/libraries/nltk/slack-desc
deleted file mode 100644
index 06e2f0f126..0000000000
--- a/libraries/nltk/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-nltk: nltk (Natural Language ToolKit)
-nltk:
-nltk: Open source Python modules, linguistic data and documentation for
-nltk: research and development in natural language processing, supporting
-nltk: dozens of NLP tasks, with distributions for Windows, Mac OSX and
-nltk: Linux.
-nltk:
-nltk:
-nltk:
-nltk:
-nltk: